summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-19 13:42:58 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-19 13:42:58 +0000
commit1533a1928d459342759fd0907a087f054f560979 (patch)
tree0f4da192d6e701dd7cd9231314a00f0add087e74 /app-shells
parentStable on x86, bug #170634. (diff)
downloadgentoo-2-1533a1928d459342759fd0907a087f054f560979.tar.gz
gentoo-2-1533a1928d459342759fd0907a087f054f560979.tar.bz2
gentoo-2-1533a1928d459342759fd0907a087f054f560979.zip
always statically link libedit incase dash is used as /bin/sh
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/dash-0.5.3.7-r1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/app-shells/dash/dash-0.5.3.7-r1.ebuild b/app-shells/dash/dash-0.5.3.7-r1.ebuild
index 4c793cc44ee2..052f790278a6 100644
--- a/app-shells/dash/dash-0.5.3.7-r1.ebuild
+++ b/app-shells/dash/dash-0.5.3.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7-r1.ebuild,v 1.1 2007/05/19 09:31:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7-r1.ebuild,v 1.2 2007/05/19 13:42:58 uberlord Exp $
inherit autotools eutils flag-o-matic toolchain-funcs
@@ -24,19 +24,28 @@ DEPEND="libedit? ( dev-libs/libedit )"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if use static && use libedit ; then
+ eerror "You cannot build dash with both static and libedit USE flags"
+ die "You cannot build dash with both static and libedit USE flags"
+ fi
+}
+
src_unpack() {
unpack ${A}
+
epatch "${WORKDIR}/${DEB_PF}".diff
cd "${S}"
- local f=
- for f in debian/diff/* ; do
- epatch "${f}"
- done
+ epatch debian/diff/*
# Below patch sorts the builtincmd structure correctly when LC_ALL isn't C
epatch "${FILESDIR}/${MY_P}"-sort-locale.patch
+ # Always statically link libedit in to ensure we always boot if it changes
+ # which it has done in the past.
+ sed -i -e 's/-ledit/-lncurses -Wl,-Bstatic -ledit -Wl,-Bdynamic/g' configure.ac || die
+
# May as well, as the debian patches force this anyway
eautoreconf
}