summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-01-22 11:54:41 +0000
committerFabian Groffen <grobian@gentoo.org>2010-01-22 11:54:41 +0000
commit0fd651c18c9b70768c53b24f06b4028545373570 (patch)
tree373c7ff05a6d8b03ff43e528f3cdf680f63c4909 /app-shells
parentAdding dlopen.patch from Alexandre Rostovtsev in bug 300836 to fix link failu... (diff)
downloadgentoo-2-0fd651c18c9b70768c53b24f06b4028545373570.tar.gz
gentoo-2-0fd651c18c9b70768c53b24f06b4028545373570.tar.bz2
gentoo-2-0fd651c18c9b70768c53b24f06b4028545373570.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/ChangeLog9
-rw-r--r--app-shells/tcsh/tcsh-6.17.ebuild91
2 files changed, 98 insertions, 2 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index 5c485dd9bc5c..e9c993200d45 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/tcsh
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.95 2009/09/30 20:13:37 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.96 2010/01/22 11:54:41 grobian Exp $
+
+*tcsh-6.17 (22 Jan 2010)
+
+ 22 Jan 2010; Fabian Groffen <grobian@gentoo.org> +tcsh-6.17.ebuild:
+ Version bump
30 Sep 2009; Fabian Groffen <grobian@gentoo.org> tcsh-6.16.ebuild:
Merge Prefix changes, no differences in functionality or behaviour
diff --git a/app-shells/tcsh/tcsh-6.17.ebuild b/app-shells/tcsh/tcsh-6.17.ebuild
new file mode 100644
index 000000000000..82a6f6b71885
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.17.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.17.ebuild,v 1.1 2010/01/22 11:54:41 grobian Exp $
+
+inherit eutils flag-o-matic autotools prefix
+
+CONFVER="1.8"
+
+MY_P="${P}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+ http://www.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="perl catalogs"
+RESTRICT="test"
+
+# we need gettext because we run autoconf
+DEPEND=">=sys-libs/ncurses-5.1
+ sys-devel/gettext
+ perl? ( dev-lang/perl )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${MY_P/17/14}"-debian-dircolors.patch # bug #120792
+ epatch "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
+ epatch "${FILESDIR}"/${PN}-6.14-use-ncurses.patch
+ eautoreconf
+
+ if use catalogs ; then
+ einfo "enabling NLS catalogs support..."
+ sed -i -e "s/#undef NLS_CATALOGS/#define NLS_CATALOGS/" \
+ config_f.h || die
+ eend $?
+ fi
+
+ # unify ECHO behaviour
+ echo "#undef ECHO_STYLE" >> config_f.h
+ echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
+
+ eprefixify "${CONFDIR}"/*
+ # activate the right default PATH
+ if [[ -z ${EPREFIX} ]] ; then
+ sed -i \
+ -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+ "${CONFDIR}"/csh.login || die
+ else
+ sed -i \
+ -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+ "${CONFDIR}"/csh.login || die
+ fi
+}
+
+src_compile() {
+ # make tcsh look and live along the lines of the prefix
+ append-flags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-flags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-flags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-flags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-flags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+ econf --prefix="${EPREFIX:-/}" || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man || die
+
+ if use perl ; then
+ perl tcsh.man2html tcsh.man || die
+ dohtml tcsh.html/*.html
+ fi
+
+ insinto /etc
+ doins \
+ "${CONFDIR}"/csh.cshrc \
+ "${CONFDIR}"/csh.login
+
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym /bin/tcsh /bin/csh
+}