summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-02-02 22:22:54 +0000
committerTorsten Veller <tove@gentoo.org>2008-02-02 22:22:54 +0000
commit7474937b022b82e5f0ddbc1b14cde1481b5d471b (patch)
treef2880c1d650c43e8ae9144ccbc70f276327bb6ff /app-shells/zsh
parentadding patch (by redhat) for CVE-2007-{4770,4771} per bug #208001 for 3.6 ser... (diff)
downloadgentoo-2-7474937b022b82e5f0ddbc1b14cde1481b5d471b.tar.gz
gentoo-2-7474937b022b82e5f0ddbc1b14cde1481b5d471b.tar.bz2
gentoo-2-7474937b022b82e5f0ddbc1b14cde1481b5d471b.zip
Version bump. Removed pkg_preinst and parts of pkg_postinst. Fixed cap useflag. Tests and static linking need more testing.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog8
-rw-r--r--app-shells/zsh/zsh-4.3.5.ebuild150
2 files changed, 157 insertions, 1 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 3e895d8b8b1b..45428539b093 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.129 2008/01/08 14:59:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.130 2008/02/02 22:22:54 tove Exp $
+
+*zsh-4.3.5 (02 Feb 2008)
+
+ 02 Feb 2008; Torsten Veller <tove@gentoo.org> +zsh-4.3.5.ebuild:
+ Version bump. Removed pkg_preinst and parts of pkg_postinst.
+ Fixed cap useflag. Tests and static linking need more testing.
08 Jan 2008; Jeroen Roovers <jer@gentoo.org> zsh-4.3.4-r1.ebuild:
Stable for HPPA (bug #204259).
diff --git a/app-shells/zsh/zsh-4.3.5.ebuild b/app-shells/zsh/zsh-4.3.5.ebuild
new file mode 100644
index 000000000000..e92f2da547d2
--- /dev/null
+++ b/app-shells/zsh/zsh-4.3.5.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.5.ebuild,v 1.1 2008/02/02 22:22:54 tove Exp $
+
+inherit eutils multilib
+
+LOVERS_PV=0.5
+LOVERS_P=zsh-lovers-${LOVERS_PV}
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
+ examples? ( http://www.grml.org/repos/zsh-lovers_${LOVERS_PV}.orig.tar.gz )
+ doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="maildir static doc examples pcre caps unicode"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ caps? ( sys-libs/libcap )
+ pcre? ( >=dev-libs/libpcre-3.9 )"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix zshall problem with soelim
+ ln -s Doc man1
+ mv Doc/zshall.1 Doc/zshall.1.soelim
+ soelim Doc/zshall.1.soelim > Doc/zshall.1
+
+ epatch "${FILESDIR}/${PN}"-init.d-gentoo.diff
+}
+
+src_compile() {
+ local myconf=
+
+ if use static ; then
+ myconf="${myconf} --disable-dynamic"
+ LDFLAGS="${LDFLAGS} -static"
+ fi
+
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/$(get_libdir) \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --enable-ldflags="${LDFLAGS}" \
+ --with-curses-terminfo \
+ --with-tcsetpgrp \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps cap) \
+ $(use_enable unicode multibyte) \
+ ${myconf} || die "configure failed"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -i \
+ -e "s/link=no/link=static/g" \
+ -e 's/cap.mdd link=static/cap.mdd link=no/' \
+ -e 's/curses.mdd link=static/curses.mdd link=no/' \
+ config.modules || die
+# else
+# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" Makefile
+ fi
+
+ emake || die "make failed"
+}
+
+src_test() {
+ local f=
+ for f in /dev/pt* ; do
+ addpredict "$f"
+ done
+ make check || ewarn "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.info || die
+
+ # Bug 207019
+ rm "${D}"/bin/${P} || die
+
+ insinto /etc/zsh
+ doins "${FILESDIR}"/zprofile || die
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ doins "${FILESDIR}"/prompt_gentoo_setup || die
+
+ # install miscellaneous scripts; bug #54520
+ local i
+ sed -i -e "s:/usr/local:/usr:g" "${S}"/{Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/${PV%_*}/${i}
+ doins ${i}/* || die
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+ if use doc ; then
+ dohtml -r "${S}"/Doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf} || die
+ fi
+
+ if use examples ; then
+ cd "${WORKDIR}/${LOVERS_P}"
+ doman zsh-lovers.1 || die "doman zsh-lovers failed"
+ dohtml zsh-lovers.html || die "dohtml zsh-lovers failed"
+ docinto zsh-lovers
+ dodoc zsh.vim README
+ insinto /usr/share/doc/${PF}/zsh-lovers
+ doins zsh-lovers.{ps,pdf} refcard.{dvi,ps,pdf} || die
+ doins -r zsh_people || die "doins zsh_people failed"
+ cd -
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+ # should link to http://www.gentoo.org/doc/en/zsh.xml
+ elog
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/zsh-completion and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ elog
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ elog
+}