summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-06-24 12:36:32 +0000
committerFabian Groffen <grobian@gentoo.org>2007-06-24 12:36:32 +0000
commitb05a0a9dd345afeae1b414df8770030766f8e1e1 (patch)
tree6087921d3946dbd5c3261c6d8d31d62b72a29233 /app-shells/tcsh
parentRemoved pg-hier and pg-vacuum USE flags for dev-db/postgresql (bug ##134491) (diff)
downloadgentoo-2-b05a0a9dd345afeae1b414df8770030766f8e1e1.tar.gz
gentoo-2-b05a0a9dd345afeae1b414df8770030766f8e1e1.tar.bz2
gentoo-2-b05a0a9dd345afeae1b414df8770030766f8e1e1.zip
Version bump to 6.15.00, fixes bug #182466
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/ChangeLog7
-rw-r--r--app-shells/tcsh/files/digest-tcsh-6.156
-rw-r--r--app-shells/tcsh/tcsh-6.15.ebuild68
3 files changed, 80 insertions, 1 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index 42dfed26b375..91455b2af759 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/tcsh
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.71 2007/04/10 18:38:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.72 2007/06/24 12:36:32 grobian Exp $
+
+*tcsh-6.15 (23 Jun 2007)
+
+ 23 Jun 2007; Fabian Groffen <grobian@gentoo.org> +tcsh-6.15.ebuild:
+ Version bump to 6.15.00, fixes bug #182466
10 Apr 2007; Fabian Groffen <grobian@gentoo.org> tcsh-6.14-r3.ebuild,
tcsh-6.14-r5.ebuild, tcsh-6.14-r33.ebuild:
diff --git a/app-shells/tcsh/files/digest-tcsh-6.15 b/app-shells/tcsh/files/digest-tcsh-6.15
new file mode 100644
index 000000000000..0cefbe779489
--- /dev/null
+++ b/app-shells/tcsh/files/digest-tcsh-6.15
@@ -0,0 +1,6 @@
+MD5 67a0611620b080bd0eb032b1774382b6 tcsh-6.15.00.tar.gz 870886
+RMD160 8065279e93bd3fddb2a95a3f74a680858d36508c tcsh-6.15.00.tar.gz 870886
+SHA256 dca83e59025f18a9811895cd7cf2a760ab1750240ea7c8c86ea21e24f783acdc tcsh-6.15.00.tar.gz 870886
+MD5 6a4f913dba5bfb71a6b84da43510acb5 tcsh-config-1.4.tar.bz2 2388
+RMD160 30ee8c3957fe1bd83534c06ea0ae634e12f9a683 tcsh-config-1.4.tar.bz2 2388
+SHA256 76500542856e69f66412735cd45c4022d95c713460e4008a215fbe4c2cbafd84 tcsh-config-1.4.tar.bz2 2388
diff --git a/app-shells/tcsh/tcsh-6.15.ebuild b/app-shells/tcsh/tcsh-6.15.ebuild
new file mode 100644
index 000000000000..f6f14a2a3e7a
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.15.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.15.ebuild,v 1.1 2007/06/24 12:36:32 grobian Exp $
+
+inherit eutils
+
+PATCHVER="1.4"
+
+MY_P="${P}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+ mirror://gentoo/tcsh-config-${PATCHVER}.tar.bz2
+ http://www.gentoo.org/~grobian/distfiles/tcsh-config-${PATCHVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="perl catalogs"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ perl? ( dev-lang/perl )
+ !app-shells/csh" # bug #119703
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${MY_P/15/14}"-debian-dircolors.patch # bug #120792
+ epatch "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
+
+ if use catalogs ; then
+ einfo "enabling NLS catalogs support..."
+ sed -i -e "s/#undef NLS_CATALOGS/#define NLS_CATALOGS/" \
+ config_f.h || die
+ eend $?
+ fi
+}
+
+src_compile() {
+ econf --prefix=/ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man || die
+
+ if use perl ; then
+ perl tcsh.man2html tcsh.man || die
+ dohtml tcsh.html/*.html
+ fi
+
+ insinto /etc
+ doins \
+ "${WORKDIR}"/tcsh-config/csh.cshrc \
+ "${WORKDIR}"/tcsh-config/csh.login
+
+ insinto /etc/profile.d
+ doins \
+ "${WORKDIR}"/tcsh-config/tcsh-bindkey.csh \
+ "${WORKDIR}"/tcsh-config/tcsh-settings.csh
+
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym /bin/tcsh /bin/csh
+}