summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-16 17:25:35 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-16 17:25:35 +0000
commitc7c8d5750334ee909098060942fe118a8ae50a26 (patch)
tree2429af16d7be599df9a3f6414b44a6925baf3667 /app-shells/bash
parentStable for HPPA (bug #379917). (diff)
downloadgentoo-2-c7c8d5750334ee909098060942fe118a8ae50a26.tar.gz
gentoo-2-c7c8d5750334ee909098060942fe118a8ae50a26.tar.bz2
gentoo-2-c7c8d5750334ee909098060942fe118a8ae50a26.zip
Fix building when job controls are disabled (like when cross-compiling) #383237 by Maciej Grela.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-4.2_p10.ebuild4
-rw-r--r--app-shells/bash/files/bash-4.2-execute-job-control.patch24
3 files changed, 33 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 7d1700e472c2..341e66d3b211 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.290 2011/08/11 02:23:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.291 2011/09/16 17:25:35 vapier Exp $
+
+ 16 Sep 2011; Mike Frysinger <vapier@gentoo.org> bash-4.2_p10.ebuild,
+ +files/bash-4.2-execute-job-control.patch:
+ Fix building when job controls are disabled (like when cross-compiling)
+ #383237 by Maciej Grela.
11 Aug 2011; Mike Frysinger <vapier@gentoo.org> bash-4.2_p8-r1.ebuild,
bash-4.2_p10.ebuild:
diff --git a/app-shells/bash/bash-4.2_p10.ebuild b/app-shells/bash/bash-4.2_p10.ebuild
index 4b6dec83b299..a1921e4b9134 100644
--- a/app-shells/bash/bash-4.2_p10.ebuild
+++ b/app-shells/bash/bash-4.2_p10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p10.ebuild,v 1.3 2011/08/11 02:23:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p10.ebuild,v 1.4 2011/09/16 17:25:35 vapier Exp $
EAPI="1"
@@ -71,6 +71,8 @@ src_unpack() {
cd lib/readline
[[ ${READLINE_PLEVEL} -gt 0 ]] && epatch $(patches -s ${READLINE_PLEVEL} readline ${READLINE_VER})
cd ../..
+
+ epatch "${FILESDIR}"/${PN}-4.2-execute-job-control.patch #383237
}
src_compile() {
diff --git a/app-shells/bash/files/bash-4.2-execute-job-control.patch b/app-shells/bash/files/bash-4.2-execute-job-control.patch
new file mode 100644
index 000000000000..82b73e5157ca
--- /dev/null
+++ b/app-shells/bash/files/bash-4.2-execute-job-control.patch
@@ -0,0 +1,24 @@
+fix build when job control is disabled
+
+http://lists.gnu.org/archive/html/bug-bash/2011-06/msg00110.html
+http://lists.gnu.org/archive/html/bug-bash/2011-07/msg00057.html
+http://lists.gnu.org/archive/html/bug-bash/2011-09/msg00039.html
+https://bugs.gentoo.org/383237
+
+should be fixed in next release of bash ...
+
+--- a/execute_cmd.c
++++ b/execute_cmd.c
+@@ -2202,7 +2202,11 @@
+ /* If the `lastpipe' option is set with shopt, and job control is not
+ enabled, execute the last element of non-async pipelines in the
+ current shell environment. */
+- if (lastpipe_opt && job_control == 0 && asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
++ if (lastpipe_opt &&
++#if defined(JOB_CONTROL)
++ job_control == 0 &&
++#endif
++ asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
+ {
+ lstdin = move_to_high_fd (0, 0, 255);
+ if (lstdin > 0)