summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-03 22:16:49 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-03 22:16:49 +0000
commitfff0235edf887e62522d5497d0d0dc7badf0f453 (patch)
treedbdf3040b2e866f291880676c87af8340c4fbc85 /app-shells/bash-completion
parentStable on amd64 (bug #256599) (diff)
downloadgentoo-2-fff0235edf887e62522d5497d0d0dc7badf0f453.tar.gz
gentoo-2-fff0235edf887e62522d5497d0d0dc7badf0f453.tar.bz2
gentoo-2-fff0235edf887e62522d5497d0d0dc7badf0f453.zip
remove old
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog6
-rw-r--r--app-shells/bash-completion/bash-completion-0.20081219-r1.ebuild102
2 files changed, 5 insertions, 103 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index e862e45ecfc0..b45b0f18b138 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.179 2009/05/31 18:22:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.180 2009/06/03 22:16:49 darkside Exp $
+
+ 03 Jun 2009; Jeremy Olexa <darkside@gentoo.org>
+ -bash-completion-0.20081219-r1.ebuild:
+ remove old
31 May 2009; Brent Baude <ranger@gentoo.org>
bash-completion-1.0-r3.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-0.20081219-r1.ebuild b/app-shells/bash-completion/bash-completion-0.20081219-r1.ebuild
deleted file mode 100644
index be6d06eb6dd2..000000000000
--- a/app-shells/bash-completion/bash-completion-0.20081219-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-0.20081219-r1.ebuild,v 1.1 2009/04/10 01:36:29 darkside Exp $
-
-EAPI="2"
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="http://bash-completion.alioth.debian.org/"
-#SRC_URI="mirror://debian/pool/main/b/${PN}/${PN}_${PV}.tar.gz"
-SRC_URI="mirror://gentoo/${PN}-${PV#0.}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="app-admin/eselect
- || (
- >=app-shells/bash-2.05a
- app-shells/zsh
- )
- sys-apps/miscfiles"
-PDEPEND="app-shells/gentoo-bashcomp"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- # bug #111681 & bug 254814
- sed -i -e "/^complete.* xine /d" \
- -e '0,/gz|bz2/s//gz|bz2|lzma/' bash_completion || die "sed failed"
- # bug 146726
- rm contrib/svk || die "rm failed"
- # bug 259818
- rm contrib/hg || die "rm failed"
-}
-
-src_install() {
- # split /etc/bash_completion into three parts:
- # 1. /usr/share/bash-completion/.pre -- hidden from eselect
- # 2. /usr/share/bash-completion/base -- eselectable
- # 3. /usr/share/bash-completion/.post -- hidden from eselect
- dodir /usr/share/bash-completion || die "dodir failed"
- awk -v D="$D" '
- BEGIN { out=".pre" }
- /^# A lot of the following one-liners/ { out="base" }
- /^# source completion directory/ { out="" }
- /^unset -f have/ { out=".post" }
- out != "" { print > D"/usr/share/bash-completion/"out }' \
- bash_completion || die "failed to split bash_completion"
-
- exeinto /etc/profile.d
- doexe "${FILESDIR}"/bash-completion.sh \
- || die "failed to install profile.d"
-
- insinto /usr/share/bash-completion
- doins contrib/* || die "failed to install contrib completions"
-
- dodoc debian/changelog README TODO
-}
-
-pkg_preinst() {
- # This file is now being installed as bash-completion.sh, so rename it
- # first. That allows CONFIG_PROTECT to kick in properly
- if [[ -f ${ROOT}/etc/profile.d/bash-completion && \
- ! -f ${ROOT}/etc/profile.d/bash-completion.sh ]]
- then
- mv "${ROOT}"/etc/profile.d/bash-completion{,.sh}
- fi
-}
-
-pkg_postinst() {
- elog
- elog "Versions of bash-completion prior to 20060301-r1 required each user to"
- elog "explicitly source /etc/profile.d/bash-completion in ~/.bashrc. This"
- elog "was inconsistent with the completion modules which are"
- elog "enabled with eselect bashcomp. Now any user can enable the base"
- elog "completions without editing their .bashrc by running"
- elog
- elog " eselect bashcomp enable base"
- elog
- elog "The system administrator can also be enable this globally with"
- elog
- elog " eselect bashcomp enable --global base"
- elog
- elog "Additional completion functions can also be enabled or"
- elog "disabled using eselect's bashcomp module."
- elog
- elog "If you use non-login shells you still need to source"
- elog "/etc/profile.d/bash-completion.sh in your ~/.bashrc."
- elog "Note this is bash-completion.sh, not bash-completion. Lots of people"
- elog "overlook this"
- elog
-
- if has_version 'app-shells/zsh' ; then
- elog "If you are interested in using the provided bash completion functions with"
- elog "zsh, valuable tips on the effective use of bashcompinit are available:"
- elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- #elog " http://zshwiki.org/ZshSwitchingTo" (doesn't exist)
- elog
- fi
-}