summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-03 22:23:07 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-03 22:23:07 +0000
commit6c76524b473ec8767379de27f1fd6c74ade68868 (patch)
treef0d1d726298e50d0916062b1be1c9fed6fc965a0 /app-shells/bash-completion
parentVersion bump (diff)
downloadgentoo-2-6c76524b473ec8767379de27f1fd6c74ade68868.tar.gz
gentoo-2-6c76524b473ec8767379de27f1fd6c74ade68868.tar.bz2
gentoo-2-6c76524b473ec8767379de27f1fd6c74ade68868.zip
Fix incompatibility with sys-apps/module-init-tools-3.8, bug 271286
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/bash-completion-1.0-r4.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index b45b0f18b138..5806563cb89e 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.180 2009/06/03 22:16:49 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.181 2009/06/03 22:23:07 darkside Exp $
+
+*bash-completion-1.0-r4 (03 Jun 2009)
+
+ 03 Jun 2009; Jeremy Olexa <darkside@gentoo.org>
+ +bash-completion-1.0-r4.ebuild:
+ Fix incompatibility with sys-apps/module-init-tools-3.8, bug 271286
03 Jun 2009; Jeremy Olexa <darkside@gentoo.org>
-bash-completion-0.20081219-r1.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-1.0-r4.ebuild b/app-shells/bash-completion/bash-completion-1.0-r4.ebuild
new file mode 100644
index 000000000000..e54491647d6b
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-1.0-r4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.0-r4.ebuild,v 1.1 2009/06/03 22:23:07 darkside Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/b/bash-completion/${PN}_${PV}.orig.tar.gz ->
+bash-completion-1.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-admin/eselect
+ || (
+ >=app-shells/bash-2.05a
+ app-shells/zsh
+ )
+ sys-apps/miscfiles
+ !<=games-misc/cowsay-3.03-r1"
+PDEPEND="app-shells/gentoo-bashcomp"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-1.0-bash4.patch"
+ # module-init-tools-3.8 changed locations
+ sed -i 's:/sbin/lsmod:/bin/lsmod:' bash_completion
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Upstream will soon be splitting this for us.
+ # split /etc/bash_completion into three parts:
+ # 1. /usr/share/bash-completion/.pre -- hidden from eselect
+ # 2. /usr/share/bash-completion/base -- eselectable
+ # 3. /usr/share/bash-completion/.post -- hidden from eselect
+ dodir /usr/share/bash-completion
+ awk -v D="$D" '
+ BEGIN { out=".pre" }
+ /^# A lot of the following one-liners/ { out="base" }
+ /^# start of section containing completion functions called by other functions/ { out=".pre" }
+ /^# start of section containing completion functions for bash built-ins/ { out="base" }
+ /^# source completion directory/ { out="" }
+ /^unset -f have/ { out=".post" }
+ out != "" { print > D"/usr/share/bash-completion/"out }' \
+ bash_completion || die "failed to split bash_completion"
+
+ dodir /etc/profile.d
+ cp bash_completion.sh "${D}/etc/profile.d/bash-completion.sh" \
+ || die "cp failed"
+
+ dodoc AUTHORS CHANGES README TODO || die "dodocs failes"
+
+ # bug 146726
+ rm "${D}/etc/bash_completion.d/svk" || die "rm failed"
+
+ # Upstream provides no easy way to move modules. sigh
+ dodir /usr/share/bash-completion
+ mv "${D}"/etc/bash_completion.d/* "${D}/usr/share/bash-completion/" \
+ || die "installation failed to move files"
+ # cleanup the mess
+ rm -r "${D}"/etc/bash_completion{,.d} || die "rm failed"
+}
+
+pkg_postinst() {
+ elog "Any user can enable the base completions without editing their"
+ elog ".bashrc by running:"
+ elog
+ elog " eselect bashcomp enable base"
+ elog
+ elog "The system administrator can also be enable this globally with"
+ elog
+ elog " eselect bashcomp enable --global base"
+ elog
+ elog "Additional completion functions can also be enabled or"
+ elog "disabled using eselect's bashcomp module."
+ elog
+ elog "If you use non-login shells you still need to source"
+ elog "/etc/profile.d/bash-completion.sh in your ~/.bashrc."
+
+ if has_version 'app-shells/zsh' ; then
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ #elog " http://zshwiki.org/ZshSwitchingTo" (doesn't exist)
+ elog
+ fi
+}