summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-04 10:43:19 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-04 10:43:19 +0000
commitf16e4de17b9b4efc947f5cdc50369672ac701b37 (patch)
treebc93fe04cb8088c05ee27c07bb223292894766ab /app-shells/autojump
parentfix typo (diff)
downloadgentoo-2-f16e4de17b9b4efc947f5cdc50369672ac701b37.tar.gz
gentoo-2-f16e4de17b9b4efc947f5cdc50369672ac701b37.tar.bz2
gentoo-2-f16e4de17b9b4efc947f5cdc50369672ac701b37.zip
Drop old, fix infinity loop sourcing shell=sh (thanks Kamil Kuduk, bug 446312), prefix support (thanks Leho Kraav, bug 465226), fix security issue (bug 467262).
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/ChangeLog10
-rw-r--r--app-shells/autojump/autojump-21.3.0-r1.ebuild (renamed from app-shells/autojump/autojump-21.3.0.ebuild)19
-rw-r--r--app-shells/autojump/files/autojump-21.3.0-supported-shells.patch34
3 files changed, 53 insertions, 10 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index 50106f552d82..07bd29f007a8 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.10 2013/05/04 10:07:36 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.11 2013/05/04 10:43:19 xmw Exp $
+
+*autojump-21.3.0-r1 (04 May 2013)
+
+ 04 May 2013; Michael Weber <xmw@gentoo.org> +autojump-21.3.0-r1.ebuild,
+ +files/autojump-21.3.0-supported-shells.patch, -autojump-21.3.0.ebuild:
+ Drop old, fix infinity loop sourcing shell=sh (thanks Kamil Kuduk, bug
+ 446312), prefix support (thanks Leho Kraav, bug 465226), fix security issue
+ (bug 467262).
04 May 2013; Michael Weber <xmw@gentoo.org> -autojump-20.9.ebuild,
-autojump-21.1.0.ebuild, -autojump-21.1.2.ebuild, -autojump-21.2.1.ebuild:
diff --git a/app-shells/autojump/autojump-21.3.0.ebuild b/app-shells/autojump/autojump-21.3.0-r1.ebuild
index ae0173170697..eae2567bf342 100644
--- a/app-shells/autojump/autojump-21.3.0.ebuild
+++ b/app-shells/autojump/autojump-21.3.0-r1.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.3.0.ebuild,v 1.1 2013/01/09 09:06:26 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.3.0-r1.ebuild,v 1.1 2013/05/04 10:43:19 xmw Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
-inherit python vcs-snapshot
+inherit eutils python-r1 vcs-snapshot
DESCRIPTION="change directory command that learns"
HOMEPAGE="http://github.com/joelthelion/autojump"
@@ -19,13 +18,12 @@ KEYWORDS="~amd64 ~x86"
IUSE="bash-completion python test zsh-completion"
RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
-DEPEND="test? ( dev-lang/python )"
+DEPEND="test? ( ${PYTHON_DEPS} )"
src_prepare() {
- #https://github.com/joelthelion/autojump/issues/129
- sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
- -i tests/runtests.py || die
+ epatch "${FILESDIR}"/${P}-supported-shells.patch
}
src_compile() {
@@ -61,4 +59,7 @@ src_install() {
doman docs/${PN}.1
dodoc README.md
+
+ elog "loading of insecure relative path \"custom_install\" has been"
+ elog "remove. See ${EPREFIX}/etc/profile.d/${PN}.sh for details."
}
diff --git a/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch b/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch
new file mode 100644
index 000000000000..a16fc2d4dcf2
--- /dev/null
+++ b/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch
@@ -0,0 +1,34 @@
+--- autojump-21.3.0/bin/autojump.sh
++++ autojump-21.3.0/bin/autojump.sh
+@@ -1,17 +1,17 @@
+ # source autojump on BASH or ZSH depending on the shell
+
+ shell=`echo ${SHELL} | awk -F/ '{ print $NF }'`
+-
+-# check local install
+-if [ -s ~/.autojump/etc/profile.d/autojump.${shell} ]; then
+- source ~/.autojump/etc/profile.d/autojump.${shell}
+-
+-# check global install
+-elif [ -s /etc/profile.d/autojump.${shell} ]; then
+- source /etc/profile.d/autojump.${shell}
+-
+-# check custom install locations (modified by Homebrew or using --destdir option)
+-elif [ -s custom_install/autojump.${shell} ]; then
+- source custom_install/autojump.${shell}
+-
+-fi
++case ${shell} in
++ bash|zsh)
++ # check local install
++ if [ -s ~/.autojump/etc/profile.d/autojump.${shell} ]; then
++ source ~/.autojump/etc/profile.d/autojump.${shell}
++ # check global install
++ elif [ -s "${EPREFIX}"/etc/profile.d/autojump.${shell} ]; then
++ source "${EPREFIX}"/etc/profile.d/autojump.${shell}
++ fi
++ ;;
++ *)
++ echo "Your shell ${shell} (from SHELL=${SHELL}) is unkown."
++ ;;
++esac