summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-09 08:55:21 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-09 08:55:21 +0000
commit9abd9263e0132c2f3261bdd73c5366a6e92e58f4 (patch)
tree1abe17f6cf4824dc07eadd49aaa145344f1cafc3 /app-shells/autojump
parentVersion bump (thanks euscan) (diff)
downloadgentoo-2-9abd9263e0132c2f3261bdd73c5366a6e92e58f4.tar.gz
gentoo-2-9abd9263e0132c2f3261bdd73c5366a6e92e58f4.tar.bz2
gentoo-2-9abd9263e0132c2f3261bdd73c5366a6e92e58f4.zip
Version bump (thanks euscan)
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/ChangeLog7
-rw-r--r--app-shells/autojump/autojump-21.2.1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index 3cf68803e106..fb28ccdc6b0d 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.7 2013/01/09 08:45:42 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.8 2013/01/09 08:55:21 xmw Exp $
+
+*autojump-21.2.1 (09 Jan 2013)
+
+ 09 Jan 2013; Michael Weber <xmw@gentoo.org> +autojump-21.2.1.ebuild:
+ Version bump (thanks euscan)
*autojump-21.1.2 (09 Jan 2013)
diff --git a/app-shells/autojump/autojump-21.2.1.ebuild b/app-shells/autojump/autojump-21.2.1.ebuild
new file mode 100644
index 000000000000..a57aa434cf8e
--- /dev/null
+++ b/app-shells/autojump/autojump-21.2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.2.1.ebuild,v 1.1 2013/01/09 08:55:21 xmw Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion gtk python test zsh-completion"
+
+RDEPEND="gtk? ( dev-python/pygtk:2 )
+ bash-completion? ( >=app-shells/bash-4 )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
+DEPEND="test? ( dev-lang/python )"
+
+src_prepare() {
+ #https://github.com/joelthelion/autojump/issues/129
+ sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
+ -i tests/runtests.py || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ if use gtk ; then
+ dobin bin/jumpapplet
+ insinto /usr/share/${PN}
+ doins bin/icon.png
+ fi
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ install_python() {
+ insinto "$(python_get_sitedir)"
+ doins tools/autojump_ipython.py
+ }
+ python_execute_function -q install_python
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}