summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-07-20 05:36:11 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-07-20 05:36:11 +0000
commitaa949b688e4f0405446e98f2a544622c5a4b07f8 (patch)
treedcf902015e8c44b207ba0e94c5c40dbedd6ce0aa /app-sci
parentnew version (diff)
downloadgentoo-2-aa949b688e4f0405446e98f2a544622c5a4b07f8.tar.gz
gentoo-2-aa949b688e4f0405446e98f2a544622c5a4b07f8.tar.bz2
gentoo-2-aa949b688e4f0405446e98f2a544622c5a4b07f8.zip
updated version
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/tilp/ChangeLog7
-rw-r--r--app-sci/tilp/Manifest5
-rw-r--r--app-sci/tilp/files/digest-tilp-6.091
-rw-r--r--app-sci/tilp/tilp-6.09.ebuild44
4 files changed, 55 insertions, 2 deletions
diff --git a/app-sci/tilp/ChangeLog b/app-sci/tilp/ChangeLog
index 2f6079c99a05..54f44324b122 100644
--- a/app-sci/tilp/ChangeLog
+++ b/app-sci/tilp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/tilp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tilp/ChangeLog,v 1.1 2003/07/20 05:22:46 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tilp/ChangeLog,v 1.2 2003/07/20 05:36:11 rphillips Exp $
+
+*tilp-6.09 (19 Jul 2003)
+
+ 19 Jul 2003; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ Submitted by Brent Redeker and Jonathan Rogers. Fixes #18234
*tilp-6.06 (19 Jul 2003)
diff --git a/app-sci/tilp/Manifest b/app-sci/tilp/Manifest
index c28bc1d078e9..a1d88be34884 100644
--- a/app-sci/tilp/Manifest
+++ b/app-sci/tilp/Manifest
@@ -1,2 +1,5 @@
-MD5 392c257ec08ca3328495277eb6be3d1d tilp-6.06.ebuild 1256
+MD5 6d824683c85b7c9c7c7dc0295bbbe181 tilp-6.06.ebuild 1351
+MD5 34e5d8fba15df795a8116b99b287cfc6 ChangeLog 516
+MD5 6d824683c85b7c9c7c7dc0295bbbe181 tilp-6.09.ebuild 1351
MD5 e63c3a7b61cdd7c36a01a074146ec93c files/digest-tilp-6.06 61
+MD5 236baab42b2a15104005363c3b21f467 files/digest-tilp-6.09 61
diff --git a/app-sci/tilp/files/digest-tilp-6.09 b/app-sci/tilp/files/digest-tilp-6.09
new file mode 100644
index 000000000000..001ab28a5da8
--- /dev/null
+++ b/app-sci/tilp/files/digest-tilp-6.09
@@ -0,0 +1 @@
+MD5 54616af8500a2f0808a92db708362e18 tilp-6.09.tar.gz 763949
diff --git a/app-sci/tilp/tilp-6.09.ebuild b/app-sci/tilp/tilp-6.09.ebuild
new file mode 100644
index 000000000000..d51af8cbf603
--- /dev/null
+++ b/app-sci/tilp/tilp-6.09.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tilp/tilp-6.09.ebuild,v 1.1 2003/07/20 05:36:11 rphillips Exp $
+
+DESCRIPTION="TiLP is a linking program for Texas Instruments' graphing calculators."
+HOMEPAGE="http://tilp.sourceforge.net/"
+
+# Should figure out a way to allow downloads from different server, rather than
+# forcing it to come from Time-Warner
+SRC_URI="http://twtelecom.dl.sourceforge.net/sourceforge/tilp/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+# Only tested on x86 so far...
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-libs/libticables
+ dev-libs/libticalcs
+ dev-libs/libtifiles
+ =x11-libs/gtk+-1.2*"
+
+src_compile() {
+ # Note the special option --with-fontpath-prefix below.
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-fontpath-prefix=${D}/usr/X11R6/lib/X11/fonts \
+ --enable-exit-homedir || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README* RELEASE THANKS TODO
+}
+
+pkg_postinst() {
+ # TiLP installs a font into /usr/X11R6/lib/X11/fonts/misc, so I'm running
+ # mkfontdir here to update the system
+ mkfontdir -- /usr/X11R6/lib/X11/fonts/misc
+}