summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-11-01 00:58:15 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-11-01 00:58:15 +0000
commita6a506c04665aca32cbb05ad4fb0ae7281d49796 (patch)
tree6b0cceb5b88072e3163a7f65ce0513b1c780d436 /app-sci
parentStable on sparc wrt security bug #69624. (Manifest recommit) (diff)
downloadgentoo-2-a6a506c04665aca32cbb05ad4fb0ae7281d49796.tar.gz
gentoo-2-a6a506c04665aca32cbb05ad4fb0ae7281d49796.tar.bz2
gentoo-2-a6a506c04665aca32cbb05ad4fb0ae7281d49796.zip
Use tc-getCC from toolchain-funcs rather than $CC.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/lapack-atlas/ChangeLog5
-rw-r--r--app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild14
2 files changed, 10 insertions, 9 deletions
diff --git a/app-sci/lapack-atlas/ChangeLog b/app-sci/lapack-atlas/ChangeLog
index 20eedb203054..b504f8814548 100644
--- a/app-sci/lapack-atlas/ChangeLog
+++ b/app-sci/lapack-atlas/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/lapack-atlas
# Copyright 2004-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/ChangeLog,v 1.15 2004/10/02 15:16:04 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/ChangeLog,v 1.16 2004/11/01 00:58:15 ribosome Exp $
+
+ 31 Oct 2004; Olivier Fisette <ribosome@gentoo.org> lapack-atlas-3.6.0.ebuild:
+ Use tc-getCC from toolchain-funcs rather than $CC.
12 Sep 2004; Danny van Dyk <kugelfang@gentoo.org> lapack-atlas-3.6.0.ebuild:
Marked stable on amd64.
diff --git a/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild b/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild
index 84480d009bfd..681a5f2190a4 100644
--- a/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild
+++ b/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild,v 1.13 2004/09/12 20:49:41 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild,v 1.14 2004/11/01 00:58:15 ribosome Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Full LAPACK implementation using available ATLAS routines"
HOMEPAGE="http://math-atlas.sourceforge.net/"
@@ -90,22 +90,20 @@ atlas_fail() {
}
src_compile() {
- GCC="gcc"
-
cd ${S}
if [ -n "${interactive}" ]
then
echo "${interactive}"
- make config CC="${GCC} -DUSE_LIBTOOL -DINTERACTIVE" || die
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
else
# Use ATLAS defaults for all questions:
- (echo | make config CC="${GCC} -DUSE_LIBTOOL") || atlas_fail
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
fi
TMPSTR=$(ls Make.Linux*)
ATLAS_ARCH=${TMPSTR#'Make.'}
- CC="libtool --mode=compile --tag=CC ${GCC} -I/usr/include/atlas"
+ CC="libtool --mode=compile --tag=CC $(tc-getCC) -I/usr/include/atlas"
cd ${S}/src/lapack/${ATLAS_ARCH}
make lib CC="${CC}" || die
@@ -149,7 +147,7 @@ src_compile() {
ar cru liblapack.a *.o
ranlib liblapack.a
else
- libtool --mode=link --tag=CC ${GCC} -o liblapack.la *.lo \
+ libtool --mode=link --tag=CC $(tc-getCC) -o liblapack.la *.lo \
-rpath ${RPATH} -lblas -lcblas -latlas -lg2c
fi
}