summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 15:47:42 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 15:47:42 +0000
commit05e0e2452318c6a32c68182ed7fb14ab4c2cbd3a (patch)
tree57b09499ad79cad03fa04456db31e0a21e2c2c8b /app-sci
parentneed eutils for epatch (diff)
downloadgentoo-2-05e0e2452318c6a32c68182ed7fb14ab4c2cbd3a.tar.gz
gentoo-2-05e0e2452318c6a32c68182ed7fb14ab4c2cbd3a.tar.bz2
gentoo-2-05e0e2452318c6a32c68182ed7fb14ab4c2cbd3a.zip
need eutils for epatch
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/pymol/pymol-0.82.ebuild10
-rw-r--r--app-sci/pymol/pymol-0.86.ebuild10
-rw-r--r--app-sci/pymol/pymol-0.88.ebuild9
-rw-r--r--app-sci/pymol/pymol-0.90.ebuild9
4 files changed, 19 insertions, 19 deletions
diff --git a/app-sci/pymol/pymol-0.82.ebuild b/app-sci/pymol/pymol-0.82.ebuild
index 7f9f05351f7b..fa19ef55f48b 100644
--- a/app-sci/pymol/pymol-0.82.ebuild
+++ b/app-sci/pymol/pymol-0.82.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.82.ebuild,v 1.7 2003/02/13 09:24:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.82.ebuild,v 1.8 2003/08/05 15:47:42 vapier Exp $
+
+inherit eutils flag-o-matic
MY_PV=${PV/./_}
DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
SRC_URI="mirror://sourceforge/pymol/${PN}-${MY_PV}-src.tgz"
-HOMEPAGE="http://pymol.sf.net"
LICENSE="PSF-2.2"
SLOT="0"
@@ -23,11 +25,11 @@ src_unpack() {
unpack ${A}
cd ${S}
cp setup/Rules.linux Rules.make
- patch -p0 < ${FILESDIR}/${PN}-gentoo.diff || die
+ epatch ${FILESDIR}/${PN}-gentoo.diff
}
src_compile() {
- CFLAGS="$CFLAGS -ffast-math -funroll-loops"
+ append-flags -ffast-math -funroll-loops
make || die
}
diff --git a/app-sci/pymol/pymol-0.86.ebuild b/app-sci/pymol/pymol-0.86.ebuild
index 225bbcdd25b9..a2c562d47cfe 100644
--- a/app-sci/pymol/pymol-0.86.ebuild
+++ b/app-sci/pymol/pymol-0.86.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.86.ebuild,v 1.3 2003/03/11 20:41:30 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.86.ebuild,v 1.4 2003/08/05 15:47:42 vapier Exp $
-IUSE=""
+inherit eutils flag-o-matic
MY_PV=${PV/./_}
DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
SRC_URI="mirror://sourceforge/pymol/${PN}-${MY_PV}-src.tgz"
-HOMEPAGE="http://pymol.sf.net"
LICENSE="PSF-2.2"
SLOT="0"
@@ -25,11 +25,11 @@ src_unpack() {
unpack ${A}
cd ${S}
cp setup/Rules.linux Rules.make
- patch -p0 < ${FILESDIR}/${PN}-gentoo.diff || die
+ epatch ${FILESDIR}/${PN}-gentoo.diff
}
src_compile() {
- CFLAGS="$CFLAGS -ffast-math"
+ append-flags -ffast-math
make || die
}
diff --git a/app-sci/pymol/pymol-0.88.ebuild b/app-sci/pymol/pymol-0.88.ebuild
index cdc03126a935..4538453a2ea4 100644
--- a/app-sci/pymol/pymol-0.88.ebuild
+++ b/app-sci/pymol/pymol-0.88.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.88.ebuild,v 1.2 2003/07/24 01:12:59 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.88.ebuild,v 1.3 2003/08/05 15:47:42 vapier Exp $
+
+inherit distutils eutils
DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
SRC_URI="mirror://sourceforge/pymol/${PN}-${PV/./_}-src.tgz"
-HOMEPAGE="http://pymol.sf.net"
LICENSE="PSF-2.2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE=""
DEPEND="dev-lang/python
dev-python/pmw
@@ -19,8 +20,6 @@ DEPEND="dev-lang/python
sys-libs/zlib
media-libs/glut"
-inherit distutils
-
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/app-sci/pymol/pymol-0.90.ebuild b/app-sci/pymol/pymol-0.90.ebuild
index aa9d87637d41..dc6e4ff4b479 100644
--- a/app-sci/pymol/pymol-0.90.ebuild
+++ b/app-sci/pymol/pymol-0.90.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.90.ebuild,v 1.1 2003/07/24 01:12:59 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.90.ebuild,v 1.2 2003/08/05 15:47:42 vapier Exp $
+
+inherit distutils eutils
DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
SRC_URI="mirror://sourceforge/pymol/${PN}-${PV/./_}-src.tgz"
-HOMEPAGE="http://pymol.sf.net"
LICENSE="PSF-2.2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE=""
DEPEND="dev-lang/python
dev-python/pmw
@@ -19,8 +20,6 @@ DEPEND="dev-lang/python
sys-libs/zlib
media-libs/glut"
-inherit distutils
-
src_unpack() {
unpack ${A}
cd ${S}