summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-15 20:07:21 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-15 20:07:21 +0000
commite9f9640927cf6c6dd1dd9ddf09f3dc7d985b51f6 (patch)
treedf16d1225aa8b5d89a33734de8bdc254d1cbcfd9 /app-sci/octave
parentRemoved a couple sparc fixes since they are present in the vendor tarball in ... (diff)
downloadgentoo-2-e9f9640927cf6c6dd1dd9ddf09f3dc7d985b51f6.tar.gz
gentoo-2-e9f9640927cf6c6dd1dd9ddf09f3dc7d985b51f6.tar.bz2
gentoo-2-e9f9640927cf6c6dd1dd9ddf09f3dc7d985b51f6.zip
Switched to George's Fortran check from app-sci/lapack-atlas.
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog6
-rw-r--r--app-sci/octave/octave-2.1.57-r1.ebuild27
2 files changed, 18 insertions, 15 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index a568a1dc1143..2655fd8b9372 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.27 2004/05/12 12:27:26 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.28 2004/05/15 20:07:21 kugelfang Exp $
+
+ 15 May 2004; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.57-r1.ebuild:
+ Now checking on both g77 and ifc Fortran compilers. Moved check routine to
+ pkg_setup.
12 May 2004; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.57-r1.ebuild:
The ebuild checks now if g77 has been compiled. If not, a warning is shown.
diff --git a/app-sci/octave/octave-2.1.57-r1.ebuild b/app-sci/octave/octave-2.1.57-r1.ebuild
index 240b0e37722c..e43272855f25 100644
--- a/app-sci/octave/octave-2.1.57-r1.ebuild
+++ b/app-sci/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.2 2004/05/12 12:27:26 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.3 2004/05/15 20:07:21 kugelfang Exp $
inherit flag-o-matic
@@ -13,7 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
IUSE="emacs static readline zlib tetex hdf5 mpi"
-#IUSE="emacs static readline zlib tetex hdf5 mpi" NOTE: Already added to use.local.desc.
+#IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas" NOTE: Already added to use.local.desc.
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r3
@@ -22,7 +22,8 @@ DEPEND="virtual/glibc
>=dev-util/gperf-2.7.2
zlib? ( sys-libs/zlib )
hdf5? ( dev-libs/hdf5 )
- tetex? ( virtual/tetex )"
+ tetex? ( virtual/tetex )
+ x86? ( ifc? ( dev-lang/ifc ) )"
# blas? ( virtual/blas )" NOTE: Blas-* is not fully done.
# NOTE: octave supports blas/lapack from intel but this is not open
@@ -30,6 +31,15 @@ DEPEND="virtual/glibc
# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
# more information
+pkg_setup() {
+ use ifc || if [ -z `which g77` ]; then
+ #if ifc is defined then the dep was already checked
+ eerror "No fortran compiler found on the system!"
+ eerror "Please add g77 to your USE flags and reemerge gcc!"
+ die
+ fi
+}
+
src_compile() {
filter-flags -ffast-math
@@ -40,17 +50,6 @@ src_compile() {
use hdf5 || myconf="${myconf} --without-hdf5"
use mpi || myconf="${myconf} --without-mpi"
- # NOTE: We need gcc to be emerge with USE="f77"
- /usr/bin/which g77 > /dev/null 2>&1
- if [ $? != 0 ]; then
- ewarn "GNU Fortran Compiler g77 is missing. This is no problem"
- ewarn "as long as you have a Fortran Compiler that will be"
- ewarn "detected by ./configure. If you have no other compiler"
- ewarn "installed, ./configure _will_ fail. In this case, add"
- ewarn "\"f77\" to your USE-flags and remerge gcc."
- sleep 20
- fi
-
# NOTE: This version actually works with gcc-3.x
./configure ${myconf} --prefix=/usr \
--sysconfdir=/etc \