summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-09-08 12:16:20 +0000
committerMichael Imhof <tantive@gentoo.org>2003-09-08 12:16:20 +0000
commit39144e235a1ad73b451b6a0c306c97d0912caff0 (patch)
tree28c8167b13a1064c5df44486d801049caa1cfe09 /app-sci/lin-seti
parentVersion bump. Closes #28024 (diff)
downloadgentoo-2-39144e235a1ad73b451b6a0c306c97d0912caff0.tar.gz
gentoo-2-39144e235a1ad73b451b6a0c306c97d0912caff0.tar.bz2
gentoo-2-39144e235a1ad73b451b6a0c306c97d0912caff0.zip
Version bump. Closes #28024
Diffstat (limited to 'app-sci/lin-seti')
-rw-r--r--app-sci/lin-seti/ChangeLog10
-rw-r--r--app-sci/lin-seti/Manifest4
-rw-r--r--app-sci/lin-seti/files/digest-lin-seti-0.7.61
-rw-r--r--app-sci/lin-seti/lin-seti-0.7.6.ebuild41
4 files changed, 52 insertions, 4 deletions
diff --git a/app-sci/lin-seti/ChangeLog b/app-sci/lin-seti/ChangeLog
index 508b2ffdb4a0..2e085f759268 100644
--- a/app-sci/lin-seti/ChangeLog
+++ b/app-sci/lin-seti/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for app-sci/lin-seti
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lin-seti/ChangeLog,v 1.8 2003/07/12 10:13:07 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lin-seti/ChangeLog,v 1.9 2003/09/08 12:16:09 tantive Exp $
+
+*lin-seti-0.7.6 (09 Sep 2003)
+
+ 09 Sep 2003; Michael Imhof <tantive@gentoo.org> :
+ lin-seti-0.7.6.ebuild:
+ Version bumped. Closes #28024.
*lin-seti-0.7.5 (12 Jul 2003)
12 Jul 2003; Michael Imhof <tantive@gentoo.org> :
- lin-seti-0.7.4.ebuild:
+ lin-seti-0.7.5.ebuild:
Version bumped
*lin-seti-0.7.4 (10 Jul 2003)
diff --git a/app-sci/lin-seti/Manifest b/app-sci/lin-seti/Manifest
index 6a06d2481545..3cf44f6495b0 100644
--- a/app-sci/lin-seti/Manifest
+++ b/app-sci/lin-seti/Manifest
@@ -1,6 +1,6 @@
-MD5 ca179e3f4ddeafe38ed865ce4f13417b ChangeLog 1341
+MD5 fcf024e53cfbf32a1c229d2adccc674d ChangeLog 1483
MD5 95138731707ae04b1c65aaac4bb6d12f lin-seti-0.7.5.ebuild 1340
-MD5 95138731707ae04b1c65aaac4bb6d12f lin-seti-0.7.6.ebuild 1340
+MD5 4b3a0052d9924ad7a62f9dc4ab06e72c lin-seti-0.7.6.ebuild 1339
MD5 36f55af924da269ce9032c8076a11d5b lin-seti-0.7.3.ebuild 1340
MD5 aad2900c6c3874bebeafa8620ce8a9cc lin-seti-0.7.4.ebuild 1342
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
diff --git a/app-sci/lin-seti/files/digest-lin-seti-0.7.6 b/app-sci/lin-seti/files/digest-lin-seti-0.7.6
new file mode 100644
index 000000000000..2481ce1b3485
--- /dev/null
+++ b/app-sci/lin-seti/files/digest-lin-seti-0.7.6
@@ -0,0 +1 @@
+MD5 dcdb3f80999546f3f12367080811d241 lin-seti-0.7.6.tar.bz2 34798
diff --git a/app-sci/lin-seti/lin-seti-0.7.6.ebuild b/app-sci/lin-seti/lin-seti-0.7.6.ebuild
new file mode 100644
index 000000000000..9392002ec734
--- /dev/null
+++ b/app-sci/lin-seti/lin-seti-0.7.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lin-seti/lin-seti-0.7.6.ebuild,v 1.1 2003/09/08 12:16:09 tantive Exp $
+
+DESCRIPTION="A Seti@Home cache manager, cache-compatible with Seti Driver. Can be run as system daemon."
+HOMEPAGE="http://lin-seti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc ~alpha"
+IUSE=""
+DEPEND="app-sci/setiathome"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ mkdir -m 755 ${D}usr
+ mkdir -m 755 ${D}usr/bin
+ mkdir -m 755 ${D}opt
+ mkdir -m 755 ${D}etc
+ mkdir -m 755 ${D}etc/init.d
+ make \
+ PREFIX=${D} \
+ install || die
+ # Let's see if this file already exists: if so we will not install it
+ if [ -a "/opt/setiathome/cache/1/user_info.sah" ]; then rm ${D}opt/setiathome/cache/1/user_info.sah; fi
+ # Otherwise the ebuild will overwrite this file!
+ # And THAT is bad: if the client runs in daemon mode,
+ # when switching to that dir it will wait forever for someone to give it
+ # some info (which would be impossible, being detached from all terminals)!
+}
+
+pkg_postinst () {
+
+ einfo "NOTICE: If you use SETI Driver for Windows"
+ einfo "to share the cache make sure it is"
+ einfo "version 1.6.4.0 or higher!"
+ sleep 5
+}