summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-04-12 01:21:49 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-04-12 01:21:49 +0000
commitee3e79db200c97eff2933c2cb7335a353f68ebf5 (patch)
tree77cd40dbb633abf90ec4acd54cf57e828344a90b /app-sci/celestia
parentrev bump so the fix to the wrapper goes out (Manifest recommit) (diff)
downloadgentoo-2-ee3e79db200c97eff2933c2cb7335a353f68ebf5.tar.gz
gentoo-2-ee3e79db200c97eff2933c2cb7335a353f68ebf5.tar.bz2
gentoo-2-ee3e79db200c97eff2933c2cb7335a353f68ebf5.zip
xorg-x11 compatibility fix.
Diffstat (limited to 'app-sci/celestia')
-rw-r--r--app-sci/celestia/ChangeLog6
-rw-r--r--app-sci/celestia/celestia-1.3.0-r1.ebuild9
-rw-r--r--app-sci/celestia/celestia-1.3.0.ebuild9
3 files changed, 19 insertions, 5 deletions
diff --git a/app-sci/celestia/ChangeLog b/app-sci/celestia/ChangeLog
index 7b59a4d5394d..cccd4b9ef851 100644
--- a/app-sci/celestia/ChangeLog
+++ b/app-sci/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/celestia
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/ChangeLog,v 1.3 2004/03/04 20:05:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/ChangeLog,v 1.4 2004/04/12 01:21:49 spyderous Exp $
+
+ 11 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ celestia-1.3.0-r1.ebuild, celestia-1.3.0.ebuild:
+ xorg-x11 compatibility fix.
25 Feb 2004; Patrick Kursawe <phosphan@gentoo.org> celestia-1.3.0-r1.ebuild:
Sandbox violation fixed
diff --git a/app-sci/celestia/celestia-1.3.0-r1.ebuild b/app-sci/celestia/celestia-1.3.0-r1.ebuild
index 4f3b9379bc10..77b39d59ee03 100644
--- a/app-sci/celestia/celestia-1.3.0-r1.ebuild
+++ b/app-sci/celestia/celestia-1.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0-r1.ebuild,v 1.3 2004/02/28 07:04:55 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0-r1.ebuild,v 1.4 2004/04/12 01:21:49 spyderous Exp $
inherit flag-o-matic kde-functions
@@ -25,10 +25,15 @@ DEPEND=">=media-libs/glut-3.7-r2
kde? ( >=kde-base/kdelibs-3.0.5 )"
pkg_setup() {
+ # Set up X11 implementation
+ X11_IMPLEM_P="$(portageq best_version "${ROOT}" virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+
einfo "Please note:"
einfo "if you experience problems building celestia with nvidia drivers,"
einfo "you can try:"
- einfo "opengl-update xfree"
+ einfo "opengl-update ${X11_IMPLEM}"
einfo "emerge celestia"
einfo "opengl-update nvidia"
einfo "------------"
diff --git a/app-sci/celestia/celestia-1.3.0.ebuild b/app-sci/celestia/celestia-1.3.0.ebuild
index 6ee5b957d510..f87b49ae2a8b 100644
--- a/app-sci/celestia/celestia-1.3.0.ebuild
+++ b/app-sci/celestia/celestia-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0.ebuild,v 1.1 2004/02/25 07:59:46 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0.ebuild,v 1.2 2004/04/12 01:21:49 spyderous Exp $
inherit flag-o-matic kde-functions
@@ -25,10 +25,15 @@ DEPEND=">=media-libs/glut-3.7-r2
!gnome? ( >=kde-base/kdelibs-3.0.5 )"
pkg_setup() {
+ # Set up X11 implementation
+ X11_IMPLEM_P="$(portageq best_version "${ROOT}" virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+
einfo "Please note:"
einfo "if you experience problems building celestia with nvidia drivers,"
einfo "you can try:"
- einfo "opengl-update xfree"
+ einfo "opengl-update ${X11_IMPLEM}"
einfo "emerge celestia"
einfo "opengl-update nvidia"
einfo "------------"