summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-05-13 18:14:07 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-05-13 18:14:07 +0000
commitc88563294b74746f8d4244338f27b7fe63c1e8b6 (patch)
tree580fa7c8fb05d6f743be83148d597b20016c7a7f /app-portage
parentversion bump (diff)
downloadgentoo-2-c88563294b74746f8d4244338f27b7fe63c1e8b6.tar.gz
gentoo-2-c88563294b74746f8d4244338f27b7fe63c1e8b6.tar.bz2
gentoo-2-c88563294b74746f8d4244338f27b7fe63c1e8b6.zip
restore old keywords
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/eix-0.10.5.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/app-portage/eix/eix-0.10.5.ebuild b/app-portage/eix/eix-0.10.5.ebuild
index 09ecb408164a..892be9ffa76c 100644
--- a/app-portage/eix/eix-0.10.5.ebuild
+++ b/app-portage/eix/eix-0.10.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.10.5.ebuild,v 1.9 2008/05/13 18:12:46 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.10.5.ebuild,v 1.10 2008/05/13 18:14:07 genstef Exp $
DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
HOMEPAGE="http://eix.sourceforge.net"
@@ -8,31 +8,31 @@ SRC_URI="mirror://sourceforge/eix/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc sqlite"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="sqlite"
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+DEPEND="sqlite? ( >=dev-db/sqlite-3 )
app-arch/bzip2"
-DEPEND="${RDEPEND}
- doc? ( dev-python/docutils )"
+RDEPEND="${DEPEND}"
src_compile() {
- econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) || die "econf failed"
+ econf --with-bzip2 $(use_with sqlite) || die "econf failed"
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog doc/format.txt
- use doc && dodoc doc/format.html
+ dodoc AUTHORS ChangeLog TODO
}
pkg_postinst() {
- ewarn
- ewarn "Security Warning:"
- ewarn
- ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
- ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
- ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ elog "As of >=eix-0.5.4, \"metadata\" is the new default cache."
+ elog "It's independent of the portage-version and the cache used by portage."
+
+ elog /etc/eixrc will not get updated anymore by the eix ebuild.
+ elog Upstream strongly recommends to remove this file resp. to keep
+ elog only those entries which you want to differ from the defaults.
+ elog Use options --dump or --dump-defaults to get an output analogous
+ elog to previous /etc/eixrc files.
}