summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-05-17 19:57:36 +0000
committerMichał Górny <mgorny@gentoo.org>2011-05-17 19:57:36 +0000
commitc6986d75be88a3abd7dc5812250ce8b6ec3427ce (patch)
tree62ecc1f436fd4b56c7b22f6f23c2da3702a47d2e /app-portage
parentupdate homepage (diff)
downloadgentoo-2-c6986d75be88a3abd7dc5812250ce8b6ec3427ce.tar.gz
gentoo-2-c6986d75be88a3abd7dc5812250ce8b6ec3427ce.tar.bz2
gentoo-2-c6986d75be88a3abd7dc5812250ce8b6ec3427ce.zip
Version bump. The new version uses remote revision fetching whenever possible and no longer touches the local repos if possible.
(Portage version: 2.2.0_alpha33_p29/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog9
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-0.8.ebuild31
2 files changed, 39 insertions, 1 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index c574021cc63b..7bf2e9092912 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.15 2011/04/24 18:24:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.16 2011/05/17 19:57:36 mgorny Exp $
+
+*smart-live-rebuild-0.8 (17 May 2011)
+
+ 17 May 2011; Michał Górny <mgorny@gentoo.org>
+ +smart-live-rebuild-0.8.ebuild:
+ Version bump. The new version uses remote revision fetching whenever possible
+ and no longer touches the local repos if possible.
*smart-live-rebuild-0.7.2 (24 Apr 2011)
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.ebuild
new file mode 100644
index 000000000000..8fdcee622241
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.ebuild,v 1.1 2011/05/17 19:57:36 mgorny Exp $
+
+EAPI=3
+PYTHON_DEPEND='*:2.6'
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='2.4 2.5'
+inherit distutils
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1.8.3"
+
+PYTHON_MODNAME=SmartLiveRebuild
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,} || die
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf || die
+}