summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-09-17 21:15:08 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-09-17 21:15:08 +0000
commitbed6c0861c9043e03e936f9e301dc1125dcf1007 (patch)
treee411a219ccdfc4225c8b17e848d19a298e16dd77 /app-portage
parentStabilize #376413 by Pacho Ramos. (diff)
downloadgentoo-2-bed6c0861c9043e03e936f9e301dc1125dcf1007.tar.gz
gentoo-2-bed6c0861c9043e03e936f9e301dc1125dcf1007.tar.bz2
gentoo-2-bed6c0861c9043e03e936f9e301dc1125dcf1007.zip
Version bump. Use PYTHON_USE_WITH. Move/Migrate $EROOT/var/lib/layman/overlays.xml to .../installed.xml.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/layman/ChangeLog9
-rw-r--r--app-portage/layman/layman-2.0.0_rc3.ebuild98
-rw-r--r--app-portage/layman/layman-9999.ebuild13
3 files changed, 117 insertions, 3 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index 0bde9578748b..97974aa09297 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/layman
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.146 2011/08/12 01:46:26 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.147 2011/09/17 21:15:08 idl0r Exp $
+
+*layman-2.0.0_rc3 (17 Sep 2011)
+
+ 17 Sep 2011; Christian Ruppert <idl0r@gentoo.org> +layman-2.0.0_rc3.ebuild,
+ layman-9999.ebuild:
+ Version bump. Use PYTHON_USE_WITH. Move/Migrate
+ $EROOT/var/lib/layman/overlays.xml to .../installed.xml.
12 Aug 2011; Paul Varner <fuzzyray@gentoo.org> layman-9999.ebuild:
Update with Gentoo Prefix modifications
diff --git a/app-portage/layman/layman-2.0.0_rc3.ebuild b/app-portage/layman/layman-2.0.0_rc3.ebuild
new file mode 100644
index 000000000000..b1f9365ff40a
--- /dev/null
+++ b/app-portage/layman/layman-2.0.0_rc3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-2.0.0_rc3.ebuild,v 1.1 2011/09/17 21:15:08 idl0r Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_USE_WITH="xml"
+
+inherit eutils distutils prefix
+
+DESCRIPTION="Tool to manage Gentoo overlays"
+HOMEPAGE="http://layman.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bazaar cvs darcs git mercurial subversion test"
+
+COMMON_DEPS="dev-lang/python"
+DEPEND="${COMMON_DEPS}
+ test? ( dev-vcs/subversion )"
+RDEPEND="${COMMON_DEPS}
+ bazaar? ( dev-vcs/bzr )
+ cvs? ( dev-vcs/cvs )
+ darcs? ( dev-vcs/darcs )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? (
+ || (
+ >=dev-vcs/subversion-1.5.4[webdav-neon]
+ >=dev-vcs/subversion-1.5.4[webdav-serf]
+ )
+ )"
+
+src_prepare() {
+ eprefixify etc/layman.cfg layman/config.py
+}
+
+src_test() {
+ testing() {
+ for suite in layman/tests/{dtest,external}.py ; do
+ PYTHONPATH="." "$(PYTHON)" ${suite} \
+ || die "test suite '${suite}' failed"
+ done
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/layman
+ doins etc/layman.cfg || die
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+ keepdir /var/lib/layman
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ ewarn "The installed db file '%(storage)/overlays.xml'"
+ ewarn "has been renamed to '%(storage)/installed.xml'"
+
+ if "${EROOT}/var/lib/layman/overlays.xml"; then
+ mv "${EROOT}/var/lib/layman/overlays.xml" "${EROOT}/var/lib/layman/installed.xml"
+ einfo "${EROOT}/var/lib/layman/overlays.xml has been moved to ${EROOT}/var/lib/layman/installed.xml"
+ fi
+
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo " layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ elog "Select an overlay and add it using"
+ elog
+ elog " layman -a overlay-name"
+ elog
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog " source /var/lib/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ elog
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+}
diff --git a/app-portage/layman/layman-9999.ebuild b/app-portage/layman/layman-9999.ebuild
index d645cb83af84..937613cd3f55 100644
--- a/app-portage/layman/layman-9999.ebuild
+++ b/app-portage/layman/layman-9999.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-9999.ebuild,v 1.21 2011/08/12 01:46:26 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-9999.ebuild,v 1.22 2011/09/17 21:15:08 idl0r Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="2:2.6"
RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_USE_WITH="xml"
inherit eutils distutils git-2 prefix
@@ -19,7 +20,7 @@ SLOT="0"
KEYWORDS=""
IUSE="bazaar cvs darcs git mercurial subversion test"
-COMMON_DEPS="dev-lang/python[xml]"
+COMMON_DEPS="dev-lang/python"
DEPEND="${COMMON_DEPS}
test? ( dev-vcs/subversion )
app-text/asciidoc"
@@ -71,6 +72,14 @@ src_install() {
pkg_postinst() {
distutils_pkg_postinst
+ ewarn "The installed db file '%(storage)/overlays.xml'"
+ ewarn "has been renamed to '%(storage)/installed.xml'"
+
+ if "${EROOT}/var/lib/layman/overlays.xml"; then
+ mv "${EROOT}/var/lib/layman/overlays.xml" "${EROOT}/var/lib/layman/installed.xml"
+ einfo "${EROOT}/var/lib/layman/overlays.xml has been moved to ${EROOT}/var/lib/layman/installed.xml"
+ fi
+
einfo "You are now ready to add overlays into your system."
einfo
einfo " layman -L"