summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-04-23 12:07:05 +0000
committerThomas Kahle <tomka@gentoo.org>2013-04-23 12:07:05 +0000
commit9b313e66d933d43fe65db1d44b169a1dec230202 (patch)
treea7e5f204df8de54eeeec826553e4fc108f3896f8 /app-portage
parentVersion bump, thanks to Adam Reichold <adamreichold AT myopera.com> (diff)
downloadgentoo-2-9b313e66d933d43fe65db1d44b169a1dec230202.tar.gz
gentoo-2-9b313e66d933d43fe65db1d44b169a1dec230202.tar.bz2
gentoo-2-9b313e66d933d43fe65db1d44b169a1dec230202.zip
0.1 release and distutils-r1 migration
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/tatt/ChangeLog11
-rw-r--r--app-portage/tatt/tatt-0.1.ebuild35
-rw-r--r--app-portage/tatt/tatt-9999.ebuild34
3 files changed, 60 insertions, 20 deletions
diff --git a/app-portage/tatt/ChangeLog b/app-portage/tatt/ChangeLog
index c8858b0073f3..ebb6d813ae9d 100644
--- a/app-portage/tatt/ChangeLog
+++ b/app-portage/tatt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/tatt
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/tatt/ChangeLog,v 1.3 2011/09/13 13:54:56 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/tatt/ChangeLog,v 1.4 2013/04/23 12:07:05 tomka Exp $
+
+*tatt-0.1 (23 Apr 2013)
+
+ 23 Apr 2013; Thomas Kahle <tomka@gentoo.org> +tatt-0.1.ebuild,
+ tatt-9999.ebuild:
+ 0.1 release and distutils-r1 migration
13 Sep 2011; Thomas Kahle <tomka@gentoo.org> tatt-9999.ebuild:
Fixing python dependencies and use git-2.eclass (Bug 382767)
@@ -13,4 +19,3 @@
27 Jul 2010; Christian Faulhammer <fauli@gentoo.org> +tatt-9999.ebuild,
+metadata.xml:
initial import, ebuild written by Thomas Kahle, who is upstream
-
diff --git a/app-portage/tatt/tatt-0.1.ebuild b/app-portage/tatt/tatt-0.1.ebuild
new file mode 100644
index 000000000000..981ac121b5e5
--- /dev/null
+++ b/app-portage/tatt/tatt-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/tatt/tatt-0.1.ebuild,v 1.1 2013/04/23 12:07:05 tomka Exp $
+
+EAPI=5
+
+#configobj does not support python-3
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="tatt is an arch testing tool"
+HOMEPAGE="https://github.com/tom111/tatt"
+SRC_URI="https://github.com/tom111/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+templates"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-portage/eix
+ app-portage/gentoolkit
+ www-client/pybugz
+ dev-python/configobj"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates || die
+ fi
+}
diff --git a/app-portage/tatt/tatt-9999.ebuild b/app-portage/tatt/tatt-9999.ebuild
index ecb24c7cd394..6bc9301f5ad8 100644
--- a/app-portage/tatt/tatt-9999.ebuild
+++ b/app-portage/tatt/tatt-9999.ebuild
@@ -1,35 +1,35 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/tatt/tatt-9999.ebuild,v 1.4 2011/09/13 13:54:56 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/tatt/tatt-9999.ebuild,v 1.5 2013/04/23 12:07:05 tomka Exp $
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
+EAPI=5
-inherit distutils git-2
+#configobj does not support python-3
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1 git-2
DESCRIPTION="tatt is an arch testing tool"
HOMEPAGE="http://github.com/tom111/tatt"
-EGIT_REPO_URI="git://github.com/tom111/tatt.git"
+EGIT_REPO_URI="https://github.com/tom111/tatt.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="+templates"
-DEPEND="dev-python/setuptools"
-RDEPEND="app-portage/eix
- app-portage/gentoolkit
- www-client/pybugz
- dev-python/configobj"
-
-#configobj does not support python-3
-RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-portage/eix
+ app-portage/gentoolkit
+ www-client/pybugz
+ dev-python/configobj"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}"
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
if use templates; then
insinto "/usr/share/${PN}"
doins -r templates || die