summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2006-11-01 19:32:35 +0000
committerPaul Varner <fuzzyray@gentoo.org>2006-11-01 19:32:35 +0000
commit758abb3acb15171dcee38445b03c7cd83edadd11 (patch)
treee5cc650d8b9f861fd1840484fff0bf173c95ce16 /app-portage
parentFixed charset.txt issue, thanks to Roger Ward, closes bug#153487 (diff)
downloadgentoo-2-758abb3acb15171dcee38445b03c7cd83edadd11.tar.gz
gentoo-2-758abb3acb15171dcee38445b03c7cd83edadd11.tar.bz2
gentoo-2-758abb3acb15171dcee38445b03c7cd83edadd11.zip
Revision bump to fix "Unknown USE component" errors
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/udept/ChangeLog8
-rw-r--r--app-portage/udept/files/digest-udept-0.5.99.0.2.95-r13
-rw-r--r--app-portage/udept/files/udept.default-use.patch24
-rw-r--r--app-portage/udept/udept-0.5.99.0.2.95-r1.ebuild36
4 files changed, 70 insertions, 1 deletions
diff --git a/app-portage/udept/ChangeLog b/app-portage/udept/ChangeLog
index 1d6f9aea1051..f55f2968b8cc 100644
--- a/app-portage/udept/ChangeLog
+++ b/app-portage/udept/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/udept
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/udept/ChangeLog,v 1.7 2006/10/22 10:15:39 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/udept/ChangeLog,v 1.8 2006/11/01 19:32:35 fuzzyray Exp $
+
+*udept-0.5.99.0.2.95-r1 (01 Nov 2006)
+
+ 01 Nov 2006; Paul Varner <fuzzyray@gentoo.org>
+ +files/udept.default-use.patch, +udept-0.5.99.0.2.95-r1.ebuild:
+ Revision bump to fix "Unknown USE component" errors
22 Oct 2006; Michael Hanselmann <hansmi@gentoo.org>
udept-0.5.99.0.2.95.ebuild:
diff --git a/app-portage/udept/files/digest-udept-0.5.99.0.2.95-r1 b/app-portage/udept/files/digest-udept-0.5.99.0.2.95-r1
new file mode 100644
index 000000000000..0383f6659f2c
--- /dev/null
+++ b/app-portage/udept/files/digest-udept-0.5.99.0.2.95-r1
@@ -0,0 +1,3 @@
+MD5 70229ec6f1586c1c43d15fe5e1a40856 udept-0.5.99.0.2.95.tar.bz2 89028
+RMD160 bd4b8bbc40fa5b57f694eb79125d8ca2fbd2c33c udept-0.5.99.0.2.95.tar.bz2 89028
+SHA256 c5a8cea71b802c63b2aaf9aeefb4bc377a8f927f8291027f5d03a2cf2673bb9a udept-0.5.99.0.2.95.tar.bz2 89028
diff --git a/app-portage/udept/files/udept.default-use.patch b/app-portage/udept/files/udept.default-use.patch
new file mode 100644
index 000000000000..d6163916b0c1
--- /dev/null
+++ b/app-portage/udept/files/udept.default-use.patch
@@ -0,0 +1,24 @@
+Index: dep.in
+===================================================================
+--- udept-0.5.99.0.2.95/src/dep.in (revision 909)
++++ udept-0.5.99.0.2.95/src/dep.in (working copy)
+@@ -1145,6 +1145,8 @@
+ function usecomponent() {
+ # return a USE component, one flag per line, highest priority first
+ # TODO FIXME not correct yet - though OK for default case
++ # Added placeholders for default USE flag implementation
++ # See http://bugs.gentoo.org/show_bug.cgi?id=61732
+ local component="$1" cpv="$2"
+ case "$component" in
+ env) sed 's/[[:space:]]\+/\n/g' <<<"$USE" | tac;;
+@@ -1154,8 +1156,10 @@
+ dep_satisfies "$cpv" $package && echo $use
+ done | sed 's/[[:space:]]\+/\n/g';;
+ conf) sed 's/[[:space:]]\+/\n/g' <<<"$__conf_USE";;
++ pkgprofile);;
+ auto) autouse;;
+ defaults);;
++ pkginternal);;
+ *) format_error <<<"Unknown USE component: $component" >&2;;
+ esac
+ }
diff --git a/app-portage/udept/udept-0.5.99.0.2.95-r1.ebuild b/app-portage/udept/udept-0.5.99.0.2.95-r1.ebuild
new file mode 100644
index 000000000000..a48eee95e83a
--- /dev/null
+++ b/app-portage/udept/udept-0.5.99.0.2.95-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/udept/udept-0.5.99.0.2.95-r1.ebuild,v 1.1 2006/11/01 19:32:35 fuzzyray Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="A Portage analysis toolkit"
+HOMEPAGE="http://catmur.co.uk/gentoo/udept"
+SRC_URI="http://files.catmur.co.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-shells/bash
+ sys-apps/portage"
+RDEPEND="${DEPEND}"
+
+BASH_COMPLETION_NAME="dep"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/udept.default-use.patch"
+}
+
+src_compile() {
+ econf $(use_enable bash-completion) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog*
+}