summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-09-21 14:08:39 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-09-21 14:08:39 +0000
commit4e33cda50c9606140613b68e356744b721c681fc (patch)
tree4fbac17e5bc9c2c36bf78d19c2eaf818660c5dfd /app-portage
parentstable ppc, bug 238056 (diff)
downloadgentoo-2-4e33cda50c9606140613b68e356744b721c681fc.tar.gz
gentoo-2-4e33cda50c9606140613b68e356744b721c681fc.tar.bz2
gentoo-2-4e33cda50c9606140613b68e356744b721c681fc.zip
Add 0.13.3-r1 for fast-track stabilization
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/eix-0.13.3-r1.ebuild48
-rw-r--r--app-portage/eix/files/eix-0.13.3-numeric-compare.patch84
3 files changed, 139 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index be87ddbc6cdd..df8740125d15 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.237 2008/09/21 13:36:18 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.238 2008/09/21 14:08:38 loki_val Exp $
+
+*eix-0.13.3-r1 (21 Sep 2008)
+
+ 21 Sep 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/eix-0.13.3-numeric-compare.patch, +eix-0.13.3-r1.ebuild:
+ Add 0.13.3-r1 for fast-track stabilization
*eix-0.13.5 (21 Sep 2008)
diff --git a/app-portage/eix/eix-0.13.3-r1.ebuild b/app-portage/eix/eix-0.13.3-r1.ebuild
new file mode 100644
index 000000000000..50aa79fedc41
--- /dev/null
+++ b/app-portage/eix/eix-0.13.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.13.3-r1.ebuild,v 1.1 2008/09/21 14:08:38 loki_val Exp $
+
+inherit base
+
+DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc sqlite"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+PATCHES=( "${FILESDIR}/${P}-numeric-compare.patch" )
+
+src_compile() {
+ econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog doc/format.txt
+ use doc && dodoc doc/format.html
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Security Warning:"
+ ewarn
+ ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
+ ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ if test -d /var/log && ! test -x /var/log || test -e /var/log/eix-sync.log
+ then
+ einfo
+ einfo "eix-sync no longer supports redirection to /var/log/eix-sync.log"
+ einfo "You can remove that file."
+ fi
+}
diff --git a/app-portage/eix/files/eix-0.13.3-numeric-compare.patch b/app-portage/eix/files/eix-0.13.3-numeric-compare.patch
new file mode 100644
index 000000000000..3f06e9d016af
--- /dev/null
+++ b/app-portage/eix/files/eix-0.13.3-numeric-compare.patch
@@ -0,0 +1,84 @@
+Index: trunk/src/eixTk/compare.h
+===================================================================
+--- trunk/src/eixTk/compare.h (revision 590)
++++ trunk/src/eixTk/compare.h (revision 730)
+@@ -1,3 +1,3 @@
+-// vim:set et cinoptions=g0,t0,^-2,(0 sw=4 ts=4:
++// vim:set noet cinoptions=g0,t0,(0 sw=4 ts=4:
+ // This file is part of the eix project and distributed under the
+ // terms of the GNU General Public License v2.
+@@ -5,4 +5,5 @@
+ // Copyright (c)
+ // Emil Beinroth <emilbeinroth@gmx.net>
++// Martin VÀth <vaeth@mathematik.uni-wuerzburg.de>
+
+ #ifndef __GUARD__COMPARE_H__
+@@ -14,34 +15,40 @@
+ namespace eix
+ {
+- /// compare two objects.
+- /// @return 0 if equal, 1 if left > right or -1 if left < right.
+- template<typename T>
+- int default_compare(const T& left, const T& right)
+- {
+- if (left == right)
+- return 0;
+- else if(left < right)
+- return -1;
+- else
+- return 1;
+- }
++ /// compare two objects.
++ /// @return 0 if equal, 1 if left > right or -1 if left < right.
++ template<typename T>
++ int default_compare(const T& left, const T& right)
++ {
++ if (left == right)
++ return 0;
++ if(left < right)
++ return -1;
++ return 1;
++ }
+
+- /// numeric comparison.
+- /// @note empty strings count a "0"
+- static inline int
+- numeric_compare(const std::string& left, const std::string& right)
+- {
+- // strip leading 0's
+- const std::string::size_type lstart = left.find_first_not_of('0');
+- const std::string::size_type rstart = right.find_first_not_of('0');
++ /// numeric comparison.
++ /// @note empty strings count a "0"
++ static inline int
++ numeric_compare(const std::string& left, const std::string& right)
++ {
++ // strip leading 0's
++ std::string::size_type lstart = left.find_first_not_of('0');
++ std::string::size_type rstart = right.find_first_not_of('0');
++ // Special cases: number is 0 or string is empty
++ if (lstart == std::string::npos) {
++ if(rstart == std::string::npos)
++ return 0;
++ return -1;
++ }
++ if (rstart == std::string::npos)
++ return 1;
+
+- // check if one is longer, that one would be bigger
+- const int size_result = default_compare(left.size() - (lstart == std::string::npos ? 0 : lstart),
+- right.size() - (rstart == std::string::npos ? 0 : rstart));
+- if (size_result)
+- return size_result;
+- // both strings have the same length, do string comparison
+- return left.compare(lstart, std::string::npos, right, rstart, std::string::npos);
+- }
++ // check if one is longer, that one would be bigger
++ int size_result = default_compare(left.size() - lstart, right.size() - rstart);
++ if (size_result)
++ return size_result;
++ // both strings have the same length, do string comparison
++ return left.compare(lstart, std::string::npos, right, rstart, std::string::npos);
++ }
+ }
+