summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-06-19 17:57:23 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-06-19 17:57:23 +0000
commit364cd35e05c6b37e63268eb0663516730897a372 (patch)
tree6127ab78ca5ec3c2ea14c0edae914341436d894e /app-portage
parentFixed security issue. (diff)
downloadgentoo-2-364cd35e05c6b37e63268eb0663516730897a372.tar.gz
gentoo-2-364cd35e05c6b37e63268eb0663516730897a372.tar.bz2
gentoo-2-364cd35e05c6b37e63268eb0663516730897a372.zip
Revision bump to fix bug 323179, thanks to Kete Tefid <ketetefid@gmail.com>.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/porthole/ChangeLog9
-rw-r--r--app-portage/porthole/files/porthole-0.6.1-missing_import.patch19
-rw-r--r--app-portage/porthole/porthole-0.6.1-r2.ebuild76
3 files changed, 103 insertions, 1 deletions
diff --git a/app-portage/porthole/ChangeLog b/app-portage/porthole/ChangeLog
index 347dc416e2dc..406d83a35080 100644
--- a/app-portage/porthole/ChangeLog
+++ b/app-portage/porthole/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/porthole
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.48 2010/05/17 22:29:28 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.49 2010/06/19 17:57:22 idl0r Exp $
+
+*porthole-0.6.1-r2 (19 Jun 2010)
+
+ 19 Jun 2010; Christian Ruppert <idl0r@gentoo.org>
+ +porthole-0.6.1-r2.ebuild, +files/porthole-0.6.1-missing_import.patch:
+ Revision bump to fix bug 323179, thanks to Kete Tefid
+ <ketetefid@gmail.com>.
17 May 2010; Kenneth Prugh <ken69267@gentoo.org> porthole-0.6.1-r1.ebuild:
amd64 stable, bug #313443
diff --git a/app-portage/porthole/files/porthole-0.6.1-missing_import.patch b/app-portage/porthole/files/porthole-0.6.1-missing_import.patch
new file mode 100644
index 000000000000..33c9e4ee3353
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.1-missing_import.patch
@@ -0,0 +1,19 @@
+--- porthole/db/user_configs.py 2010/03/20 12:32:29 1217
++++ porthole/db/user_configs.py 2010/03/20 14:10:46 1218
+@@ -36,6 +36,7 @@
+ from porthole import backends
+ portage_lib = backends.portage_lib
+ from porthole.utils import debug
++from porthole.privilege import controller as privileges
+
+ ## set up this module to act as a user configs data server,
+ ## watch the user configs for changes and auto update
+@@ -363,7 +364,7 @@
+ debug.dprint("USER_CONFIGS: set_user_config(): add: " +
+ "%s,\n remove: %s " %(str(add),str(remove)))
+ set_config.set_user_config(filename=file, name=name, ebuild=ebuild,
+- comment=comment, username=priviliges.USER,
++ comment=comment, username=privileges.USER,
+ add=add, remove=remove)
+ self.set_config_callback()
+ else:
diff --git a/app-portage/porthole/porthole-0.6.1-r2.ebuild b/app-portage/porthole/porthole-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..cd38995a0ede
--- /dev/null
+++ b/app-portage/porthole/porthole-0.6.1-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.1-r2.ebuild,v 1.1 2010/06/19 17:57:22 idl0r Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="xml threads"
+
+inherit distutils eutils
+
+DESCRIPTION="A GTK+-based frontend to Portage"
+HOMEPAGE="http://porthole.sourceforge.net"
+SRC_URI="mirror://sourceforge/porthole/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+LANGS="de pl ru vi it fr tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=dev-python/pygtk-2.4.0
+ >=gnome-base/libglade-2.5.0
+ dev-python/pygtksourceview:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.14 )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-masking_status.patch" # bug 307037
+ epatch "${FILESDIR}/${P}-missing_import.patch" # bug 323179
+}
+
+src_compile(){
+ # Compile localizations if necessary
+ if use nls ; then
+ cd scripts
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc TODO README NEWS AUTHORS
+
+ keepdir /var/log/porthole
+ fperms g+w /var/log/porthole
+ keepdir /var/db/porthole
+ fperms g+w /var/db/porthole
+
+ # nls
+ if use nls; then
+ # mo directory doesn't exists with nls enabled and unsupported LINGUAS
+ [[ -d porthole/i18n/mo ]] && domo porthole/i18n/mo/*
+ fi
+}
+
+pkg_preinst() {
+ chgrp portage "${D}"/var/log/porthole
+ chgrp portage "${D}"/var/db/porthole
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Porthole has updated the way that the upgrades are sent to emerge."
+ einfo "In this new way the user needs to set any 'Settings' menu emerge options"
+ einfo "Porthole automatically adds '--oneshot' for all upgrades selections"
+ einfo "Other options recommended are '--noreplace' along with '--update'"
+ einfo "They allow for portage to skip any packages that might have already"
+ einfo "been upgraded as a dependency of another previously upgraded package"
+ einfo
+}