summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-07 17:15:17 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-07 17:15:17 +0000
commit87c5b93d5a8086fe37b75911405ebfaaba3d0858 (patch)
treef45aeb1f11e5930ba1d834e06955a8083fb7daef /app-pda
parentDont bother defining pkg_setup as the eclass will do it for us as noted by Do... (diff)
downloadgentoo-2-87c5b93d5a8086fe37b75911405ebfaaba3d0858.tar.gz
gentoo-2-87c5b93d5a8086fe37b75911405ebfaaba3d0858.tar.bz2
gentoo-2-87c5b93d5a8086fe37b75911405ebfaaba3d0858.zip
Added a patch to correct upstream's broken check for Werror and disabled it explicitly. Fixes bug 194921. Fixed several quoting issues and other minor QA stuff.
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog9
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.2-werror_194921.patch18
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild4
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8.ebuild15
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.2.ebuild6
5 files changed, 40 insertions, 12 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 45286d7de593..6c97d66233bd 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/pilot-link
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.29 2007/09/18 21:04:18 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.30 2007/10/07 17:15:16 philantrop Exp $
+
+ 07 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/pilot-link-0.12.2-werror_194921.patch, pilot-link-0.11.8.ebuild,
+ pilot-link-0.11.8-r1.ebuild, pilot-link-0.12.2.ebuild:
+ Added a patch to correct upstream's broken check for Werror and disabled it
+ explicitly. Fixes bug 194921. Fixed several quoting issues and other minor
+ QA stuff.
18 Sep 2007; Wulf C. Krueger <philantrop@gentoo.org>
+files/pilot-link-0.11.8-missing-include.patch,
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.2-werror_194921.patch b/app-pda/pilot-link/files/pilot-link-0.12.2-werror_194921.patch
new file mode 100644
index 000000000000..a49000490d5d
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.2-werror_194921.patch
@@ -0,0 +1,18 @@
+diff -Naur pilot-link-0.12.2.orig/configure.ac pilot-link-0.12.2/configure.ac
+--- pilot-link-0.12.2.orig/configure.ac 2007-10-07 18:18:47.000000000 +0200
++++ pilot-link-0.12.2/configure.ac 2007-10-07 18:18:35.000000000 +0200
+@@ -757,11 +757,9 @@
+ dnl *************************************
+ dnl (already done) enable_werror=no
+
+-AC_ARG_ENABLE(compile-werror,
+- [ --enable-compile-werror
+- Causes warnings to be treated as errors in GCC],
+- enable_werror=yes)
+-if test "x$GCC" = "xyes" -a "x$enable_werror" = "xyes"; then
++AC_ARG_ENABLE([compile-werror], AS_HELP_STRING([--enable-compile-werror], [Causes warnings to be treated as errors in GCC (default: disabled)]))
++
++if test "x$GCC" = "xyes" -a "x$enable_compile_werror" = "xyes"; then
+ CFLAGS="$CFLAGS -Werror"
+ fi
+
diff --git a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
index 9bb3a99f35e2..e72881b943e9 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.19 2007/09/18 21:04:18 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.20 2007/10/07 17:15:16 philantrop Exp $
inherit perl-module eutils
@@ -88,7 +88,7 @@ src_install() {
dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
if use perl ; then
- cd ${S}/bindings/Perl
+ cd "${S}/bindings/Perl"
perl-module_src_install
fi
}
diff --git a/app-pda/pilot-link/pilot-link-0.11.8.ebuild b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
index d7190f67b14e..1094c31f7888 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.16 2006/11/28 17:34:39 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.17 2007/10/07 17:15:16 philantrop Exp $
inherit perl-module eutils
@@ -13,8 +13,7 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
IUSE="perl java tk python png readline"
-DEPEND="virtual/libc
- sys-libs/ncurses
+DEPEND="sys-libs/ncurses
perl? ( dev-lang/perl )
java? ( virtual/jre )
tk? ( dev-lang/tcl dev-tcltk/itcl dev-lang/tk )
@@ -24,7 +23,7 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-java_install_all.patch
+ epatch "${FILESDIR}/${P}-java_install_all.patch"
}
src_compile() {
@@ -57,19 +56,19 @@ src_compile() {
make || die
if use perl ; then
- cd ${S}/bindings/Perl
+ cd "${S}/bindings/Perl"
perl-module_src_prep
perl-module_src_compile
fi
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
if use perl ; then
- cd ${S}/bindings/Perl
+ cd "${S}/bindings/Perl"
perl-module_src_install
fi
}
diff --git a/app-pda/pilot-link/pilot-link-0.12.2.ebuild b/app-pda/pilot-link/pilot-link-0.12.2.ebuild
index a2287c9bd1da..b177dbf63e4e 100644
--- a/app-pda/pilot-link/pilot-link-0.12.2.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.2.ebuild,v 1.1 2007/08/25 19:17:04 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.2.ebuild,v 1.2 2007/10/07 17:15:16 philantrop Exp $
inherit perl-module java-pkg-opt-2 eutils autotools
@@ -43,6 +43,9 @@ src_unpack() {
epatch "${FILESDIR}/${P}-readline.patch"
epatch "${FILESDIR}/${P}-threads.patch"
+ # Upstream's check for Werror was wrong. Fxies bug 194921.
+ epatch "${FILESDIR}/${P}-werror_194921.patch"
+
# Some Java fixes.
if use java ; then
epatch "${FILESDIR}/${P}-java-compile.patch"
@@ -59,6 +62,7 @@ src_compile() {
--enable-conduits \
--with-tcl=no \
--without-included-popt \
+ --disable-compile-werror \
$(use_enable threads) \
$(use_enable usb libusb) \
$(use_enable debug) \