summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-22 10:32:49 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-22 10:32:49 +0000
commit37c80b52657693cf1809763f30d308dabf51eed3 (patch)
treeab35b03035ec1e0079077b288042ce6c20688402 /app-pda
parentfixed wrong keywords, my error, sorry (diff)
downloadgentoo-2-37c80b52657693cf1809763f30d308dabf51eed3.tar.gz
gentoo-2-37c80b52657693cf1809763f30d308dabf51eed3.tar.bz2
gentoo-2-37c80b52657693cf1809763f30d308dabf51eed3.zip
added patch for fix compile error, cleaned up patching in ebuild and changed to use_with for econf options. (#141222)
(Portage version: 2.1-r2)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/coldsync/ChangeLog8
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild21
-rw-r--r--app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff23
-rw-r--r--app-pda/coldsync/files/digest-coldsync-2.2.5-r12
4 files changed, 44 insertions, 10 deletions
diff --git a/app-pda/coldsync/ChangeLog b/app-pda/coldsync/ChangeLog
index 91e9688540ec..2cae6d4675fb 100644
--- a/app-pda/coldsync/ChangeLog
+++ b/app-pda/coldsync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/coldsync
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/ChangeLog,v 1.7 2006/03/12 08:04:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/ChangeLog,v 1.8 2006/08/22 10:32:49 liquidx Exp $
+
+ 22 Aug 2006; Alastair Tse <liquidx@gentoo.org>
+ +files/coldsync-2.2.5-broken-c++.diff, -coldsync-2.2.5.ebuild,
+ coldsync-2.2.5-r1.ebuild:
+ added patch for fix compile error, cleaned up patching in ebuild and changed
+ to use_with for econf options. (#141222)
*coldsync-3.0_pre4 (12 Mar 2006)
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
index e54df057a1ed..50b3b45be9ab 100644
--- a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
+++ b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.7 2005/07/22 17:21:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.8 2006/08/22 10:32:49 liquidx Exp $
+
+inherit eutils
DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
SRC_URI="http://www.coldsync.org/download/${P}.tar.gz"
@@ -11,15 +13,16 @@ LICENSE="Artistic"
KEYWORDS="~ppc sparc x86"
IUSE="nls perl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/coldsync-2.2.5-gcc3.diff
+ epatch ${FILESDIR}/coldsync-2.2.5-broken-c++.diff
+}
+
src_compile() {
cd ${S}
- local myconf
- use nls || myconf="${myconf} --without-i18n"
- use perl || myconf="${myconf} --without-perl"
-
- patch -p1 < ${FILESDIR}/coldsync-2.2.5-gcc3.diff
-
- econf ${myconf} || die "configuring coldsync failed"
+ econf $(use_with nls i18n) $(use_with perl)
make || die "couldn't make coldsync"
}
diff --git a/app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff b/app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff
new file mode 100644
index 000000000000..48693632ccbb
--- /dev/null
+++ b/app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff
@@ -0,0 +1,23 @@
+diff -Naur coldsync-2.2.5/src/symboltable.cc coldsync-2.2.5-new/src/symboltable.cc
+--- coldsync-2.2.5/src/symboltable.cc 2001-11-13 07:48:07.000000000 -0800
++++ coldsync-2.2.5-new/src/symboltable.cc 2006-08-14 16:42:10.000000000 -0700
+@@ -12,6 +12,7 @@
+ #include <map>
+ #include <cstdlib> // For malloc() and friends
+ #include "symboltable.h"
++using namespace std;
+
+ static char *make_c_string(const string &s);
+
+diff -Naur coldsync-2.2.5/src/symboltable.h coldsync-2.2.5-new/src/symboltable.h
+--- coldsync-2.2.5/src/symboltable.h 2001-10-17 18:39:10.000000000 -0700
++++ coldsync-2.2.5-new/src/symboltable.h 2006-08-14 16:42:10.000000000 -0700
+@@ -26,7 +26,7 @@
+ /* Initialize the symbol table based on the
+ * arguments. */
+ #ifdef __cplusplus
+-};
++}
+ #endif /* __cplusplus */
+
+ /* This is for Emacs's benefit:
diff --git a/app-pda/coldsync/files/digest-coldsync-2.2.5-r1 b/app-pda/coldsync/files/digest-coldsync-2.2.5-r1
index 73055c37fa32..8ac88b92beab 100644
--- a/app-pda/coldsync/files/digest-coldsync-2.2.5-r1
+++ b/app-pda/coldsync/files/digest-coldsync-2.2.5-r1
@@ -1 +1,3 @@
MD5 cba1d751a51d50a1983a7e0245820099 coldsync-2.2.5.tar.gz 663307
+RMD160 76d1065c3558f26f22a94d67e26e0ed25a2367fd coldsync-2.2.5.tar.gz 663307
+SHA256 635575e2175a865827319ad21cbfbac95a42a7256730898ae9e9104b63b4fef6 coldsync-2.2.5.tar.gz 663307