summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-13 21:25:07 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-13 21:25:07 +0000
commitef7f1397d9aae5ded2bd5095a5a13622f726b6a9 (patch)
treeac500be28c76eace059535614472755d1d0676d1 /app-pda/synce-libsynce
parentRemove obsolete version. Fix the as-needed patch (#140255). (diff)
downloadgentoo-2-ef7f1397d9aae5ded2bd5095a5a13622f726b6a9.tar.gz
gentoo-2-ef7f1397d9aae5ded2bd5095a5a13622f726b6a9.tar.bz2
gentoo-2-ef7f1397d9aae5ded2bd5095a5a13622f726b6a9.zip
Version bump. Removed slang.h header include and replaced it with the single 'offsetof' macro that it needed. Cleaned up old versions. (#135060)
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-pda/synce-libsynce')
-rw-r--r--app-pda/synce-libsynce/ChangeLog10
-rw-r--r--app-pda/synce-libsynce/files/digest-synce-libsynce-0.9.23
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild38
3 files changed, 50 insertions, 1 deletions
diff --git a/app-pda/synce-libsynce/ChangeLog b/app-pda/synce-libsynce/ChangeLog
index 61d50bfeac60..76fc98cf7db3 100644
--- a/app-pda/synce-libsynce/ChangeLog
+++ b/app-pda/synce-libsynce/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-pda/synce-libsynce
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/ChangeLog,v 1.18 2006/06/22 10:31:55 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/ChangeLog,v 1.19 2006/07/13 21:25:07 liquidx Exp $
+
+*synce-libsynce-0.9.2 (13 Jul 2006)
+
+ 13 Jul 2006; Alastair Tse <liquidx@gentoo.org> -synce-libsynce-0.7.ebuild,
+ -synce-libsynce-0.8.1.ebuild, -synce-libsynce-0.9.0.ebuild,
+ +synce-libsynce-0.9.2.ebuild:
+ Version bump. Removed slang.h header include and replaced it with the single
+ 'offsetof' macro that it needed. Cleaned up old versions. (#135060)
22 Jun 2006; Karol Wojtaszek <sekretarz@gentoo.org>
+files/synce-libsynce-0.9.1-amd64.patch, synce-libsynce-0.9.1.ebuild:
diff --git a/app-pda/synce-libsynce/files/digest-synce-libsynce-0.9.2 b/app-pda/synce-libsynce/files/digest-synce-libsynce-0.9.2
new file mode 100644
index 000000000000..59cbf32678be
--- /dev/null
+++ b/app-pda/synce-libsynce/files/digest-synce-libsynce-0.9.2
@@ -0,0 +1,3 @@
+MD5 c75f68c28bcae07f2a369dd49a3c6767 synce-libsynce-0.9.2.tar.gz 365167
+RMD160 27bfcd933279c48809ba75ce764fb82e69661a34 synce-libsynce-0.9.2.tar.gz 365167
+SHA256 1fef19c1ad9d1d25d19bfed681717760ce298b219aa8aa59037db4ad0b84e566 synce-libsynce-0.9.2.tar.gz 365167
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild
new file mode 100644
index 000000000000..82ca9d9aeb76
--- /dev/null
+++ b/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild,v 1.1 2006/07/13 21:25:07 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="Common Library for Synce (connecting WinCE devices to Linux)"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="" # dbus
+
+DEPEND=">=dev-libs/check-0.8.3.1"
+# dbus? ( sys-apps/dbus )"
+
+S=${WORKDIR}/libsynce-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.9.1-amd64.patch
+ sed -i -e 's/#include <slang.h>/#ifndef offsetof\n#define offsetof(T,F) ((unsigned int)((char *)\&((T *)0L)->F - (char *)0L))\n#endif/' lib/synce_socket.c
+}
+
+src_compile() {
+ # dbus support not quite there yet.
+ econf # $(use_enable dbus)
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README
+}