summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-29 01:06:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-29 01:06:38 +0000
commit890e1582ec35d15d994557706bb1dc7f3ea59f9b (patch)
tree6bee0d67ff6f316865f58bf4c66bbe58fa03fd2a /app-pda/libimobiledevice
parentFix name of ebuild. (diff)
downloadgentoo-2-890e1582ec35d15d994557706bb1dc7f3ea59f9b.tar.gz
gentoo-2-890e1582ec35d15d994557706bb1dc7f3ea59f9b.tar.bz2
gentoo-2-890e1582ec35d15d994557706bb1dc7f3ea59f9b.zip
Version bump.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libimobiledevice')
-rw-r--r--app-pda/libimobiledevice/ChangeLog10
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index 245d172123e2..8a133dee1ea1 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libimobiledevice
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.11 2010/11/30 11:01:59 bangert Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.12 2011/03/29 01:06:38 ssuominen Exp $
+
+*libimobiledevice-1.0.6 (29 Mar 2011)
+
+ 29 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +libimobiledevice-1.0.6.ebuild:
+ Version bump.
*libimobiledevice-1.0.4 (30 Nov 2010)
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild
new file mode 100644
index 000000000000..abd03c441d51
--- /dev/null
+++ b/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild,v 1.1 2011/03/29 01:06:38 ssuominen Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2:2.6"
+inherit python
+
+DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="python static-libs"
+
+RDEPEND=">=app-pda/libplist-0.15
+ >=app-pda/usbmuxd-0.1.4
+ >=dev-libs/glib-2.14.1
+ dev-libs/libgcrypt
+ dev-libs/libtasn1
+ >=net-libs/gnutls-1.6.3
+ sys-fs/fuse
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_with python swig)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}