summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-03-13 00:32:17 +0000
committerAron Griffis <agriffis@gentoo.org>2005-03-13 00:32:17 +0000
commite03ce3700c5a881b1840236d1a90562ca61b9683 (patch)
tree29ed4385b2d734aee0d008ed511c5d6183c23448 /app-pda/jpilot
parentFixinng 8+ patches problem (diff)
downloadgentoo-2-e03ce3700c5a881b1840236d1a90562ca61b9683.tar.gz
gentoo-2-e03ce3700c5a881b1840236d1a90562ca61b9683.tar.bz2
gentoo-2-e03ce3700c5a881b1840236d1a90562ca61b9683.zip
Add patch for gcc-2 compilation #70127. Stable on alpha, ia64, x86
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-pda/jpilot')
-rw-r--r--app-pda/jpilot/ChangeLog6
-rw-r--r--app-pda/jpilot/files/jpilot-0.99.7-gcc2.patch23
-rw-r--r--app-pda/jpilot/jpilot-0.99.7-r1.ebuild7
3 files changed, 33 insertions, 3 deletions
diff --git a/app-pda/jpilot/ChangeLog b/app-pda/jpilot/ChangeLog
index d5a7505505bd..a3cca3c76d33 100644
--- a/app-pda/jpilot/ChangeLog
+++ b/app-pda/jpilot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/jpilot
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.21 2005/01/02 21:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.22 2005/03/13 00:32:17 agriffis Exp $
+
+ 13 Mar 2005; Aron Griffis <agriffis@gentoo.org>
+ +files/jpilot-0.99.7-gcc2.patch, jpilot-0.99.7-r1.ebuild:
+ Add patch for gcc-2 compilation #70127. Stable on alpha, ia64, x86
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-pda/jpilot/files/jpilot-0.99.7-gcc2.patch b/app-pda/jpilot/files/jpilot-0.99.7-gcc2.patch
new file mode 100644
index 000000000000..fad2d4f8ae5e
--- /dev/null
+++ b/app-pda/jpilot/files/jpilot-0.99.7-gcc2.patch
@@ -0,0 +1,23 @@
+Patch from Matt Black in bug 70127
+12 Mar 2005 agriffis
+
+--- address_gui.c~ 2004-02-22 14:34:23 -0500
++++ address_gui.c 2004-11-04 23:59:24 -0500
+@@ -1427,12 +1427,15 @@
+ char number[100];
+ char ext[100];
+
+- number[0]=ext[0]='\0';
+- text=data;
+ #ifdef ENABLE_GTK2
+ GtkTextIter start_iter;
+ GtkTextIter end_iter;
+ GtkTextBuffer *text_buffer;
++#endif
++
++ number[0]=ext[0]='\0';
++ text=data;
++#ifdef ENABLE_GTK2
+
+ text_buffer = gtk_text_view_get_buffer(GTK_TEXT_VIEW(text));
+ gtk_text_buffer_get_bounds(GTK_TEXT_BUFFER(text),&start_iter,&end_iter);
diff --git a/app-pda/jpilot/jpilot-0.99.7-r1.ebuild b/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
index e991c452e0c6..feb76c706808 100644
--- a/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
+++ b/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.7-r1.ebuild,v 1.4 2005/01/01 15:44:41 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.7-r1.ebuild,v 1.5 2005/03/13 00:32:17 agriffis Exp $
DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
HOMEPAGE="http://jpilot.org/"
@@ -8,7 +8,7 @@ SRC_URI="http://jpilot.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="alpha ~amd64 ia64 ~ppc ~sparc x86"
IUSE="nls gtk2"
RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
@@ -22,6 +22,9 @@ src_unpack() {
unpack ${A}
cd ${S} || die
+ # Patch for gcc-2.95 compilation, thanks to Matt Black in #70127
+ epatch ${FILESDIR}/jpilot-0.99.7-gcc2.patch
+
# There are four icons available. Use the third.
sed -i 's/jpilot.xpm/jpilot-icon3.xpm/' jpilot.desktop || die
}