summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-08-27 16:50:09 +0000
committerMarinus Schraal <foser@gentoo.org>2003-08-27 16:50:09 +0000
commitd4b7515041291d4a9ac9bdce9ba3ee548ff13615 (patch)
treef057fe4dce0ea6b16234de2a228172b4ee7dc6c7 /app-office
parentadded gtk USE flag (diff)
downloadgentoo-2-d4b7515041291d4a9ac9bdce9ba3ee548ff13615.tar.gz
gentoo-2-d4b7515041291d4a9ac9bdce9ba3ee548ff13615.tar.bz2
gentoo-2-d4b7515041291d4a9ac9bdce9ba3ee548ff13615.zip
add patch (duh)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog4
-rw-r--r--app-office/abiword/Manifest5
-rw-r--r--app-office/abiword/abiword-1.99.5.ebuild10
-rw-r--r--app-office/abiword/files/abiword-1.99.5-cast_fix.patch12
4 files changed, 26 insertions, 5 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index aa2f536fa3d4..5ab6b86c1941 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.48 2003/08/27 16:25:02 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.49 2003/08/27 16:49:47 foser Exp $
*abiword-1.99.5 (27 Aug 2003)
27 Aug 2003; foser <foser@gentoo.org> abiword-1.99.5.ebuild :
- New version with patch+special unpack procedure
+ New version with patch to get around gcc bug
Hardcode disable perl, hope it fixes (#27225)
*abiword-1.99.4-r2 (19 Aug 2003)
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 9a992ad361f0..83c9f9d8e090 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,8 +1,8 @@
MD5 144371398dbe030e96f2e320cf8470c2 abiword-1.0.6-r1.ebuild 1930
-MD5 b78dcdc09b106f342cc5acb6f481a8ec abiword-1.99.5.ebuild 2421
+MD5 33a8b2080daec734b7bba4b059117e7f abiword-1.99.5.ebuild 2496
MD5 1abe03d14ed3a4064bb061324361cab9 abiword-1.0.2-r1.ebuild 4687
MD5 fb253d2410ebab0b96d9939aac12c071 abiword-1.99.4-r2.ebuild 2619
-MD5 d3549987c8a7ac59e9cc1a79d6aa1705 ChangeLog 7884
+MD5 ffd8733d502dffebd615d762ac87a5a1 ChangeLog 7881
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 d57b12387f05b71dd4e52f258a6e6e91 files/abiword-1.99.4-ots_buildfix.patch 416
MD5 475c8ca576317154869d2a10bbc4bf14 files/digest-abiword-1.99.5 144
@@ -10,6 +10,7 @@ MD5 9568c6ef14fe052d3d9f42747bda1aa2 files/digest-abiword-1.99.4-r2 144
MD5 4ab387fa04b0102a395a4b654f0714df files/abiword-1.1.4-wv_configure_fooling.patch 1575
MD5 31616e14907aefda2489036cc3d1db3d files/AbiWord.desktop 901
MD5 1ebcd22c6249c06e631c13491113d8ef files/AbiWord2.desktop 166
+MD5 2b9d4f094142556d7827af935a8fb64b files/abiword-1.99.5-cast_fix.patch 733
MD5 e6d9565092f5a6c2243401eccf1ca5a1 files/abiword-1.0.3-aspell.patch 812
MD5 7e39e4fdc4561d314daedcd78dce7ce3 files/digest-abiword-1.0.2-r1 67
MD5 55d85bca7cd645ef338336da3d6e6a7e files/digest-abiword-1.0.6-r1 67
diff --git a/app-office/abiword/abiword-1.99.5.ebuild b/app-office/abiword/abiword-1.99.5.ebuild
index 3f17fe6f99c7..03d8c45d7be1 100644
--- a/app-office/abiword/abiword-1.99.5.ebuild
+++ b/app-office/abiword/abiword-1.99.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.5.ebuild,v 1.1 2003/08/27 16:25:02 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.5.ebuild,v 1.2 2003/08/27 16:49:47 foser Exp $
inherit eutils debug
@@ -44,6 +44,14 @@ DEPEND="${RDEPEND}
# perl? ( >=dev-lang/perl-5.6 )
# perl seems broken
+src_unpack() {
+
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-cast_fix.patch
+
+}
+
src_compile() {
./autogen.sh
diff --git a/app-office/abiword/files/abiword-1.99.5-cast_fix.patch b/app-office/abiword/files/abiword-1.99.5-cast_fix.patch
new file mode 100644
index 000000000000..cef2f5d840ac
--- /dev/null
+++ b/app-office/abiword/files/abiword-1.99.5-cast_fix.patch
@@ -0,0 +1,12 @@
+diff -uNr abiword-1.99.5.patched/abi/src/wp/impexp/xp/ie_imp_MsWord_97.cpp abiword-1.99.5/abi/src/wp/impexp/xp/ie_imp_MsWord_97.cpp
+--- abiword-1.99.5.patched/abi/src/wp/impexp/xp/ie_imp_MsWord_97.cpp 2003-08-24 18:00:10.000000000 +0200
++++ abiword-1.99.5/abi/src/wp/impexp/xp/ie_imp_MsWord_97.cpp 2003-08-25 00:40:56.000000000 +0200
+@@ -3402,7 +3402,7 @@
+ comprLen = size;
+ uncomprLen = b->blip.metafile.m_cb;
+ unsigned char *uncompr = new unsigned char[uncomprLen];
+- int err = uncompress (uncompr, &uncomprLen, data, comprLen);
++ int err = uncompress (uncompr, &uncomprLen, reinterpret_cast<const unsigned char *>(data), comprLen);
+ if (err != Z_OK)
+ {
+ UT_DEBUGMSG(("Could not uncompress image\n"));