summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-27 22:27:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-27 22:27:46 +0000
commitb13342c9c9ae7da5d44dbb5b0b9a55e957a1056a (patch)
treebfcba3eeb2d1c0d9e8a93d0b578ff426f62789c7 /app-office
parentVersion bump. (diff)
downloadgentoo-2-b13342c9c9ae7da5d44dbb5b0b9a55e957a1056a.tar.gz
gentoo-2-b13342c9c9ae7da5d44dbb5b0b9a55e957a1056a.tar.bz2
gentoo-2-b13342c9c9ae7da5d44dbb5b0b9a55e957a1056a.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/kword-2.1.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 1aa0110358b2..2a0f359d9c92 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.144 2010/01/24 13:38:32 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.145 2010/02/27 22:27:46 ssuominen Exp $
+
+*kword-2.1.1 (27 Feb 2010)
+
+ 27 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> +kword-2.1.1.ebuild:
+ Version bump.
24 Jan 2010; Brent Baude <ranger@gentoo.org> kword-2.1.0.ebuild:
Marking kword-2.1.0 ~ppc for bug 295884
diff --git a/app-office/kword/kword-2.1.1.ebuild b/app-office/kword/kword-2.1.1.ebuild
new file mode 100644
index 000000000000..2b2ba702a5b9
--- /dev/null
+++ b/app-office/kword/kword-2.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-2.1.1.ebuild,v 1.1 2010/02/27 22:27:46 ssuominen Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice word processor."
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="wpd +wv2"
+
+DEPEND="
+ wpd? ( app-text/libwpd )
+ wv2? ( >=app-text/wv2-0.4.2 )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}/"
+
+KMEXTRACTONLY="
+ filters/
+ kspread/
+ libs/
+ plugins/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpd)
+ $(cmake-utils_use_with wv2)"
+
+ kde4-meta_src_configure
+}