summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-08-01 17:55:19 +0000
committerDan Armak <danarmak@gentoo.org>2001-08-01 17:55:19 +0000
commit89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8 (patch)
tree33594fd138745287e70efbfd15da171de28fcf7c /app-office
parentnoweb: a literate programming tool, lighter than web (diff)
downloadgentoo-2-89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8.tar.gz
gentoo-2-89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8.tar.bz2
gentoo-2-89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8.zip
lyx 1.1.6fix3, replaces fix2. Note that lthe new lyx-utils includes many new deps, some of them just now aded to portage. hey aren't completely tested and that's why I'm keeping 1.1.6fix2 yet. lyx-base updates are always stable.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx-base/files/digest-lyx-base-1.1.6.31
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.2.ebuild2
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.3.ebuild46
-rw-r--r--app-office/lyx-utils/lyx-utils-1.1.6.2.ebuild2
-rw-r--r--app-office/lyx-utils/lyx-utils-1.1.6.3.ebuild32
-rw-r--r--app-office/lyx/lyx-1.1.6.2.ebuild4
-rw-r--r--app-office/lyx/lyx-1.1.6.3.ebuild13
7 files changed, 96 insertions, 4 deletions
diff --git a/app-office/lyx-base/files/digest-lyx-base-1.1.6.3 b/app-office/lyx-base/files/digest-lyx-base-1.1.6.3
new file mode 100644
index 000000000000..15faa84195c3
--- /dev/null
+++ b/app-office/lyx-base/files/digest-lyx-base-1.1.6.3
@@ -0,0 +1 @@
+MD5 b97a87d87d5c19da917547d9b81fab89 lyx-1.1.6fix3.tar.gz
diff --git a/app-office/lyx-base/lyx-base-1.1.6.2.ebuild b/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
index fa6bf3963e9d..6b6625b9e4f4 100644
--- a/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
+++ b/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
@@ -13,7 +13,7 @@ DESCRIPTION="LyX is an Xwindows graphical frontend for LaTeX. Instead\
of forcing you to learn LaTeX markup syntax and use the\
proper tags, however, it is a WYSIWYM program."
-SRC_URI="ftp://ftp.lyx.org/pub/${A}"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${A}"
HOMEPAGE="http://www.lyx.org/"
diff --git a/app-office/lyx-base/lyx-base-1.1.6.3.ebuild b/app-office/lyx-base/lyx-base-1.1.6.3.ebuild
new file mode 100644
index 000000000000..832f1a914d90
--- /dev/null
+++ b/app-office/lyx-base/lyx-base-1.1.6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $ /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp$
+
+# The real version of LyX is 1.1.6fix3. As Portage has no support for
+# arbitrary suffixes like 'fix' (yet), this is translated into 1.1.6.3.
+P=lyx-1.1.6fix3
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+
+DESCRIPTION="LyX is an Xwindows graphical frontend for LaTeX. Instead\
+ of forcing you to learn LaTeX markup syntax and use the\
+ proper tags, however, it is a WYSIWYM program."
+
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${A}"
+
+HOMEPAGE="http://www.lyx.org/"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-devel/ld.so"
+
+src_compile() {
+
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+
+ try emake
+
+}
+
+src_install () {
+
+ # install-strip is a special target provided by the LyX makefile
+ # for striping installed binaries.
+ try make DESTDIR=${D} install-strip
+
+}
+
diff --git a/app-office/lyx-utils/lyx-utils-1.1.6.2.ebuild b/app-office/lyx-utils/lyx-utils-1.1.6.2.ebuild
index 038e38114800..89a5bcee5ff7 100644
--- a/app-office/lyx-utils/lyx-utils-1.1.6.2.ebuild
+++ b/app-office/lyx-utils/lyx-utils-1.1.6.2.ebuild
@@ -13,7 +13,7 @@ DESCRIPTION="All the utils/packages LyX (lyx-base.ebuild) can make use of."
HOMEPAGE="http://www.lyx.org/"
-DEPEND="app-office/lyx-base
+DEPEND="~app-office/lyx-base-1.1.6.2
app-text/ghostscript
app-text/xpdf
app-text/ispell
diff --git a/app-office/lyx-utils/lyx-utils-1.1.6.3.ebuild b/app-office/lyx-utils/lyx-utils-1.1.6.3.ebuild
new file mode 100644
index 000000000000..1e5d057e9c04
--- /dev/null
+++ b/app-office/lyx-utils/lyx-utils-1.1.6.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $ /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp$
+
+# This ebuild does nothing, it depends on lyx-base and on all known
+# packages lyx can make use of. See the lyx-base ebuild for more info.
+# Note that these packages ( the ones this ebuild depends on) can be
+# installed in any order, both before and after the lyx installation;
+# when lyx runs it automatically uses whatever it finds.
+
+DESCRIPTION="All the utils/packages LyX (lyx-base.ebuild) can make use of."
+
+HOMEPAGE="http://www.lyx.org/"
+
+DEPEND="~app-office/lyx-base-1.1.6.3
+ app-text/ghostscript
+ app-text/xpdf
+ app-text/ispell
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ virtual/lpr
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb"
+# app-text/chktex"
+
+# Missing from this list:
+# sgmltools - www.sgmltools.org is unreachable so I couldn't make
+# an ebuild for it. Lyx uses sgmltools for DocBook conversion.
diff --git a/app-office/lyx/lyx-1.1.6.2.ebuild b/app-office/lyx/lyx-1.1.6.2.ebuild
index 108e7560ced6..a976116241e2 100644
--- a/app-office/lyx/lyx-1.1.6.2.ebuild
+++ b/app-office/lyx/lyx-1.1.6.2.ebuild
@@ -9,5 +9,5 @@ DESCRIPTION="Lyx itself (lyx-base), plus all the utils/packages it can make use
HOMEPAGE="http://www.lyx.org/"
-DEPEND="app-office/lyx-base
- app-office/lyx-utils" \ No newline at end of file
+DEPEND="~app-office/lyx-utils-1.1.6.2
+ ~app-office/lyx-base-1.1.6.2" \ No newline at end of file
diff --git a/app-office/lyx/lyx-1.1.6.3.ebuild b/app-office/lyx/lyx-1.1.6.3.ebuild
new file mode 100644
index 000000000000..8351286927cb
--- /dev/null
+++ b/app-office/lyx/lyx-1.1.6.3.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $ /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp$
+
+# This ebuild simply depends on lyx-base and lyx-utils.
+
+DESCRIPTION="Lyx itself (lyx-base), plus all the utils/packages it can make use of (lyx-utils)."
+
+HOMEPAGE="http://www.lyx.org/"
+
+DEPEND="~app-office/lyx-utils-1.1.6.3
+ ~app-office/lyx-base-1.1.6.3" \ No newline at end of file