summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-09 21:17:21 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-09 21:17:21 +0000
commit803b0e92b8c8075491480984d61b2b7b144c7fed (patch)
treef8e6f553cc42a57bc670ff70ce9230c56a7c1569 /app-office
parentmask oo-bin (diff)
downloadgentoo-2-803b0e92b8c8075491480984d61b2b7b144c7fed.tar.gz
gentoo-2-803b0e92b8c8075491480984d61b2b7b144c7fed.tar.bz2
gentoo-2-803b0e92b8c8075491480984d61b2b7b144c7fed.zip
intruduce new install method
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/ChangeLog7
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.0.0-r31
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.0.0-r3.ebuild106
3 files changed, 113 insertions, 1 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 129b493107df..251450f94146 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.5 2002/08/06 20:38:38 prez Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.6 2002/09/09 21:17:21 azarah Exp $
+
+*openoffice-bin-1.0.0-r3 (9 Sep 2002)
+
+ 9 Sep 2002; Martin Schlemmer <azarah@gentoo.org> openoffice-bin-1.0.0-r3.ebuild :
+ Get a src_install() that actually should work properl (tm).
*openoffice-bin-1.0.0-r2 (15 Jul 2002)
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.0-r3 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.0-r3
new file mode 100644
index 000000000000..18ef3eba7a85
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.0-r3
@@ -0,0 +1 @@
+MD5 24b64e79509f4e6b4e458fe35f82c762 OOo_1.0.0_LinuxIntel_install.tar.gz 69877656
diff --git a/app-office/openoffice-bin/openoffice-bin-1.0.0-r3.ebuild b/app-office/openoffice-bin/openoffice-bin-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..661a35e92584
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-1.0.0-r3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.0-r3.ebuild,v 1.1 2002/09/09 21:17:21 azarah Exp $
+
+inherit virtualx
+
+# NOTE: There are two big issues that should be addressed.
+#
+# 1) Language support and fonts should be addressed.
+
+MY_PV="`echo ${PV} | gawk '{ print toupper($1) }'`"
+LOC="/opt"
+S="${WORKDIR}/install"
+DESCRIPTION="OpenOffice productivity suite"
+SRC_URI="x86? ( http://ny1.mirror.openoffice.org/${PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
+ http://sf1.mirror.openoffice.org/${PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz )"
+HOMEPAGE="http://www.openoffice.org"
+
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5.0
+ virtual/x11
+ app-arch/zip
+ app-arch/unzip
+ >=virtual/jdk-1.3.1"
+
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+
+ unpack OOo_${MY_PV}_LinuxIntel_install.tar.gz
+}
+
+src_install() {
+
+ # Autoresponse file for main installation
+ cat > ${T}/rsfile-global <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_NETWORK
+ INSTALLATIONTYPE=STANDARD
+ DESTINATIONPATH=<destdir>
+ OUTERPATH=
+ LOGFILE=
+ LANGUAGELIST=<LANGUAGE>
+
+ [JAVA]
+ JavaSupport=preinstalled_or_none
+ END_RS
+
+ # Autoresponse file for user isntallation
+ cat > ${T}/rsfile-local <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_WORKSTATION
+ INSTALLATIONTYPE=WORKSTATION
+ DESTINATIONPATH=<home>/.openoffice
+
+ [JAVA]
+ JavaSupport=none
+ END_RS
+
+ # Fixing install location in response file
+ sed -e "s|<destdir>|${D}${LOC}/OpenOffice-${PV}|" \
+ ${T}/rsfile-global > ${T}/autoresponse
+
+ einfo "Installing into build root..."
+ dodir ${LOC}/OpenOffice-${PV}
+ cd ${S}
+ export maketype="./setup"
+ virtualmake "-v -r:${T}/autoresponse"
+
+ echo
+ einfo "Removing build root from registy..."
+ # Remove totally useless stuff.
+ rm -f ${D}${LOC}/OpenOffice-${PV}/program/{setup.log,sopatchlevel.sh}
+ # Remove build root from registry and co
+ egrep -rl "${D}" ${D}${LOC}/OpenOffice-${PV}/* | \
+ xargs -i perl -pi -e "s|${D}||g" {} || :
+
+ einfo "Fixing permissions..."
+ # Fix permissions
+ find ${D}${LOC}/OpenOffice-${PV}/ -type f -exec chmod ag+r {} \;
+
+ # Fix symlinks
+ for x in "soffice program/spadmin" \
+ "program/setup setup" \
+ "program/spadmin spadmin"
+ do
+ dosym $(echo ${x} | awk '{print $1}') \
+ ${LOC}/OpenOffice-${PV}/$(echo ${x} | awk '{print $2}')
+ done
+
+ # Install user autoresponse file
+ insinto /etc/openoffice
+ newins ${T}/rsfile-local autoresponse.conf
+}
+
+pkg_postinst() {
+
+ # Make sure these do not get nuked.
+ cd ${ROOT}${LOC}/OpenOffice-${PV}
+ keepdir -p user/config/registry/instance/org/openoffice/{Office,ucb}
+ keepdir -p user/psprint/{driver,fontmetric}
+ keepdir -p user/{autocorr,backup,plugin,store,temp,template}
+}
+