summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-29 08:18:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-29 08:18:10 +0000
commit76cb8ba99ab56a10cd1f03e97af8ee70c8bc7751 (patch)
treea235f77130f95e07fcd3f473d42358cb701ef821 /app-office
parentAdd python deps. (diff)
downloadgentoo-2-76cb8ba99ab56a10cd1f03e97af8ee70c8bc7751.tar.gz
gentoo-2-76cb8ba99ab56a10cd1f03e97af8ee70c8bc7751.tar.bz2
gentoo-2-76cb8ba99ab56a10cd1f03e97af8ee70c8bc7751.zip
app-office/scribus: Backport upstream fix for deprecated dev-python/imaging usage, #471498
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/ChangeLog8
-rw-r--r--app-office/scribus/files/scribus-1.4.2-imaging.patch25
-rw-r--r--app-office/scribus/scribus-1.4.2-r3.ebuild130
3 files changed, 162 insertions, 1 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index a0836715bd04..97643dbe1b69 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/scribus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.174 2013/03/02 19:37:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.175 2013/05/29 08:18:10 jlec Exp $
+
+*scribus-1.4.2-r3 (29 May 2013)
+
+ 29 May 2013; Justin Lecher <jlec@gentoo.org> +scribus-1.4.2-r3.ebuild,
+ +files/scribus-1.4.2-imaging.patch:
+ Backport upstream fix for deprecated dev-python/imaging usage, #471498
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> scribus-1.4.1-r1.ebuild,
scribus-1.4.2-r2.ebuild, scribus-1.4.9999.ebuild, scribus-9999.ebuild:
diff --git a/app-office/scribus/files/scribus-1.4.2-imaging.patch b/app-office/scribus/files/scribus-1.4.2-imaging.patch
new file mode 100644
index 000000000000..e94e812d1353
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.4.2-imaging.patch
@@ -0,0 +1,25 @@
+ scribus/plugins/scriptplugin/scripts/FontSample.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/scribus/plugins/scriptplugin/scripts/FontSample.py b/scribus/plugins/scriptplugin/scripts/FontSample.py
+index 0219a32..1e9be38 100644
+--- a/scribus/plugins/scriptplugin/scripts/FontSample.py
++++ b/scribus/plugins/scriptplugin/scripts/FontSample.py
+@@ -154,7 +154,7 @@ if not os.path.exists(CONFIG_PATH):
+
+
+ try:
+- import Image
++ from PIL import Image
+ except ImportError,err:
+ print 'You need to install Python Imaging Library (PIL).'
+ print 'If using gentoo then you need to emerge /dev-python/imaging'
+@@ -164,7 +164,7 @@ except ImportError,err:
+
+
+ try:
+- import ImageTk
++ from PIL import ImageTk
+ except ImportError,err:
+ print 'Module ImageTk not found, font preview disabled'
+ showPreviewPanel = 0
diff --git a/app-office/scribus/scribus-1.4.2-r3.ebuild b/app-office/scribus/scribus-1.4.2-r3.ebuild
new file mode 100644
index 000000000000..d9844848fb8f
--- /dev/null
+++ b/app-office/scribus/scribus-1.4.2-r3.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.4.2-r3.ebuild,v 1.1 2013/05/29 08:18:10 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE=tk
+
+inherit cmake-utils fdo-mime multilib python-single-r1
+
+DESCRIPTION="Desktop publishing (DTP) and layout program"
+HOMEPAGE="http://www.scribus.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aspell cairo debug examples hunspell +minimal +pdf templates"
+
+# a=$(ls resources/translations/po/scribus.*ts | sed -e 's:\.: :g' | awk '{print $2}'); echo ${a}
+IUSE_LINGUAS=" af ar bg br ca cs_CZ cy da_DK de de_1901 de_CH el en_AU en_GB en_US es_ES et eu fi fr gl hu id it ja ko lt_LT nb_NO nl pl_PL pt pt_BR ru sa sk_SK sl sq sr sv th_TH tr uk zh_CN zh_TW"
+IUSE+=" ${IUSE_LINGUAS// / linguas_}"
+
+COMMON_DEPEND="
+ dev-python/imaging[tk,${PYTHON_USEDEP}]
+ dev-libs/boost
+ dev-libs/hyphen
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ net-print/cups
+ sys-libs/zlib[minizip]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ virtual/jpeg
+ cairo? ( x11-libs/cairo[X,svg] )
+ pdf? ( app-text/podofo )
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docs.patch
+ "${FILESDIR}"/${P}-imaging.patch
+ "${FILESDIR}"/${PN}-1.4.0-minizip.patch
+ )
+
+src_prepare() {
+ cat > cmake/modules/FindZLIB.cmake <<- EOF
+ find_package(PkgConfig)
+ pkg_check_modules(ZLIB minizip zlib)
+ SET( ZLIB_LIBRARY \${ZLIB_LIBRARIES} )
+ SET( ZLIB_INCLUDE_DIR \${ZLIB_INCLUDE_DIRS} )
+ MARK_AS_ADVANCED( ZLIB_LIBRARY ZLIB_INCLUDE_DIR )
+ EOF
+
+ rm scribus/{ioapi,unzip}.[ch] || die
+
+ sed \
+ -e 's:\(${CMAKE_INSTALL_PREFIX}\):./\1:g' \
+ -i resources/templates/CMakeLists.txt || die
+
+ base_src_prepare
+}
+
+src_configure() {
+ local lang langs
+ for lang in ${IUSE_LINGUAS}; do
+ if use linguas_${lang}; then
+ langs+=",${lang}"
+ else
+ sed -e "/${lang}/d" -i scribus/doc/CMakeLists.txt || die
+ fi
+ done
+
+ local mycmakeargs=(
+ -DHAVE_PYTHON=ON
+ -DPYTHON_INCLUDE_PATH=$(python_get_includedir)
+ -DPYTHON_LIBRARY="${EPREFIX}/usr/$(get_libdir)/lib${EPYTHON}.so"
+ -DWANT_NORPATH=ON
+ -DWANT_QTARTHUR=ON
+ -DWANT_QT3SUPPORT=OFF
+ -DGENTOOVERSION=${PVR}
+ -DWANT_GUI_LANG=${langs#,}
+ $(cmake-utils_use_with aspell ASPELL)
+ $(cmake-utils_use_with pdf PODOFO)
+ $(cmake-utils_use_want cairo)
+ $(cmake-utils_use_want debug DEBUG)
+ $(cmake-utils_use_want minimal NOHEADERINSTALL)
+ $(cmake-utils_use_want hunspell HUNSPELL)
+ )
+ use examples || mycmakeargs+=( -DWANT_NOEXAMPLES=ON)
+ use templates || mycmakeargs+=( -DWANT_NOTEMPLATES=ON)
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ local lang file
+ for lang in ${IUSE_LINGUAS}; do
+ file="${ED}"/usr/share/scribus/translations/scribus.${lang}.qm
+ if ! use linguas_${lang} && [[ -f "${file}" ]]; then
+ rm "${file}" || die
+ fi
+ done
+
+ mv "${ED}"/usr/share/doc/${PF}/{en,html} || die
+ ln -sf html "${ED}"/usr/share/doc/${PF}/en || die
+ docompress -x /usr/share/doc/${PF}/en
+ doicon resources/icons/scribus.png
+ domenu scribus.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}