summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-08 12:13:05 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-08 12:13:05 +0000
commit19a3300658995eb5769a37f23240bd905e4d031b (patch)
tree0bbd641c5797876fa2babca865ad077458911127 /app-office
parentNeeds slot 2 for gtk+ (#500664 by Bombino) (diff)
downloadgentoo-2-19a3300658995eb5769a37f23240bd905e4d031b.tar.gz
gentoo-2-19a3300658995eb5769a37f23240bd905e4d031b.tar.bz2
gentoo-2-19a3300658995eb5769a37f23240bd905e4d031b.zip
Version bump, bug 499988
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-l10n/ChangeLog8
-rw-r--r--app-office/libreoffice-l10n/libreoffice-l10n-4.2.0.4.ebuild94
-rw-r--r--app-office/libreoffice-l10n/metadata.xml4
3 files changed, 105 insertions, 1 deletions
diff --git a/app-office/libreoffice-l10n/ChangeLog b/app-office/libreoffice-l10n/ChangeLog
index 8ab14be34908..c8a618ed0b47 100644
--- a/app-office/libreoffice-l10n/ChangeLog
+++ b/app-office/libreoffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-l10n
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/ChangeLog,v 1.98 2014/01/28 22:43:05 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/ChangeLog,v 1.99 2014/02/08 12:13:05 dilfridge Exp $
+
+*libreoffice-l10n-4.2.0.4 (08 Feb 2014)
+
+ 08 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libreoffice-l10n-4.2.0.4.ebuild:
+ Version bump, bug 499988
28 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org>
libreoffice-l10n-4.1.4.2.ebuild:
diff --git a/app-office/libreoffice-l10n/libreoffice-l10n-4.2.0.4.ebuild b/app-office/libreoffice-l10n/libreoffice-l10n-4.2.0.4.ebuild
new file mode 100644
index 000000000000..7b3124d86f92
--- /dev/null
+++ b/app-office/libreoffice-l10n/libreoffice-l10n-4.2.0.4.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/libreoffice-l10n-4.2.0.4.ebuild,v 1.1 2014/02/08 12:13:05 dilfridge Exp $
+
+EAPI=5
+
+inherit rpm eutils multilib versionator
+
+MY_PV=$(get_version_component_range 1-3)
+
+DESCRIPTION="Translations for the Libreoffice suite."
+HOMEPAGE="http://www.libreoffice.org"
+BASE_SRC_URI="http://download.documentfoundation.org/${PN/-l10n/}/stable/${MY_PV}/rpm"
+
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="offlinehelp"
+
+#
+# when changing the language lists, please be careful to preserve the spaces (bug 491728)
+#
+LANGUAGES_HELP=" am ast bg bn_IN bn bo bs ca_valencia ca cs da de dz el en_GB en
+en_ZA eo es et eu fi fr gl gu he hi hr hu id is it ja ka km ko mk nb ne nl nn om
+pl pt_BR pt ru si sk sl sq sv tg tr ug uk vi zh_CN zh_TW "
+LANGUAGES="${LANGUAGES_HELP}af ar as be br brx cy dgo fa ga gd kk kmr_Latn kn
+kok ks lb lo lt lv mai ml mn mni mr my nr nso oc or pa_IN ro rw sa_IN sat sd
+sid sr_Latn sr ss st sw_TZ ta te th tn ts tt uz ve xh zu "
+
+for lang in ${LANGUAGES_HELP}; do
+ helppack=""
+ [[ ${lang} == en ]] && lang2=${lang/en/en_US} || lang2=${lang}
+ helppack="offlinehelp? ( ${BASE_SRC_URI}/x86/LibreOffice_${MY_PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz )"
+ SRC_URI+=" linguas_${lang}? ( ${helppack} )"
+done
+for lang in ${LANGUAGES}; do
+ langpack=""
+ [[ ${lang} == en ]] \
+ || langpack="${BASE_SRC_URI}/x86/LibreOffice_${MY_PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz"
+ [[ -z ${langpack} ]] || SRC_URI+=" linguas_${lang}? ( ${langpack} )"
+ IUSE+=" linguas_${lang}"
+done
+unset lang helppack langpack lang2
+
+RDEPEND+="app-text/hunspell"
+
+RESTRICT="strip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+
+ local lang dir rpmdir i
+ local ooextused=()
+
+ for lang in ${LANGUAGES}; do
+ # break away if not enabled; paludis support
+ use_if_iuse linguas_${lang} || continue
+
+ dir=${lang/_/-}
+
+ # for english we provide just helppack, as translation is always there
+ if [[ ${lang} != en ]]; then
+ rpmdir="LibreOffice_${PV}_Linux_x86_rpm_langpack_${dir}/RPMS/"
+ [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
+ # First remove dictionaries, we want to use system ones.
+ rm -rf "${S}/${rpmdir}/"*dict*.rpm
+ rpm_unpack "./${rpmdir}/"*.rpm
+ fi
+ if [[ "${LANGUAGES_HELP}" =~ " ${lang} " ]] && use offlinehelp; then
+ [[ ${lang} == en ]] && dir="en-US"
+ rpmdir="LibreOffice_${PV}_Linux_x86_rpm_helppack_${dir}/RPMS/"
+ [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
+ rpm_unpack ./"${rpmdir}/"*.rpm
+ fi
+ done
+}
+
+src_prepare() { :; }
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local dir="${S}"/opt/${PN/-l10n/}$(get_version_component_range 1-2)/
+ # Condition required for people that do not install anything eg no linguas
+ # or just english with no offlinehelp.
+ if [[ -d "${dir}" ]] ; then
+ insinto /usr/$(get_libdir)/${PN/-l10n/}/
+ doins -r "${dir}"/*
+ fi
+ # remove extensions that are in the l10n for some weird reason
+ rm -rf "${ED}"/usr/$(get_libdir)/${PN/-l10n/}/share/extensions/
+}
diff --git a/app-office/libreoffice-l10n/metadata.xml b/app-office/libreoffice-l10n/metadata.xml
index f8e7455c3961..0158a0af074b 100644
--- a/app-office/libreoffice-l10n/metadata.xml
+++ b/app-office/libreoffice-l10n/metadata.xml
@@ -4,5 +4,9 @@
<herd>openoffice</herd>
<use>
<flag name="offlinehelp">Install help files locally instead of using the LibreOffice Wiki</flag>
+ <flag name="linguas_ca_valencia">Catalan locale (Valencia)</flag>
+ <flag name="linguas_kmr_Latn">kmr_Latn localization</flag>
+ <flag name="linguas_sid">sid localization</flag>
+ <flag name="linguas_sr_Latn">Serbian (Latin) locale</flag>
</use>
</pkgmetadata>