summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-21 18:58:10 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-21 18:58:10 +0000
commit15ee47f398efea7209ed76f69946ee337be524f8 (patch)
tree446cda2919c0a5a1f70a64cb54f5d4579b7920a9 /app-office
parentold (Manifest recommit) (diff)
downloadgentoo-2-15ee47f398efea7209ed76f69946ee337be524f8.tar.gz
gentoo-2-15ee47f398efea7209ed76f69946ee337be524f8.tar.bz2
gentoo-2-15ee47f398efea7209ed76f69946ee337be524f8.zip
moving webapp-detect into pkg_setup. closes 44780 and 48380.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/phprojekt/ChangeLog8
-rw-r--r--app-office/phprojekt/phprojekt-3.2a.ebuild31
-rw-r--r--app-office/phprojekt/phprojekt-4.0-r1.ebuild7
-rw-r--r--app-office/phprojekt/phprojekt-4.1.ebuild9
4 files changed, 31 insertions, 24 deletions
diff --git a/app-office/phprojekt/ChangeLog b/app-office/phprojekt/ChangeLog
index eb869b39fa70..43ce22dfd518 100644
--- a/app-office/phprojekt/ChangeLog
+++ b/app-office/phprojekt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/phprojekt
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/ChangeLog,v 1.8 2003/12/30 14:14:35 mholzer Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/ChangeLog,v 1.9 2004/04/21 18:58:10 mholzer Exp $
+
+ 21 Apr 2004; Martin Holzer <mholzer@gentoo.org> phprojekt-4.0-r1.ebuild,
+ phprojekt-4.1.ebuild:
+ moving webapp-detect into pkg_setup. closes 44780 and 48380.
*phprojekt-4.1 (30 Dec 2003)
diff --git a/app-office/phprojekt/phprojekt-3.2a.ebuild b/app-office/phprojekt/phprojekt-3.2a.ebuild
index d57ae78313f6..53add002c5ca 100644
--- a/app-office/phprojekt/phprojekt-3.2a.ebuild
+++ b/app-office/phprojekt/phprojekt-3.2a.ebuild
@@ -1,29 +1,34 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-3.2a.ebuild,v 1.5 2003/02/13 09:19:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-3.2a.ebuild,v 1.6 2004/04/21 18:58:10 mholzer Exp $
-# lid of download link
-MY_DOWNLOAD_ID=14
-
-HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
-[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
-HTTPD_USER=apache
-HTTPD_GROUP=apache
+inherit webapp-apache
DESCRIPTION="Project management and coordination system"
HOMEPAGE="http://www.phprojekt.com/"
SRC_URI="http://www.phprojekt.de/download/${PN}.tar.gz"
-
+IUSE="apache2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
RDEPEND="virtual/php"
+pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
src_install() {
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+
dodoc ChangeLog install readme
- dodir ${HTTPD_ROOT}/phprojekt
- cp -r . ${D}/${HTTPD_ROOT}/phprojekt
+ dodir ${destdir}
+ cp -r . ${D}/${destdir}
cd ${D}/${HTTPD_ROOT}
- chown -R ${HTTPD_USER}:${HTTPD_GROUP} phprojekt
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
}
diff --git a/app-office/phprojekt/phprojekt-4.0-r1.ebuild b/app-office/phprojekt/phprojekt-4.0-r1.ebuild
index ab3327d9625c..251891cd260b 100644
--- a/app-office/phprojekt/phprojekt-4.0-r1.ebuild
+++ b/app-office/phprojekt/phprojekt-4.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-4.0-r1.ebuild,v 1.4 2003/12/30 14:14:35 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-4.0-r1.ebuild,v 1.5 2004/04/21 18:58:10 mholzer Exp $
inherit webapp-apache
@@ -14,9 +14,8 @@ KEYWORDS="x86 ~ppc"
RDEPEND="virtual/php"
-webapp-detect || NO_WEBSERVER=1
-
pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
webapp-pkg_setup "${NO_WEBSERVER}"
einfo "Installing into ${ROOT}${HTTPD_ROOT}."
}
diff --git a/app-office/phprojekt/phprojekt-4.1.ebuild b/app-office/phprojekt/phprojekt-4.1.ebuild
index 6547b9a9a85b..f8274f4f8050 100644
--- a/app-office/phprojekt/phprojekt-4.1.ebuild
+++ b/app-office/phprojekt/phprojekt-4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-4.1.ebuild,v 1.1 2003/12/30 14:14:35 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-4.1.ebuild,v 1.2 2004/04/21 18:58:10 mholzer Exp $
inherit webapp-apache
@@ -10,13 +10,12 @@ IUSE="apache2"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
RDEPEND="virtual/php"
-webapp-detect || NO_WEBSERVER=1
-
pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
webapp-pkg_setup "${NO_WEBSERVER}"
einfo "Installing into ${ROOT}${HTTPD_ROOT}."
}