summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-30 07:13:59 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-30 07:13:59 +0000
commitf0cf4835b8717c87108b3cb0d133cf4378c9f4aa (patch)
tree297d818a4b30e73344b1ad9d1fdedbc4a07ccba4 /app-office/oooqs
parentadd support for USE=cdinstall (diff)
downloadgentoo-2-f0cf4835b8717c87108b3cb0d133cf4378c9f4aa.tar.gz
gentoo-2-f0cf4835b8717c87108b3cb0d133cf4378c9f4aa.tar.bz2
gentoo-2-f0cf4835b8717c87108b3cb0d133cf4378c9f4aa.zip
New release, with some fixes to work with OpenOffice.org 2.0.0
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-office/oooqs')
-rw-r--r--app-office/oooqs/ChangeLog8
-rw-r--r--app-office/oooqs/files/digest-oooqs-2.0.3-r21
-rw-r--r--app-office/oooqs/files/oooqs-20.patch86
-rw-r--r--app-office/oooqs/oooqs-2.0.3-r2.ebuild26
4 files changed, 120 insertions, 1 deletions
diff --git a/app-office/oooqs/ChangeLog b/app-office/oooqs/ChangeLog
index 6029ab0c8da2..4b957ae12518 100644
--- a/app-office/oooqs/ChangeLog
+++ b/app-office/oooqs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/oooqs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.17 2005/09/24 06:46:13 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.18 2005/10/30 07:13:59 suka Exp $
+
+*oooqs-2.0.3-r2 (30 Oct 2005)
+
+ 30 Oct 2005; Andreas Proschofsky <suka@gentoo.org> +files/oooqs-20.patch,
+ +oooqs-2.0.3-r2.ebuild:
+ New release, with some fixes to work with OpenOffice.org 2.0.0
24 Sep 2005; Andreas Proschofsky <suka@gentoo.org> files/fixxooo.patch:
Fix icons to correctly display for both openoffice and openoffice-ximian,
diff --git a/app-office/oooqs/files/digest-oooqs-2.0.3-r2 b/app-office/oooqs/files/digest-oooqs-2.0.3-r2
new file mode 100644
index 000000000000..5d78f6742d54
--- /dev/null
+++ b/app-office/oooqs/files/digest-oooqs-2.0.3-r2
@@ -0,0 +1 @@
+MD5 5d401aa7250f80734d785d4c286f635b oooqs-2.0.3.tar.gz 584849
diff --git a/app-office/oooqs/files/oooqs-20.patch b/app-office/oooqs/files/oooqs-20.patch
new file mode 100644
index 000000000000..7f62486a6672
--- /dev/null
+++ b/app-office/oooqs/files/oooqs-20.patch
@@ -0,0 +1,86 @@
+--- src/oooqs.cpp
++++ src/oooqs.cpp
+@@ -18,17 +18,12 @@
+ #include <ksimpleconfig.h>
+
+ #include "oooqs.h"
+-#include "oooqsselectordialog.h"
+
+ OOoQs::OOoQs()
+ : KSystemTray( 0, "OOoQs" ),
+ _quickProcess( 0 ), _okToRun( true ) {
+
+ QMap<QString, QString> versions;
+-
+- KConfig* oooConfig = 0;
+-
+- OOoQsSelectorDialog* selector = 0;
+
+ /**
+ Get the global config-object.
+@@ -86,51 +81,11 @@
+ Read the configuration.
+ */
+ _autostart->setChecked( _config->readBoolEntry( "Autostart", true ) );
+- _exec = _config->readEntry( "Exec" );
+-
+- /**
+- Try to autodetect settings if they aren't found in our own config.
+- */
+- if ( _exec.length() < 2 ) {
+- oooConfig = new KSimpleConfig(
+- QDir::homeDirPath() + QDir::separator()
+- + ".sversionrc", true );
+- oooConfig->setGroup( "Versions" );
+- versions = oooConfig->entryMap( "Versions" );
+- /**
+- If there are more than one possible configurations,
+- ask the user which one to use.
+- */
+- if ( versions.count() > 1 ) {
+- selector = new OOoQsSelectorDialog( versions, this );
+- if ( selector->exec() == QDialog::Accepted ) {
+- _exec = versions[ selector->selected() ];
+- _exec = _exec.section( ':', 1 );
+- _exec += QDir::separator();
+- _exec += "soffice";
+- _exec = QDir::cleanDirPath( _exec );
+- _config->writeEntry( "Exec", _exec );
+- } else {
+- /**
+- Kill the app here if the user hadn't chosen a configuration.
+- */
+- _okToRun = false;
+- return ;
+- }
+- /**
+- Added by Sergio Visinoni <piffio@piffio.org>
+-
+- I (Christian) simply forgot it (shame on me!)
+- */
+- } else {
+- _exec = versions.begin().data();
+- _exec = _exec.section( ':', 1 );
+- _exec += QDir::separator();
+- _exec += "soffice";
+- _exec = QDir::cleanDirPath( _exec );
+- _config->writeEntry( "Exec", _exec );
+- }
+- }
++
++ /**
++ Fixed place for the exec now
++ */
++ _exec += "/usr/bin/ooffice2";
+
+ /**
+ Make sure that OpenOffice.org is killed
+@@ -182,7 +137,7 @@
+ */
+ process->setExecutable( _exec );
+ ( *process ) << "-plugin";
+- ( *process ) << "-quickstart";
++ ( *process ) << "-nologo" << "-nodefault";
+ connect ( process, SIGNAL( processExited( KProcess* ) ),
+ this, SLOT( restartQuickInstance( KProcess* ) ) );
+ /**
diff --git a/app-office/oooqs/oooqs-2.0.3-r2.ebuild b/app-office/oooqs/oooqs-2.0.3-r2.ebuild
new file mode 100644
index 000000000000..a8d98b1ee38b
--- /dev/null
+++ b/app-office/oooqs/oooqs-2.0.3-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/oooqs-2.0.3-r2.ebuild,v 1.1 2005/10/30 07:13:59 suka Exp $
+
+inherit kde eutils
+
+need-kde 3
+
+DESCRIPTION="OpenOffice.org Quickstarter, runs in the KDE SystemTray"
+HOMEPAGE="http://segfaultskde.berlios.de/index.php"
+SRC_URI="http://download.berlios.de/segfaultskde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+SLOT="0"
+
+RDEPEND=">=virtual/ooo-2.0.0"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/oooqs-20.patch
+}