summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-10-27 10:27:03 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-10-27 10:27:03 +0000
commitf557d513da60fa49b5fef2e3f763cd1de06ac65d (patch)
treebe08c2af8710d17c63953ab0668b8b7834d67595 /app-office/magicpoint
parentCall "load" instead of "load-library" in Emacs site-init file. (diff)
downloadgentoo-2-f557d513da60fa49b5fef2e3f763cd1de06ac65d.tar.gz
gentoo-2-f557d513da60fa49b5fef2e3f763cd1de06ac65d.tar.bz2
gentoo-2-f557d513da60fa49b5fef2e3f763cd1de06ac65d.zip
add patch to kill QA warnings, provided by Thomas Anderson
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-office/magicpoint')
-rw-r--r--app-office/magicpoint/ChangeLog7
-rw-r--r--app-office/magicpoint/files/magicpoint-1.12a-implicit-declaration.patch32
-rw-r--r--app-office/magicpoint/magicpoint-1.12a-r1.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/app-office/magicpoint/ChangeLog b/app-office/magicpoint/ChangeLog
index 3ef9c361186f..cd32ff9af640 100644
--- a/app-office/magicpoint/ChangeLog
+++ b/app-office/magicpoint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/magicpoint
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.33 2007/10/26 20:04:52 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.34 2007/10/27 10:27:03 opfer Exp $
+
+ 27 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/magicpoint-1.12a-implicit-declaration.patch,
+ magicpoint-1.12a-r1.ebuild:
+ add patch to kill QA warnings, provided by Thomas Anderson
26 Oct 2007; Christoph Mende <angelos@gentoo.org>
magicpoint-1.12a-r1.ebuild:
diff --git a/app-office/magicpoint/files/magicpoint-1.12a-implicit-declaration.patch b/app-office/magicpoint/files/magicpoint-1.12a-implicit-declaration.patch
new file mode 100644
index 000000000000..631b1a033a6b
--- /dev/null
+++ b/app-office/magicpoint/files/magicpoint-1.12a-implicit-declaration.patch
@@ -0,0 +1,32 @@
+--- magicpoint-1.12a/ctlwords.c 1999-02-14 18:02:25.000000000 -0500
++++ ctlwords.c 2007-10-26 15:41:16.000000000 -0400
+@@ -24,6 +24,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ main(int argc, char *argv[])
+ {
+--- magicpoint-1.12a/image/gif.c 2000-03-07 01:59:56.000000000 -0500
++++ gif.c 2007-10-26 15:42:36.000000000 -0400
+@@ -17,6 +17,7 @@
+
+ #include "image.h"
+ #include <gif_lib.h>
++#include <stdlib.h>
+
+ static void
+ tellAboutImage(name, gifp)
+--- magicpoint-1.12a/image/misc.c 2004-07-28 11:47:31.000000000 -0400
++++ misc.c 2007-10-26 15:43:20.000000000 -0400
+@@ -12,9 +12,7 @@
+ #include "xloadimage.h"
+ #include "patchlevel"
+ #include <signal.h>
+-#ifdef __APPLE__
+ #include <stdlib.h>
+-#endif
+
+ extern int _Xdebug;
+ extern Display *display;
diff --git a/app-office/magicpoint/magicpoint-1.12a-r1.ebuild b/app-office/magicpoint/magicpoint-1.12a-r1.ebuild
index a85b14c4a150..38872e8bf2e0 100644
--- a/app-office/magicpoint/magicpoint-1.12a-r1.ebuild
+++ b/app-office/magicpoint/magicpoint-1.12a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.12a-r1.ebuild,v 1.6 2007/10/26 20:04:52 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.12a-r1.ebuild,v 1.7 2007/10/27 10:27:03 opfer Exp $
inherit autotools elisp-common eutils fixheadtails
@@ -40,6 +40,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-1.11b-gentoo.diff"
+ epatch "${FILESDIR}/${P}-implicit-declaration.patch"
# bug #85720
sed -i -e "s/ungif/gif/g" configure.in || die "sed failed"