summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-08-31 09:11:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-08-31 09:11:32 +0000
commit295147a719770f9557bcc7c806e9f8e97a74b791 (patch)
treec28ff8eca991e2285976183bf66958b7366451b2 /app-office/libreoffice/libreoffice-9999.ebuild
parentMask net-irc/conspire for removal (diff)
downloadgentoo-2-295147a719770f9557bcc7c806e9f8e97a74b791.tar.gz
gentoo-2-295147a719770f9557bcc7c806e9f8e97a74b791.tar.bz2
gentoo-2-295147a719770f9557bcc7c806e9f8e97a74b791.zip
Fix bash completion placement. Fixes bug #380977.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index b92ac4e24745..fe9143c17f69 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999.ebuild,v 1.18 2011/08/23 11:07:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999.ebuild,v 1.19 2011/08/31 09:11:32 scarabeus Exp $
EAPI=3
@@ -25,7 +25,7 @@ ADDONS_URI="http://dev-www.libreoffice.org/src/"
BRANDING="${PN}-branding-gentoo-0.3.tar.xz"
[[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
-inherit base autotools check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
+inherit base autotools bash-completion check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="LibreOffice, a full office productivity suite."
@@ -548,6 +548,10 @@ src_install() {
# This is not Makefile so no buildserver
make DESTDIR="${D}" distro-pack-install || die
+ # Fix bash completion placement
+ dobashcompletion "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
+ rm -rf "${ED}"/etc/
+
# symlink the plugin to system location
if use nsplugin; then
inst_plugin /usr/$(get_libdir)/libreoffice/program/libnpsoplugin.so