summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-08 17:29:48 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-08 17:29:48 +0000
commit8cb9f6e530a06e76df01487858a404085d2a7185 (patch)
tree6e339b5a1441f31437b02bfee9ae58d9fb003c8c /app-office/kword
parentSync to branch plus various fixes. (diff)
downloadgentoo-2-8cb9f6e530a06e76df01487858a404085d2a7185.tar.gz
gentoo-2-8cb9f6e530a06e76df01487858a404085d2a7185.tar.bz2
gentoo-2-8cb9f6e530a06e76df01487858a404085d2a7185.zip
Sync to branch plus various fixes.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-office/kword')
-rw-r--r--app-office/kword/ChangeLog10
-rw-r--r--app-office/kword/kword-1.6.3_p20090204.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 51c89a0e7d2c..b665261c97b1 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kword
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.117 2008/05/18 01:06:05 hanno Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.118 2009/02/08 17:29:48 carlo Exp $
+
+*kword-1.6.3_p20090204 (08 Feb 2009)
+
+ 08 Feb 2009; Carsten Lohrke <carlo@gentoo.org>
+ +kword-1.6.3_p20090204.ebuild:
+ Sync to branch plus various fixes.
18 May 2008; Hanno Boeck <hanno@gentoo.org> +files/kword-gcc43.patch,
kword-1.6.3-r2.ebuild:
diff --git a/app-office/kword/kword-1.6.3_p20090204.ebuild b/app-office/kword/kword-1.6.3_p20090204.ebuild
new file mode 100644
index 000000000000..fa1cab8cd7ef
--- /dev/null
+++ b/app-office/kword/kword-1.6.3_p20090204.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6.3_p20090204.ebuild,v 1.1 2009/02/08 17:29:48 carlo Exp $
+
+
+ARTS_REQUIRED="never"
+
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~app-office/koffice-libs-1.6.3_p20090204
+ ~app-office/kspread-1.6.3_p20090204
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.5
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > "${S}"/filters/Makefile.am
+
+ for i in $(find "${S}"/lib -iname "*\.ui"); do
+ "${QTDIR}"/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}