summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-27 16:35:54 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-27 16:35:54 +0000
commitd499d4d10ab0ea48a78acdaefb1acbc868bb4980 (patch)
tree30ebc661c5fd582312313f5d7b3a3d71a3c1bc25 /app-office/imposter/imposter-0.3.ebuild
parentdepend on xen-r1 ebuild (diff)
downloadgentoo-2-d499d4d10ab0ea48a78acdaefb1acbc868bb4980.tar.gz
gentoo-2-d499d4d10ab0ea48a78acdaefb1acbc868bb4980.tar.bz2
gentoo-2-d499d4d10ab0ea48a78acdaefb1acbc868bb4980.zip
after ages a new release
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-office/imposter/imposter-0.3.ebuild')
-rw-r--r--app-office/imposter/imposter-0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-office/imposter/imposter-0.3.ebuild b/app-office/imposter/imposter-0.3.ebuild
new file mode 100644
index 000000000000..0c7f9ed2bc38
--- /dev/null
+++ b/app-office/imposter/imposter-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/imposter/imposter-0.3.ebuild,v 1.1 2005/10/27 16:35:54 suka Exp $
+
+inherit eutils
+
+DESCRIPTION="Imposter is a standalone viewer for the presentations created by OpenOffice.org Impress software"
+HOMEPAGE="http://imposter.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/imposter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="iksemel"
+DEPEND="virtual/x11
+ dev-libs/atk
+ x11-libs/pango
+ dev-libs/glib
+ dev-util/pkgconfig
+ >=x11-libs/gtk+-2.4.0
+ iksemel? ( >=dev-libs/iksemel-1.2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Patch by Recai OktaÅŸ <roktas@omu.edu.tr>, backported from CVS...
+ epatch "${FILESDIR}/${P}-ignore-modifiers.patch"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}