summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-11-02 18:13:30 +0000
committerAlin Năstac <mrness@gentoo.org>2008-11-02 18:13:30 +0000
commitd3523d5c85db64b6a84ac7c2882e7548b19967e1 (patch)
tree8fb04ed8f4404ac89e7f352b1f2e1367bfd7aabb /app-mobilephone
parentRemoving jmglov as a maintainer since he was retired. (diff)
downloadgentoo-2-d3523d5c85db64b6a84ac7c2882e7548b19967e1.tar.gz
gentoo-2-d3523d5c85db64b6a84ac7c2882e7548b19967e1.tar.bz2
gentoo-2-d3523d5c85db64b6a84ac7c2882e7548b19967e1.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/bitpim/ChangeLog10
-rw-r--r--app-mobilephone/bitpim/bitpim-1.0.6.ebuild147
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch12
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch22
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch90
-rwxr-xr-xapp-mobilephone/bitpim/files/maketarball30
6 files changed, 310 insertions, 1 deletions
diff --git a/app-mobilephone/bitpim/ChangeLog b/app-mobilephone/bitpim/ChangeLog
index fc6bfabbcc5a..eb2d95d963b6 100644
--- a/app-mobilephone/bitpim/ChangeLog
+++ b/app-mobilephone/bitpim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-mobilephone/bitpim
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.26 2008/07/01 18:56:50 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.27 2008/11/02 18:13:30 mrness Exp $
+
+*bitpim-1.0.6 (02 Nov 2008)
+
+ 02 Nov 2008; Alin Năstac <mrness@gentoo.org>
+ +files/bitpim-1.0.6-ffmpeg_quality.patch, +files/bitpim-1.0.6-gcc43.patch,
+ +files/bitpim-1.0.6-gentoo.patch, +files/maketarball,
+ +bitpim-1.0.6.ebuild:
+ Version bump.
01 Jul 2008; Alin Năstac <mrness@gentoo.org>
+files/bitpim-1.0.5-gcc43.patch, bitpim-1.0.5.ebuild:
diff --git a/app-mobilephone/bitpim/bitpim-1.0.6.ebuild b/app-mobilephone/bitpim/bitpim-1.0.6.ebuild
new file mode 100644
index 000000000000..b14234d75c05
--- /dev/null
+++ b/app-mobilephone/bitpim/bitpim-1.0.6.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/bitpim-1.0.6.ebuild,v 1.1 2008/11/02 18:13:30 mrness Exp $
+
+inherit distutils fdo-mime multilib
+
+DESCRIPTION="Program to view and manipulate data on LG VX4400/VX6000 and many Sanyo Sprint mobile phones"
+HOMEPAGE="http://www.bitpim.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# this needs fixing
+#KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="crypt evo usb"
+
+COMMON_DEPEND="=dev-python/wxpython-2.8*
+ dev-python/python-dsv
+ dev-python/pyserial
+ dev-python/apsw
+ crypt? ( >=dev-python/paramiko-1.7.1
+ dev-python/pycrypto )
+ usb? ( dev-libs/libusb )"
+DEPEND="${COMMON_DEPEND}
+ usb? ( dev-lang/swig )"
+RDEPEND="${COMMON_DEPEND}
+ media-video/ffmpeg
+ media-libs/netpbm
+ >=dev-lang/python-2.5"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-ffmpeg_quality.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ sed -i "s/python2.3/${python}/" "${S}/src/native/usb/build.sh"
+}
+
+src_compile() {
+ # USB stuff
+ if use usb; then
+ cd "${S}/src/native/usb"
+ sh ./build.sh || die "compilation of native/usb failed"
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ ${python} setup.py build || die "compilation of native/strings failed"
+
+ # bmp2avi
+ cd "${S}/src/native/av/bmp2avi"
+ PLATFORM=linux make || die "compilation of native/bmp2avi failed"
+}
+
+src_install() {
+
+ # Install files into right place
+ #
+ # BitPim is a self-contained app, so jamming it into
+ # Python's site-packages might not be worthwhile. We'll
+ # Put it in its own home, and add the PYTHONPATH in the
+ # wrapper executables below.
+ distutils_python_version
+ local RLOC=/usr/$(get_libdir)/${P}
+
+ # Main Python source
+ insinto ${RLOC}
+ doins src/*.py
+
+ # Phone specifics
+ insinto ${RLOC}/phones
+ doins src/phones/*.py
+
+ # Native products
+ insinto ${RLOC}/native
+ doins src/native/*.py
+ insinto ${RLOC}/native/qtopiadesktop
+ doins src/native/qtopiadesktop/*.py
+ insinto ${RLOC}/native/outlook
+ doins src/native/outlook/*.py
+ insinto ${RLOC}/native/egroupware
+ doins src/native/egroupware/*.py
+ if use evo ; then
+ insinto ${RLOC}/native/evolution
+ doins src/native/evolution/*.py
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ ${python} setup.py install --root="${D}" --no-compile "$@" \
+ || die "install of native/strings failed"
+
+ cd "${S}"
+ insinto $RLOC/native/strings
+ doins src/native/strings/__init__.py src/native/strings/jarowpy.py
+
+ # usb
+ if use usb; then
+ insinto ${RLOC}/native/usb
+ doins src/native/usb/*.py
+ doins src/native/usb/*.so
+ fi
+
+ # Helpers and resources
+ dobin src/native/av/bmp2avi/bmp2avi
+ insinto ${RLOC}/resources
+ doins resources/*
+
+ # Bitfling
+ if use crypt; then
+ FLINGDIR="${RLOC}/bitfling"
+ insinto $FLINGDIR
+ cd "${S}/src/bitfling"
+ doins *.py
+ cd "${S}"
+ fi
+
+ # Creating scripts
+ echo '#!/bin/sh' > "${T}/bitpim"
+ echo "exec ${python} ${RLOC}/bp.py \"\$@\"" >> "${T}/bitpim"
+ dobin "${T}/bitpim"
+ if use crypt; then
+ echo '#!/bin/sh' > "${T}/bitfling"
+ echo "exec ${python} ${RLOC}/bp.py \"\$@\" bitfling" >> "${T}/bitfling"
+ dobin "${T}/bitfling"
+ fi
+
+ # Desktop file
+ insinto /usr/share/applications
+ sed -i -e "s|%%INSTALLBINDIR%%|/usr/bin|" -e "s|%%INSTALLLIBDIR%%|${RLOC}|" \
+ packaging/bitpim.desktop
+ doins packaging/bitpim.desktop
+}
+
+pkg_postinst() {
+ # Optimize in installed directory
+ python_mod_optimize /usr/$(get_libdir)/${P}
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${P}
+ fdo-mime_desktop_database_update
+}
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch
new file mode 100644
index 000000000000..2a5b7cb5237b
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch
@@ -0,0 +1,12 @@
+diff -Nru bitpim-1.0.6.orig/src/conversions.py bitpim-1.0.6/src/conversions.py
+--- bitpim-1.0.6.orig/src/conversions.py 2008-11-02 13:51:31.000000000 +0000
++++ bitpim-1.0.6/src/conversions.py 2008-11-02 13:52:21.000000000 +0000
+@@ -239,7 +239,7 @@
+ ffmpeg=gethelperbinary("ffmpeg")
+ with common.usetempfile('mp3') as mp3file:
+ try:
+- run(ffmpeg, "-i", shortfilename(inputfilename), "-hq", "-ab", `bitrate`, "-ar", `samplerate`, "-ac", `channels`, shortfilename(mp3file))
++ run(ffmpeg, "-i", shortfilename(inputfilename), "-sameq", "-ab", `bitrate`, "-ar", `samplerate`, "-ac", `channels`, shortfilename(mp3file))
+ except common.CommandExecutionFailed, e:
+ # we get this exception on bad parameters, or any other
+ # issue so we assume bad parameters for the moment.
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch
new file mode 100644
index 000000000000..dfb02d931a7a
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/avi_file.cxx bitpim-1.0.6/src/native/av/bmp2avi/avi_file.cxx
+--- bitpim-1.0.6.orig/src/native/av/bmp2avi/avi_file.cxx 2005-02-18 06:55:03.000000000 +0000
++++ bitpim-1.0.6/src/native/av/bmp2avi/avi_file.cxx 2008-11-02 13:54:15.000000000 +0000
+@@ -9,6 +9,7 @@
+
+ #include "avi_file.h"
+ #include "byte_order.h"
++#include <cstring>
+
+ // endian conversion routines
+
+diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/bmp_file.cxx bitpim-1.0.6/src/native/av/bmp2avi/bmp_file.cxx
+--- bitpim-1.0.6.orig/src/native/av/bmp2avi/bmp_file.cxx 2005-02-18 06:55:03.000000000 +0000
++++ bitpim-1.0.6/src/native/av/bmp2avi/bmp_file.cxx 2008-11-02 13:54:15.000000000 +0000
+@@ -11,6 +11,7 @@
+ #include <string>
+ #include "bmp_file.h"
+ #include "byte_order.h"
++#include <cstring>
+
+ using namespace std;
+
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch
new file mode 100644
index 000000000000..ed7f96e62898
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch
@@ -0,0 +1,90 @@
+diff -Nru bitpim-1.0.6.orig/src/common.py bitpim-1.0.6/src/common.py
+--- bitpim-1.0.6.orig/src/common.py 2007-08-29 00:19:51.000000000 +0000
++++ bitpim-1.0.6/src/common.py 2008-11-02 13:50:39.000000000 +0000
+@@ -860,7 +860,7 @@
+ # windows running from exe, return as is
+ return os.path.abspath(os.path.dirname(sys.executable))
+ # running from src, up one
+- return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
++ return os.path.abspath(os.path.dirname(sys.argv[0]))
+
+ if sys.platform=='win32':
+ # From Tim Golden's Win32 How Do I ...?
+diff -Nru bitpim-1.0.6.orig/src/conversions.py bitpim-1.0.6/src/conversions.py
+--- bitpim-1.0.6.orig/src/conversions.py 2007-08-29 00:19:51.000000000 +0000
++++ bitpim-1.0.6/src/conversions.py 2008-11-02 13:50:39.000000000 +0000
+@@ -23,11 +23,11 @@
+
+ class ConversionFailed(Exception): pass
+
+-helperdir=os.path.join(common.get_main_dir(), "helpers")
++helperdir="/usr/bin"
+
+ osext={'win32': '.exe',
+ 'darwin': '.mbin',
+- 'linux2': '.lbin'} \
++ 'linux2': ''} \
+ [sys.platform]
+
+ # This shortname crap is needed because Windows programs (including ffmpeg)
+@@ -128,14 +128,14 @@
+ p=sys.path[0]
+ if os.path.isfile(p):
+ p=os.path.dirname(p)
+- helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
++ helpersdirectory="/usr/bin"
+ print "Helper Directory: "+helpersdirectory
+ if sys.platform=='win32':
+ osext=".exe"
+ if sys.platform=='darwin':
+ osext=".mbin"
+ if sys.platform=='linux2':
+- osext=".lbin"
++ osext=""
+
+ pngtopnmbin=gethelperbinary('pngtopnm')
+ ppmquantbin=gethelperbinary('ppmquant')
+diff -Nru bitpim-1.0.6.orig/src/importexport.py bitpim-1.0.6/src/importexport.py
+--- bitpim-1.0.6.orig/src/importexport.py 2007-08-27 04:58:33.000000000 +0000
++++ bitpim-1.0.6/src/importexport.py 2008-11-02 13:50:39.000000000 +0000
+@@ -23,7 +23,7 @@
+ import wx.html
+
+ # Others
+-from thirdparty import DSV
++import DSV
+
+ # My modules
+ import common
+diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/Makefile bitpim-1.0.6/src/native/av/bmp2avi/Makefile
+--- bitpim-1.0.6.orig/src/native/av/bmp2avi/Makefile 2006-05-05 07:10:08.000000000 +0000
++++ bitpim-1.0.6/src/native/av/bmp2avi/Makefile 2008-11-02 13:50:39.000000000 +0000
+@@ -13,6 +13,6 @@
+
+ SRC=avi_file.cxx bmp_file.cxx b2a.cxx
+
+-bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
++bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
+ $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
+
+diff -Nru bitpim-1.0.6.orig/src/native/usb/build.sh bitpim-1.0.6/src/native/usb/build.sh
+--- bitpim-1.0.6.orig/src/native/usb/build.sh 2007-08-10 21:53:59.000000000 +0000
++++ bitpim-1.0.6/src/native/usb/build.sh 2008-11-02 13:50:39.000000000 +0000
+@@ -4,4 +4,4 @@
+ swig -python -I/usr/include libusb.i
+
+ gcc -fPIC -Wall -fno-strict-aliasing -O2 -g -shared -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb
+-strip _libusb.so
++#strip _libusb.so
+diff -Nru bitpim-1.0.6.orig/src/phones/com_samsung.py bitpim-1.0.6/src/phones/com_samsung.py
+--- bitpim-1.0.6.orig/src/phones/com_samsung.py 2007-08-17 21:11:59.000000000 +0000
++++ bitpim-1.0.6/src/phones/com_samsung.py 2008-11-02 13:50:39.000000000 +0000
+@@ -16,7 +16,7 @@
+ import time
+
+ # site-packages
+-from thirdparty import DSV
++import DSV
+
+ # BitPim modules
+ import bpcalendar
diff --git a/app-mobilephone/bitpim/files/maketarball b/app-mobilephone/bitpim/files/maketarball
new file mode 100755
index 000000000000..8df7f071df9a
--- /dev/null
+++ b/app-mobilephone/bitpim/files/maketarball
@@ -0,0 +1,30 @@
+# For building the tarball. To be used only by ebuild maintainers
+DISTDIR=/usr/portage/distfiles
+PN=bitpim
+PV=$1
+P=$PN-$PV
+
+if [ -z "$PV" ]; then
+ echo "usage: $0 version"
+else
+ svnrev=$(svn log -q --limit 1 https://${PN}.svn.sourceforge.net/svnroot/${PN}/releases/${PV} | sed -r '/^[^r]/d;s/^r([0-9]+) .*$/\1/')
+ [ $? = 0 ] || return 1
+
+ #Fetch the source (only those directories that are needed)
+ cd "${DISTDIR}" && mkdir -p ${P} || return 1
+ for x in resources packaging src ; do
+ svn export https://${PN}.svn.sourceforge.net/svnroot/${PN}/releases/${PV}/${x} ${P}/${x} || return 1
+ done
+
+ #Remove unneeded stuff
+ rm ${P}/resources/*.chm ${P}/src/package.py
+
+ #Freeze version and set vendor name to Gentoo
+ sed -i -e 's/\(^__FROZEN__="[$]Id: \).*\( $"\)/\1'${svnrev}'\2/' \
+ -e 's/^vendor=".*"/vendor="Gentoo"/' \
+ ${P}/src/version.py || return 1
+
+ #Make the tarball
+ tar -cjf ${P}.tar.bz2 ${P}
+ rm -r ${P}
+fi