summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-02-01 21:46:20 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-02-01 21:46:20 +0000
commit2cf5b6287aa17fe6ac3aa87f1d8e4ef2aa1d84c0 (patch)
tree43e56910f85a47f6307ee982e6b422b4a4801e53 /app-mobilephone/gammu
parentMarking vim-7.2.303 ppc64 for bug 301975 (diff)
downloadgentoo-2-2cf5b6287aa17fe6ac3aa87f1d8e4ef2aa1d84c0.tar.gz
gentoo-2-2cf5b6287aa17fe6ac3aa87f1d8e4ef2aa1d84c0.tar.bz2
gentoo-2-2cf5b6287aa17fe6ac3aa87f1d8e4ef2aa1d84c0.zip
version bump for bug 298020
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'app-mobilephone/gammu')
-rw-r--r--app-mobilephone/gammu/ChangeLog9
-rw-r--r--app-mobilephone/gammu/gammu-1.27.0.ebuild87
2 files changed, 94 insertions, 2 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 80c421b756ea..396801633528 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/gammu
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.78 2009/10/24 11:02:16 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.79 2010/02/01 21:46:20 fauli Exp $
+
+*gammu-1.27.0 (01 Feb 2010)
+
+ 01 Feb 2010; Christian Faulhammer <fauli@gentoo.org> +gammu-1.27.0.ebuild:
+ version bump for bug 298020
24 Oct 2009; nixnut <nixnut@gentoo.org> gammu-1.25.0-r1.ebuild:
ppc stable #283672
diff --git a/app-mobilephone/gammu/gammu-1.27.0.ebuild b/app-mobilephone/gammu/gammu-1.27.0.ebuild
new file mode 100644
index 000000000000..1af4c5b9593a
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.27.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.27.0.ebuild,v 1.1 2010/02/01 21:46:20 fauli Exp $
+
+EAPI="2"
+
+inherit cmake-utils distutils
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+HOMEPAGE="http://www.gammu.org"
+SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
+
+RDEPEND="bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
+ curl? ( net-misc/curl )
+ usb? ( dev-libs/libusb:1 )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )
+ dbi? ( >=dev-db/libdbi-0.8.3 )
+ dev-util/dialog
+ dev-lang/python
+ !dev-python/python-gammu" # needs to be removed from the tree
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ dev-util/cmake"
+
+# sys-devel/gettext is needed for creating .mo files
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-skip-locktest.patch
+
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -rf locale/${lang} || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ # debug flag is used inside cmake-utils.eclass
+ local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
+ $(cmake-utils_use_with irda IRDA) \
+ $(cmake-utils_use_with curl CURL) \
+ $(cmake-utils_use_with usb USB) \
+ $(cmake-utils_use_with python PYTHON) \
+ $(cmake-utils_use_with mysql MySQL) \
+ $(cmake-utils_use_with postgres Postgres) \
+ $(cmake-utils_use_with dbi LibDBI) \
+ $(cmake-utils_use_with nls GettextLibs) \
+ $(cmake-utils_use_with nls Iconv) \
+ -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
+ if use python; then
+ mycmakeargs="${mycmakeargs} -DBUILD_PYTHON=/usr/bin/python"
+ fi
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}