summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-28 15:15:00 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-28 15:15:00 +0000
commitfcba5ea41bcda0633bd99adefdf320c0f3108283 (patch)
tree8db4a920822dceef4ec6f16385ba92a48ace69c8 /app-misc
parentFix NSInvalidArgumentException on document creation, patch from Debian in bug... (diff)
downloadgentoo-2-fcba5ea41bcda0633bd99adefdf320c0f3108283.tar.gz
gentoo-2-fcba5ea41bcda0633bd99adefdf320c0f3108283.tar.bz2
gentoo-2-fcba5ea41bcda0633bd99adefdf320c0f3108283.zip
New ebuild for fslint, from sunrise overlay. EAPI 5. Made install function more specific and give binaries +x permissions. Fixes bug #33341.
(Portage version: 2.1.11.59/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fslint/ChangeLog10
-rw-r--r--app-misc/fslint/Manifest4
-rw-r--r--app-misc/fslint/fslint-2.42.ebuild68
-rw-r--r--app-misc/fslint/metadata.xml11
4 files changed, 93 insertions, 0 deletions
diff --git a/app-misc/fslint/ChangeLog b/app-misc/fslint/ChangeLog
new file mode 100644
index 000000000000..114125c25a86
--- /dev/null
+++ b/app-misc/fslint/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-misc/fslint
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fslint/ChangeLog,v 1.1 2013/03/28 15:15:00 tomwij Exp $
+
+*fslint-2.42 (28 Mar 2013)
+
+ 28 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +fslint-2.42.ebuild,
+ +metadata.xml:
+ New ebuild for fslint, from sunrise overlay. EAPI 5. Made install function
+ more specific and give binaries +x permissions. Fixes bug #33341.
diff --git a/app-misc/fslint/Manifest b/app-misc/fslint/Manifest
new file mode 100644
index 000000000000..df261d495135
--- /dev/null
+++ b/app-misc/fslint/Manifest
@@ -0,0 +1,4 @@
+DIST fslint-2.42.tar.gz 111520 SHA256 babbef4a34f42ab1d396152fd79b4353adc114b2e8d68b838e20a8067c5a3273 SHA512 e32575827769a6e0e1847f6edb4ed5337fc5705d65f327e93510af29cafe11df175eec9924f15e9525ff7c320048940e9341e9e62b4ec717b2630aa405a484e6 WHIRLPOOL fc74fb8ddd9d03283d6f7ec7763c2efef9036242ab5ba487046af14f880f0bc8661cec07614fc61fcee684933614abe49142f6dde4c3ef1d42d0f5292437be67
+EBUILD fslint-2.42.ebuild 1574 SHA256 d87c02d09688678e15b038411aadace914c899a0cc7fe3013a4e7f1d1c83e089 SHA512 8f715045ac8300ea4261b35ebf4feaab5848c60087c51616aa9c2b2694335602c586470fe03451e349f9129fa30bdc13dcde7fa2e529a768729b4cc32471279e WHIRLPOOL c4024cf3438541c2e8b74fda151bbbaa171af37efdb0add9c3d1c9a91f02284fcb1a946e9cf9630c334ae145b11e4df6ab42a2f674aa7e54708f20c0387ff768
+MISC ChangeLog 374 SHA256 19427377704fc8cf25f7f842cc8b722ed1518391706a383059c1d2518e4bfdee SHA512 b2d062dcae3cbbab819881ce21fe47f3a263e45f1e9d53f0491b301a9d15525288217a84229844fcfc9403a0778326d58660024a382bdef057059b86361b948d WHIRLPOOL 206f74c107b125e8e958e2574e97a44cf272198905e27882af9111910ebe2fb3df2303b6b7dc9b8383dd5a405528b480a51e368d01249b85bad2f3c2532629ce
+MISC metadata.xml 339 SHA256 0e25a7be0783b62b1d2726e63f714ef687c5f9da4612ba90e722ea5e54d09911 SHA512 99d6e357a8479296b482eaeacbe8f4f9c00c08dbbf078328d787d784d058485d73b7f7a5fce1500d6546487526d4ea1e8e1b3dc3719ae31725fa65b95da54a4e WHIRLPOOL f6f234cb154f839dc6f6b2f3a19dcd664f0b8fccd7bfad70d0054b0f1cfcad0f93b5a72d72fd901511569df3ea4cb48bf4a9606e6b4ded988901bb23af54d820
diff --git a/app-misc/fslint/fslint-2.42.ebuild b/app-misc/fslint/fslint-2.42.ebuild
new file mode 100644
index 000000000000..866d81008d56
--- /dev/null
+++ b/app-misc/fslint/fslint-2.42.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fslint/fslint-2.42.ebuild,v 1.1 2013/03/28 15:15:00 tomwij Exp $
+
+EAPI="5"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An utility to find various forms of lint on a filesystem."
+HOMEPAGE="http://www.pixelbeat.org/${PN}/"
+SRC_URI="http://www.pixelbeat.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="dev-python/pygtk:2"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+
+ # Change some paths to make fslint-gui run when installed in /usr/bin.
+ sed -e "s:^liblocation=.*$:liblocation='${EROOT}usr/share/${PN}' #Gentoo:" \
+ -e "s:^locale_base=.*$:locale_base=None #Gentoo:" \
+ -i fslint-gui || die "sed failed"
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins ${PN}{.glade,.gladep,_icon.png}
+
+ insinto /usr/share/${PN}/${PN}
+ doins ${PN}/find*
+ doins ${PN}/${PN}
+ doins ${PN}/zipdir
+
+ insinto /usr/share/${PN}/${PN}/fstool/
+ doins ${PN}/fstool/*
+
+ insinto /usr/share/${PN}/${PN}/supprt/
+ doins ${PN}/supprt/*
+
+ insinto /usr/share/${PN}/${PN}/supprt/rmlint
+ doins ${PN}/supprt/rmlint/*
+
+ fperms +x /usr/share/${PN}/${PN}/find*
+ fperms +x /usr/share/${PN}/${PN}/zipdir
+ fperms +x /usr/share/${PN}/${PN}/fstool/*
+ fperms +x /usr/share/${PN}/${PN}/supprt/*
+ fperms +x /usr/share/${PN}/${PN}/supprt/rmlint/{fixdup,merge_hardlinks}
+
+ dobin ${PN}-gui
+
+ doicon ${PN}_icon.png
+ domenu ${PN}.desktop
+
+ dodoc doc/{FAQ,NEWS,README,TODO}
+ doman man/{fslint.1,fslint-gui.1}
+
+ if use nls ; then
+ cd po
+ emake DESTDIR="${D}" install
+ fi
+}
diff --git a/app-misc/fslint/metadata.xml b/app-misc/fslint/metadata.xml
new file mode 100644
index 000000000000..1b9295d3078b
--- /dev/null
+++ b/app-misc/fslint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <longdescription>
+ An utility to find various forms of lint on a filesystem.
+ </longdescription>
+</pkgmetadata>