summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-10-17 18:22:33 +0000
committerTorsten Veller <tove@gentoo.org>2009-10-17 18:22:33 +0000
commitb3bdc58ba50ee9d856e8c159992199fd7799cf13 (patch)
tree029b5f2651f3897cf4154220aed5efb0d4eb2810 /app-misc
parentTypo in ChangeLog. (diff)
downloadgentoo-2-b3bdc58ba50ee9d856e8c159992199fd7799cf13.tar.gz
gentoo-2-b3bdc58ba50ee9d856e8c159992199fd7799cf13.tar.bz2
gentoo-2-b3bdc58ba50ee9d856e8c159992199fd7799cf13.zip
Patch to fix a segfault bug in editor (#287113)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/abook/ChangeLog10
-rw-r--r--app-misc/abook/abook-0.5.6-r1.ebuild33
-rw-r--r--app-misc/abook/files/0.5.6-01_editor.patch18
3 files changed, 59 insertions, 2 deletions
diff --git a/app-misc/abook/ChangeLog b/app-misc/abook/ChangeLog
index 2a4caf8d7a6e..f6324b5b325d 100644
--- a/app-misc/abook/ChangeLog
+++ b/app-misc/abook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/abook
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/ChangeLog,v 1.48 2007/07/21 21:08:54 grobian Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/ChangeLog,v 1.49 2009/10/17 18:22:32 tove Exp $
+
+*abook-0.5.6-r1 (17 Oct 2009)
+
+ 17 Oct 2009; Torsten Veller <tove@gentoo.org> +abook-0.5.6-r1.ebuild,
+ +files/0.5.6-01_editor.patch:
+ Patch to fix a segfault bug in editor (#287113). Thanks Arseny Solokha.
21 Jul 2007; Fabian Groffen <grobian@gentoo.org> abook-0.5.6.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-misc/abook/abook-0.5.6-r1.ebuild b/app-misc/abook/abook-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..4d26bc364dfe
--- /dev/null
+++ b/app-misc/abook/abook-0.5.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.5.6-r1.ebuild,v 1.1 2009/10/17 18:22:32 tove Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client."
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="mirror://sourceforge/abook/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-01_editor.patch
+}
+
+src_configure() {
+ econf $(use_enable nls) || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc BUGS ChangeLog FAQ README TODO \
+ sample.abookrc || die "dodoc failed"
+}
diff --git a/app-misc/abook/files/0.5.6-01_editor.patch b/app-misc/abook/files/0.5.6-01_editor.patch
new file mode 100644
index 000000000000..bacfd55a491d
--- /dev/null
+++ b/app-misc/abook/files/0.5.6-01_editor.patch
@@ -0,0 +1,18 @@
+--- ui.c 10 Apr 2006 08:15:46 -0000 1.57
++++ ui.c 6 Sep 2006 02:24:33 -0000 1.58
+@@ -569,9 +569,13 @@
+ } else {
+ char *s;
+ s = ui_readline("/", findstr, MAX_FIELD_LEN - 1, 0);
+- strncpy(findstr, s, MAX_FIELD_LEN);
+- free(s);
+ refresh_screen();
++ if(s == NULL) {
++ return; /* user cancelled (ctrl-G) */
++ } else {
++ strncpy(findstr, s, MAX_FIELD_LEN);
++ free(s);
++ }
+ }
+
+ if( (item = find_item(findstr, curitem + !!next, search_fields)) < 0 &&