summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-02-19 19:47:19 +0000
committerTorsten Veller <tove@gentoo.org>2012-02-19 19:47:19 +0000
commit81f671c8d033bc84b31c45b7d0b587845b1763a1 (patch)
treebb9c4b5e0a8073ddf6f168473d9da308556a6afc /app-misc
parentMask FSF GCC on Mac OS X profiles, because Gentoo Prefix does not support its... (diff)
downloadgentoo-2-81f671c8d033bc84b31c45b7d0b587845b1763a1.tar.gz
gentoo-2-81f671c8d033bc84b31c45b7d0b587845b1763a1.tar.bz2
gentoo-2-81f671c8d033bc84b31c45b7d0b587845b1763a1.zip
Version bump (#815145). Drop ocaml from RDEPEND (#394367). Thanks to Nick Hebrun and James Rowe
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wyrd/ChangeLog10
-rw-r--r--app-misc/wyrd/wyrd-1.4.5.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/app-misc/wyrd/ChangeLog b/app-misc/wyrd/ChangeLog
index 8bc7e194db0c..0aa62f1f3420 100644
--- a/app-misc/wyrd/ChangeLog
+++ b/app-misc/wyrd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/wyrd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.20 2011/11/22 18:50:07 tove Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.21 2012/02/19 19:47:19 tove Exp $
+
+*wyrd-1.4.5 (19 Feb 2012)
+
+ 19 Feb 2012; Torsten Veller <tove@gentoo.org> +wyrd-1.4.5.ebuild:
+ Version bump (#815145). Drop ocaml from RDEPEND (#394367). Thanks to Nick
+ Hebrun and James Rowe
22 Nov 2011; Torsten Veller <tove@gentoo.org> wyrd-1.4.4.ebuild:
remind was moved from x11-misc to app-misc
diff --git a/app-misc/wyrd/wyrd-1.4.5.ebuild b/app-misc/wyrd/wyrd-1.4.5.ebuild
new file mode 100644
index 000000000000..43e8c0bc9541
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.5.ebuild,v 1.1 2012/02/19 19:47:19 tove Exp $
+
+EAPI=4
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://pessimization.com/software/wyrd/"
+SRC_URI="http://pessimization.com/software/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ sys-libs/ncurses[unicode?]
+ >=app-misc/remind-03.01
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/ocaml-3.08
+"
+
+src_configure() {
+ econf \
+ $(use_enable unicode utf8)
+}
+
+src_compile() {
+ # no parallel build, see https://bugs.launchpad.net/wyrd/+bug/691827
+ emake -j1
+}
+
+src_install() {
+ export STRIP_MASK="/usr/bin/wyrd"
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog
+ dohtml doc/manual.html
+}