summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-06-20 06:29:31 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-06-20 06:29:31 +0000
commit9b81929e5ae18474e319e13c5a2e9966a12010ff (patch)
tree3f11b479d2a72b8414e764c801769400c46516fe /app-misc/pyge/pyge-0.6.1.2.ebuild
parentdigest fix (Manifest recommit) (diff)
downloadgentoo-2-9b81929e5ae18474e319e13c5a2e9966a12010ff.tar.gz
gentoo-2-9b81929e5ae18474e319e13c5a2e9966a12010ff.tar.bz2
gentoo-2-9b81929e5ae18474e319e13c5a2e9966a12010ff.zip
Initial commit bug# 54044. Thanks Tim Cera <timcera@earthlink.net> for the ebuild
Diffstat (limited to 'app-misc/pyge/pyge-0.6.1.2.ebuild')
-rw-r--r--app-misc/pyge/pyge-0.6.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/pyge/pyge-0.6.1.2.ebuild b/app-misc/pyge/pyge-0.6.1.2.ebuild
new file mode 100644
index 000000000000..3e8b82b2c595
--- /dev/null
+++ b/app-misc/pyge/pyge-0.6.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pyge/pyge-0.6.1.2.ebuild,v 1.1 2004/06/20 06:29:31 pythonhead Exp $
+
+inherit eutils
+
+MY_P=${P/pyge/PyGE}
+
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Python Gutenberg E-text (PyGE) project, contains a Gutenberg E-text reader, and utilities for retrieval and compression."
+HOMEPAGE="http://pyge.sourceforge.net"
+SRC_URI="mirror://sourceforge/pyge/${MY_P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.1
+ >=dev-python/wxPython-2.4"
+
+src_install() {
+ python setup.py install --root=${D} --prefix=/usr || die "setup.py install failed"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/help_file_location-${PV}.diff
+ mv pygers.pyw pygers
+ mv pygets.pyw pygets
+ mv pygemz.pyw pygemz
+ sed -i "s/.pyw//g" setup.py || die "Failed on sed setup.py"
+}
+
+pkg_postinst() {
+ einfo "You can find a sample database in /usr/share/pyge/gutenberg.xml"
+ einfo "For speech output you may optionally install app-accessibility/festival"
+}
+