summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-02 19:13:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-02 19:13:36 +0000
commit2d864bc79290105f023a24a1db6ebdf6fe59aab1 (patch)
treee6dce0770670a7c733292681961e0482a08d1c12 /app-misc/ledit
parentVersion bump (diff)
downloadgentoo-2-2d864bc79290105f023a24a1db6ebdf6fe59aab1.tar.gz
gentoo-2-2d864bc79290105f023a24a1db6ebdf6fe59aab1.tar.bz2
gentoo-2-2d864bc79290105f023a24a1db6ebdf6fe59aab1.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'app-misc/ledit')
-rw-r--r--app-misc/ledit/ChangeLog7
-rw-r--r--app-misc/ledit/ledit-2.01.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-misc/ledit/ChangeLog b/app-misc/ledit/ChangeLog
index c6599f3a50c1..d59e0eba42b0 100644
--- a/app-misc/ledit/ChangeLog
+++ b/app-misc/ledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ledit
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.24 2008/04/06 19:53:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.25 2008/07/02 19:13:36 aballier Exp $
+
+*ledit-2.01 (02 Jul 2008)
+
+ 02 Jul 2008; Alexis Ballier <aballier@gentoo.org> +ledit-2.01.ebuild:
+ version bump
06 Apr 2008; Alexis Ballier <aballier@gentoo.org>
-files/ledit-1.11-loc.patch, -ledit-1.11-r1.ebuild:
diff --git a/app-misc/ledit/ledit-2.01.ebuild b/app-misc/ledit/ledit-2.01.ebuild
new file mode 100644
index 000000000000..12773f36f669
--- /dev/null
+++ b/app-misc/ledit/ledit-2.01.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.01.ebuild,v 1.1 2008/07/02 19:13:36 aballier Exp $
+
+inherit eutils
+
+EAPI="1"
+
+RESTRICT="installsources"
+IUSE="+ocamlopt"
+
+DESCRIPTION="A line editor to be used with interactive commands."
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+DEPEND=">=dev-lang/ocaml-3.09 dev-ml/camlp5"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile()
+{
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 ledit.opt || die "make failed"
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install()
+{
+ if use ocamlopt; then
+ newbin ledit.opt ledit
+ else
+ newbin ledit.out ledit
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}