summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-08-11 10:47:32 +0000
committerUlrich Müller <ulm@gentoo.org>2011-08-11 10:47:32 +0000
commiteef5f51e1a9c64b96e7430b6b65c7d10efa5fc08 (patch)
tree7370408817078ec943561b62cec0cd3aad8391ed /app-misc/editor-wrapper
parentPackage moved from app-editors/gentoo-editor to app-misc/editor-wrapper. (diff)
downloadgentoo-2-eef5f51e1a9c64b96e7430b6b65c7d10efa5fc08.tar.gz
gentoo-2-eef5f51e1a9c64b96e7430b6b65c7d10efa5fc08.tar.bz2
gentoo-2-eef5f51e1a9c64b96e7430b6b65c7d10efa5fc08.zip
Version bump, adding wrapper for PAGER.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/editor-wrapper')
-rw-r--r--app-misc/editor-wrapper/ChangeLog8
-rw-r--r--app-misc/editor-wrapper/editor-wrapper-3.ebuild28
-rw-r--r--app-misc/editor-wrapper/files/editor-wrapper-3.sh17
3 files changed, 52 insertions, 1 deletions
diff --git a/app-misc/editor-wrapper/ChangeLog b/app-misc/editor-wrapper/ChangeLog
index b45617e8a416..22095b9e62c9 100644
--- a/app-misc/editor-wrapper/ChangeLog
+++ b/app-misc/editor-wrapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/editor-wrapper
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/editor-wrapper/ChangeLog,v 1.1 2011/08/11 10:40:41 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/editor-wrapper/ChangeLog,v 1.2 2011/08/11 10:47:32 ulm Exp $
+
+*editor-wrapper-3 (11 Aug 2011)
+
+ 11 Aug 2011; Ulrich Mueller <ulm@gentoo.org> +editor-wrapper-3.ebuild,
+ +files/editor-wrapper-3.sh:
+ Version bump, adding wrapper for PAGER.
*editor-wrapper-2 (11 Aug 2011)
diff --git a/app-misc/editor-wrapper/editor-wrapper-3.ebuild b/app-misc/editor-wrapper/editor-wrapper-3.ebuild
new file mode 100644
index 000000000000..a8c1e6439c37
--- /dev/null
+++ b/app-misc/editor-wrapper/editor-wrapper-3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/editor-wrapper/editor-wrapper-3.ebuild,v 1.1 2011/08/11 10:47:32 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Wrapper scripts that will execute EDITOR or PAGER"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -e 's/@VAR@/EDITOR/g' "${FILESDIR}/${P}.sh" >editor || die
+ sed -e 's/@VAR@/PAGER/g' "${FILESDIR}/${P}.sh" >pager || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe editor pager
+ # backwards compatibility
+ dosym editor /usr/libexec/gentoo-editor
+}
diff --git a/app-misc/editor-wrapper/files/editor-wrapper-3.sh b/app-misc/editor-wrapper/files/editor-wrapper-3.sh
new file mode 100644
index 000000000000..34520ffef78a
--- /dev/null
+++ b/app-misc/editor-wrapper/files/editor-wrapper-3.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+# Copyright 2009-2011 Gentoo Foundation
+# Distributed under the terms of the MIT/X11 license
+
+# Wrapper script, executes ${@VAR@} with arguments $@
+
+if [ -z "${@VAR@}" ]; then
+ # Try to get @VAR@ from system profile
+ @VAR@=$(. /etc/profile &>/dev/null; echo "${@VAR@}")
+fi
+
+if [ -z "${@VAR@}" ]; then
+ echo "$0: The @VAR@ variable must be set" >&2
+ exit 1
+fi
+
+exec ${@VAR@} "$@"