summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 03:35:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 03:35:06 +0000
commita7f952dc2651134533e6475a8f736e854d242d51 (patch)
tree297ff040bd9ee8c317b4da2f0e98e9f5b690ef68 /app-misc/digitemp
parentQA - fix use invocation (diff)
downloadgentoo-2-a7f952dc2651134533e6475a8f736e854d242d51.tar.gz
gentoo-2-a7f952dc2651134533e6475a8f736e854d242d51.tar.bz2
gentoo-2-a7f952dc2651134533e6475a8f736e854d242d51.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/digitemp-3.2.0.ebuild13
-rw-r--r--app-misc/digitemp/digitemp-3.3.1.ebuild13
2 files changed, 12 insertions, 14 deletions
diff --git a/app-misc/digitemp/digitemp-3.2.0.ebuild b/app-misc/digitemp/digitemp-3.2.0.ebuild
index e39047f19738..eaf04e442673 100644
--- a/app-misc/digitemp/digitemp-3.2.0.ebuild
+++ b/app-misc/digitemp/digitemp-3.2.0.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.2.0.ebuild,v 1.4 2004/06/24 22:08:19 agriffis Exp $
-
-IUSE="perl python"
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.2.0.ebuild,v 1.5 2004/06/28 03:31:40 vapier Exp $
DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="perl python"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
# default is to compile to the ds9097u. local use flag takes care of
@@ -32,8 +31,8 @@ src_compile() {
}
src_install() {
- dobin digitemp
- dodoc README COPYING FAQ TODO
+ dobin digitemp || die
+ dodoc README FAQ TODO
# method one: don't treat the examples as docs; place them somewhere else.
# then tell the user where to find this stuff. suitable alternative:
diff --git a/app-misc/digitemp/digitemp-3.3.1.ebuild b/app-misc/digitemp/digitemp-3.3.1.ebuild
index 6e78b4f6c272..d053d732d84c 100644
--- a/app-misc/digitemp/digitemp-3.3.1.ebuild
+++ b/app-misc/digitemp/digitemp-3.3.1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.1.ebuild,v 1.3 2004/06/24 22:08:19 agriffis Exp $
-
-IUSE="perl python"
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.1.ebuild,v 1.4 2004/06/28 03:31:40 vapier Exp $
DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="perl python"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
# default is to compile to the ds9097u. local use flag takes care of
@@ -32,8 +31,8 @@ src_compile() {
}
src_install() {
- dobin digitemp
- dodoc README COPYING FAQ TODO
+ dobin digitemp || die
+ dodoc README FAQ TODO
# method one: don't treat the examples as docs; place them somewhere else.
# then tell the user where to find this stuff. suitable alternative: