summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 05:19:41 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 05:19:41 +0000
commitd3c19e701d8c6a03395b26f003758a89c2cfc008 (patch)
tree6cb5c0a23b53e330598b271a73be6817b52a8896 /app-misc/cdspeed
parentRespect LDFLAGS (bug #335584). (diff)
downloadgentoo-2-d3c19e701d8c6a03395b26f003758a89c2cfc008.tar.gz
gentoo-2-d3c19e701d8c6a03395b26f003758a89c2cfc008.tar.bz2
gentoo-2-d3c19e701d8c6a03395b26f003758a89c2cfc008.zip
Respect LDFLAGS (bug #335611), CC. Replace convoluted CFLAGS placement with emake variable. Use emake install instead of dobin. Do not install cdmount as it is nearly useless without changes to the filesystem or to the script.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'app-misc/cdspeed')
-rw-r--r--app-misc/cdspeed/ChangeLog12
-rw-r--r--app-misc/cdspeed/cdspeed-0.4-r1.ebuild34
2 files changed, 44 insertions, 2 deletions
diff --git a/app-misc/cdspeed/ChangeLog b/app-misc/cdspeed/ChangeLog
index cf17bd1da23f..e3bf67ddbd4b 100644
--- a/app-misc/cdspeed/ChangeLog
+++ b/app-misc/cdspeed/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/cdspeed
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/ChangeLog,v 1.23 2009/09/23 15:59:54 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/ChangeLog,v 1.24 2010/09/17 05:19:41 jer Exp $
+
+*cdspeed-0.4-r1 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> +cdspeed-0.4-r1.ebuild:
+ Respect LDFLAGS (bug #335611), CC. Replace convoluted CFLAGS placement
+ with emake variable. Use emake install instead of dobin. Do not install
+ cdmount as it is nearly useless without changes to the filesystem or to
+ the script.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> cdspeed-0.4.ebuild:
Remove virtual/libc
diff --git a/app-misc/cdspeed/cdspeed-0.4-r1.ebuild b/app-misc/cdspeed/cdspeed-0.4-r1.ebuild
new file mode 100644
index 000000000000..f249f5cf6096
--- /dev/null
+++ b/app-misc/cdspeed/cdspeed-0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/cdspeed-0.4-r1.ebuild,v 1.1 2010/09/17 05:19:41 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Change the speed of your CD drive"
+HOMEPAGE="http://linuxfocus.org/~guido/"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "emake install"
+ dodoc README
+}