summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-07-19 01:39:04 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-07-19 01:39:04 +0000
commiteabdb91778bb2ba271cf69bef9b2655c734ef448 (patch)
tree7750903decba0e05e958592c4bc36b7faa75feee /app-laptop
parentVersion bump, upstream provides versioned downloads now. (diff)
downloadgentoo-2-eabdb91778bb2ba271cf69bef9b2655c734ef448.tar.gz
gentoo-2-eabdb91778bb2ba271cf69bef9b2655c734ef448.tar.bz2
gentoo-2-eabdb91778bb2ba271cf69bef9b2655c734ef448.zip
Added patch to remove hdparm settings for bug #185341.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog8
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1-r13
-rw-r--r--app-laptop/pbbuttonsd/files/pmcs.patch21
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r1.ebuild101
4 files changed, 132 insertions, 1 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 0ff311a1675e..a29cc9ff7fa2 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.68 2007/07/07 23:40:18 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.69 2007/07/19 01:39:04 josejx Exp $
+
+*pbbuttonsd-0.8.1-r1 (19 Jul 2007)
+
+ 19 Jul 2007; Joseph Jezak <josejx@gentoo.org> +files/pmcs.patch,
+ +pbbuttonsd-0.8.1-r1.ebuild:
+ Added patch to remove hdparm settings for bug #185341.
*pbbuttonsd-0.8.1 (07 Jul 2007)
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1-r1 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1-r1
new file mode 100644
index 000000000000..68208022e6dc
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1-r1
@@ -0,0 +1,3 @@
+MD5 5addde05fe291bee974443b531a3a3e5 pbbuttonsd-0.8.1.tar.gz 589630
+RMD160 2f1dc0bc8b67cbb310f06df932a5dfcf26d35551 pbbuttonsd-0.8.1.tar.gz 589630
+SHA256 b391fd98ed263f355d7e7addc6566959e986627c87dcfdaa1da15310ad70bffa pbbuttonsd-0.8.1.tar.gz 589630
diff --git a/app-laptop/pbbuttonsd/files/pmcs.patch b/app-laptop/pbbuttonsd/files/pmcs.patch
new file mode 100644
index 000000000000..21dd23831a36
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/pmcs.patch
@@ -0,0 +1,21 @@
+--- scripts/pmcs-config.bak 2007-07-07 13:52:25.000000000 -0400
++++ scripts/pmcs-config 2007-07-18 21:29:27.000000000 -0400
+@@ -11,15 +11,15 @@
+
+ # Section for power policy 'performance'
+ performance_HDTimeOff=0 # hdsetup - timeout in seconds
+-performance_HDOptions="-p" # hdsetup
++performance_HDOptions="" # hdsetup
+ performance_LaptopMode="stop" # bdflush
+
+ # Section for power policy 'custom'
+ custom_HDTimeOff=60 # hdsetup - timeout in seconds
+-custom_HDOptions="-p" # hdsetup
++custom_HDOptions="" # hdsetup
+ custom_LaptopMode="start" # bdflush
+
+ # Section for power policy 'powersave'
+ powersave_HDTimeOff=60 # hdsetup - timeout in seconds
+-powersave_HDOptions="-p" # hdsetup
++powersave_HDOptions="" # hdsetup
+ powersave_LaptopMode="start" # bdflush
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r1.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..a1c9185a6791
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r1.ebuild,v 1.1 2007/07/19 01:39:04 josejx Exp $
+
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="Handles power management and special keys on laptops."
+HOMEPAGE="http://pbbuttons.berlios.de"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="acpi alsa debug doc ibam macbook oss"
+
+DEPEND="macbook? ( sys-libs/libsmbios )
+ >=dev-libs/glib-2.6
+ doc? ( app-doc/doxygen )"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
+ >=dev-libs/glib-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/pmcs.patch
+ eautoconf
+}
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if use macbook; then
+ laptop=macbook
+ elif use x86 || use amd64; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ # Default to PowerBook
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_enable debug) \
+ $(use_with doc doxygen_docs) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with ibam) \
+ || die "Sorry, failed to configure pbbuttonsd"
+
+ # Thanks to Stefan Bruda for this workaround
+ # Using -j1 fixes a parallel build issue with the docs
+ if use doc; then
+ emake -j1 || die "Sorry, failed to compile pbbuttonsd"
+ else
+ emake || die "Sorry, failed to compile pbbuttonsd"
+ fi
+}
+
+src_install() {
+ dodir /etc/power
+ use ibam && dodir /var/lib/ibam
+ make DESTDIR=${D} install || die "failed to install"
+ newinitd ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+ use doc && dohtml -r doc/*
+}
+
+pkg_postinst() {
+ if [ -e /etc/pbbuttonsd.conf ]; then
+ ewarn "The pbbuttonsd.cnf file replaces /etc/pbuttonsd.conf with a new"
+ ewarn "file (/etc/pbbuttonsd.conf) and a new format. Please check the"
+ ewarn "manual page with 'man pbbuttonsd.cnf' for details."
+ ewarn
+ fi
+
+ if use macbook; then
+ ewarn "Macbook and Macbook Pro users should make sure to have applesmc"
+ ewarn "loaded before starting pbbuttonsdm otherwise auto-adjustments"
+ ewarn "will not work and pbbuttonsd may segfault."
+ fi
+
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work. SysV IPC is also required."
+ ewarn
+ ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
+ ewarn "input from one user. You can set the userallowed option in"
+ ewarn "/etc/pbbuttonsd.cnf to limit access."
+ ewarn
+
+ if use ibam; then
+ elog "To properly initialize the IBaM battery database, you will"
+ elog "need to perform a full discharge/charge cycle. For more"
+ elog "details, please see the pbbuttonsd man page."
+ elog
+ fi
+}